{"id":"CVE-2002-1159","aliases":["DEBIAN-CVE-2002-1159","DSA-224","EUVD-2002-1146","GHSA-v63f-8cmr-47h8"],"status":"published","title":"Canna 3.6 and earlier does not properly validate requests, which allows remote attackers to cause...","description":"Canna 3.6 and earlier does not properly validate requests, which allows remote attackers to cause a denial of service or information leak.","severity":{"version":"2.0","score":6.4,"vector":"AV:N/AC:L/Au:N/C:P/I:N/A:P","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.01898,"percentile":0.79782,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"published":"2002-12-18T05:00:00Z","modified":"2026-10-22T23:47:23Z","fixes":[{"ecosystem":"Debian:12","package":"canna","fixed_in":["3.6p1-1"],"sources":["osv"]},{"ecosystem":"Debian:13","package":"canna","fixed_in":["3.6p1-1"],"sources":["osv"]},{"ecosystem":"Debian:14","package":"canna","fixed_in":["3.6p1-1"],"sources":["osv"]}],"affected":[{"source":"osv","ecosystem":"Debian:12","package":"canna","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"3.6p1-1"}]}]},{"source":"osv","ecosystem":"Debian:13","package":"canna","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"3.6p1-1"}]}]},{"source":"osv","ecosystem":"Debian:14","package":"canna","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"3.6p1-1"}]}]},{"source":"osv","ecosystem":"Debian:3.0","package":"canna","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"3.5b2-46.2"}]}],"bundled":2}],"products":[{"vendor":"canna","product":"canna"}],"references":[{"url":"http://www.debian.org/security/2003/dsa-224","tags":["vendor-advisory","x_refsource_DEBIAN","x_transferred","Patch","Vendor Advisory","advisory","fix"]},{"url":"http://www.securityfocus.com/bid/6354","tags":["vdb-entry","x_refsource_BID","x_transferred","web"]},{"url":"http://www.redhat.com/support/errata/RHSA-2002-246.html","tags":["vendor-advisory","x_refsource_REDHAT","x_transferred","Patch","Vendor Advisory","advisory","fix"]},{"url":"http://www.redhat.com/support/errata/RHSA-2002-261.html","tags":["vendor-advisory","x_refsource_REDHAT","x_transferred","web"]},{"url":"https://exchange.xforce.ibmcloud.com/vulnerabilities/10832","tags":["vdb-entry","x_refsource_XF","x_transferred","web"]},{"url":"http://www.redhat.com/support/errata/RHSA-2003-115.html","tags":["vendor-advisory","x_refsource_REDHAT","x_transferred","web"]},{"url":"http://canna.sourceforge.jp/sec/Canna-2002-01.txt","tags":["x_refsource_CONFIRM","x_transferred","web"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2002-1159"},{"url":"https://github.com/advisories/GHSA-v63f-8cmr-47h8"},{"url":"https://security-tracker.debian.org/tracker/CVE-2002-1159","tags":["advisory"]}],"sources":{"cve":[{"id":"CVE-2002-1159","description":"Canna 3.6 and earlier does not properly validate requests, which allows remote attackers to cause a denial of service or information leak.","status":"published","published":"2004-09-01T04:00:00Z","modified":"2024-08-08T03:19:27.403Z","updated_at":"2026-11-02T14:33:54.641433Z"}],"euvd":[{"id":"EUVD-2002-1146","description":"Canna 3.6 and earlier does not properly validate requests, which allows remote attackers to cause a denial of service or information leak.","status":"published","published":"2004-09-01T04:00:00Z","modified":"2024-08-08T03:19:27Z","updated_at":"2026-11-03T01:14:57.2805Z"}],"ghsa":[{"id":"GHSA-v63f-8cmr-47h8","title":"Canna 3.6 and earlier does not properly validate requests, which allows remote attackers to cause...","description":"Canna 3.6 and earlier does not properly validate requests, which allows remote attackers to cause a denial of service or information leak.","status":"published","published":"2022-04-30T18:20:39Z","modified":"2023-01-30T05:05:42Z","updated_at":"2026-11-02T14:47:20.238022Z"}],"nvd":[{"id":"CVE-2002-1159","description":"Canna 3.6 and earlier does not properly validate requests, which allows remote attackers to cause a denial of service or information leak.","status":"published","published":"2002-12-18T05:00:00Z","modified":"2026-06-16T21:58:51.49Z","cvss":[{"version":"2.0","score":6.4,"vector":"AV:N/AC:L/Au:N/C:P/I:N/A:P","level":"medium","assessor":"primary"}],"updated_at":"2026-11-02T14:00:43.239725Z"}],"osv":[{"id":"CVE-2002-1159","description":"Canna 3.6 and earlier does not properly validate requests, which allows remote attackers to cause a denial of service or information leak.","status":"published","published":"2002-12-18T05:00:00Z","modified":"2026-04-10T03:34:16.35956Z","updated_at":"2026-11-02T15:43:55.998148Z"},{"id":"DEBIAN-CVE-2002-1159","description":"Canna 3.6 and earlier does not properly validate requests, which allows remote attackers to cause a denial of service or information leak.","status":"published","published":"2002-12-18T05:00:00Z","modified":"2026-10-22T23:47:23.993191656Z","updated_at":"2026-11-02T15:45:22.248131Z"},{"id":"DSA-224","title":"canna - buffer overflow and more","status":"published","published":"2003-01-08T00:00:00Z","modified":"2026-03-09T01:18:07.309944Z","updated_at":"2026-11-02T15:46:15.108335Z"}]}}
