{"id":"CVE-2008-0460","aliases":["DEBIAN-CVE-2008-0460","EUVD-2008-0470","GHSA-q3v9-vqch-gc4g"],"status":"published","title":"Cross-site scripting (XSS) vulnerability in api.php in (1) MediaWiki 1.11 through 1.11.0rc1, 1.10...","description":"Cross-site scripting (XSS) vulnerability in api.php in (1) MediaWiki 1.11 through 1.11.0rc1, 1.10 through 1.10.2, 1.9 through 1.9.4, and 1.8; and (2) the BotQuery extension for MediaWiki 1.7 and earlier; when Internet Explorer is used, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.","severity":{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.14562,"percentile":0.96667,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-79"],"published":"2008-01-25T15:00:00Z","modified":"2026-10-23T17:47:38Z","fixes":[{"ecosystem":"Debian:12","package":"mediawiki","fixed_in":["1:1.11.1-1"],"sources":["osv"]},{"ecosystem":"Debian:13","package":"mediawiki","fixed_in":["1:1.11.1-1"],"sources":["osv"]},{"ecosystem":"Debian:14","package":"mediawiki","fixed_in":["1:1.11.1-1"],"sources":["osv"]}],"affected":[{"source":"osv","ecosystem":"Debian:12","package":"mediawiki","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:1.11.1-1"}]}]},{"source":"osv","ecosystem":"Debian:13","package":"mediawiki","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:1.11.1-1"}]}]},{"source":"osv","ecosystem":"Debian:14","package":"mediawiki","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:1.11.1-1"}]}]}],"products":[{"vendor":"mediawiki","product":"mediawiki"},{"vendor":"mediawiki","product":"mediawiki_botquery_ext"},{"vendor":"microsoft","product":"internet_explorer"}],"references":[{"url":"https://exchange.xforce.ibmcloud.com/vulnerabilities/39901","tags":["vdb-entry","x_refsource_XF","x_transferred","web"]},{"url":"https://www.redhat.com/archives/fedora-package-announce/2008-March/msg00189.html","tags":["vendor-advisory","x_refsource_FEDORA","x_transferred","web"]},{"url":"http://www.vupen.com/english/advisories/2008/0280","tags":["vdb-entry","x_refsource_VUPEN","x_transferred","advisory"]},{"url":"https://www.redhat.com/archives/fedora-package-announce/2008-March/msg00147.html","tags":["vendor-advisory","x_refsource_FEDORA","x_transferred","web"]},{"url":"http://www.securityfocus.com/bid/28137","tags":["vdb-entry","x_refsource_BID","x_transferred","web"]},{"url":"http://lists.wikimedia.org/pipermail/mediawiki-announce/2008-January/000068.html","tags":["mailing-list","x_refsource_MLIST","x_transferred","web"]},{"url":"http://secunia.com/advisories/28629","tags":["third-party-advisory","x_refsource_SECUNIA","x_transferred","Vendor Advisory","advisory"]},{"url":"http://secunia.com/advisories/29266","tags":["third-party-advisory","x_refsource_SECUNIA","x_transferred","advisory"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2008-0460"},{"url":"https://github.com/advisories/GHSA-q3v9-vqch-gc4g"},{"url":"https://security-tracker.debian.org/tracker/CVE-2008-0460","tags":["advisory"]}],"sources":{"cve":[{"id":"CVE-2008-0460","description":"Cross-site scripting (XSS) vulnerability in api.php in (1) MediaWiki 1.11 through 1.11.0rc1, 1.10 through 1.10.2, 1.9 through 1.9.4, and 1.8; and (2) the BotQuery extension for MediaWiki 1.7 and earlier; when Internet Explorer is used, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.","status":"published","published":"2008-01-25T15:00:00Z","modified":"2024-08-07T07:46:54.584Z","updated_at":"2026-11-02T14:34:48.505097Z"}],"euvd":[{"id":"EUVD-2008-0470","description":"Cross-site scripting (XSS) vulnerability in api.php in (1) MediaWiki 1.11 through 1.11.0rc1, 1.10 through 1.10.2, 1.9 through 1.9.4, and 1.8; and (2) the BotQuery extension for MediaWiki 1.7 and earlier; when Internet Explorer is used, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.","status":"published","published":"2008-01-25T15:00:00Z","modified":"2024-08-07T07:46:54Z","updated_at":"2026-11-03T01:39:05.878106Z"}],"ghsa":[{"id":"GHSA-q3v9-vqch-gc4g","title":"Cross-site scripting (XSS) vulnerability in api.php in (1) MediaWiki 1.11 through 1.11.0rc1, 1.10...","description":"Cross-site scripting (XSS) vulnerability in api.php in (1) MediaWiki 1.11 through 1.11.0rc1, 1.10 through 1.10.2, 1.9 through 1.9.4, and 1.8; and (2) the BotQuery extension for MediaWiki 1.7 and earlier; when Internet Explorer is used, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.","status":"published","published":"2022-05-01T23:30:32Z","modified":"2023-01-31T05:05:10Z","cwes":["CWE-79"],"updated_at":"2026-11-02T14:48:48.170956Z"}],"nvd":[{"id":"CVE-2008-0460","description":"Cross-site scripting (XSS) vulnerability in api.php in (1) MediaWiki 1.11 through 1.11.0rc1, 1.10 through 1.10.2, 1.9 through 1.9.4, and 1.8; and (2) the BotQuery extension for MediaWiki 1.7 and earlier; when Internet Explorer is used, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.","status":"published","published":"2008-01-25T16:00:00Z","modified":"2026-06-16T22:49:41.103Z","cvss":[{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:01:24.89535Z"}],"osv":[{"id":"CVE-2008-0460","description":"Cross-site scripting (XSS) vulnerability in api.php in (1) MediaWiki 1.11 through 1.11.0rc1, 1.10 through 1.10.2, 1.9 through 1.9.4, and 1.8; and (2) the BotQuery extension for MediaWiki 1.7 and earlier; when Internet Explorer is used, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.","status":"published","published":"2008-01-25T16:00:00Z","modified":"2026-04-10T03:39:36.23811Z","updated_at":"2026-11-02T15:43:57.178433Z"},{"id":"DEBIAN-CVE-2008-0460","description":"Cross-site scripting (XSS) vulnerability in api.php in (1) MediaWiki 1.11 through 1.11.0rc1, 1.10 through 1.10.2, 1.9 through 1.9.4, and 1.8; and (2) the BotQuery extension for MediaWiki 1.7 and earlier; when Internet Explorer is used, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.","status":"published","published":"2008-01-25T16:00:00Z","modified":"2026-10-23T17:47:38.787348406Z","updated_at":"2026-11-02T15:45:23.411908Z"}]}}
