{"id":"CVE-2008-2025","aliases":["EUVD-2022-5553","GHSA-wcgx-2hvx-5cwr"],"status":"published","title":"Apache Struts Cross-site Scripting vulnerability","description":"Cross-site scripting (XSS) vulnerability in Apache Struts before 1.2.9-162.31.1 on SUSE Linux Enterprise (SLE) 11, before 1.2.9-108.2 on SUSE openSUSE 10.3, before 1.2.9-198.2 on SUSE openSUSE 11.0, and before 1.2.9-162.163.2 on SUSE openSUSE 11.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors related to \"insufficient quoting of parameters.\"","severity":{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.07911,"percentile":0.94753,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-79"],"published":"2009-04-09T15:00:00Z","modified":"2026-06-16T22:52:57Z","fixes":[{"ecosystem":"Maven","package":"struts:struts","fixed_in":["1.2.9-162.31.1"],"sources":["ghsa","osv"]}],"affected":[{"source":"ghsa","ecosystem":"Maven","package":"struts:struts","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1.2.9-162.31.1"}]}]},{"source":"osv","ecosystem":"Maven","package":"struts:struts","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1.2.9-162.31.1"}]}],"versions":["1.0.2","1.1","1.1-b2-20021124","1.1-b3","1.1-beta-2","1.1-rc1","1.1-rc2","1.2.2","1.2.4","1.2.7","1.2.8","1.2.9"]}],"products":[{"vendor":"apache","product":"struts"}],"references":[{"url":"http://secunia.com/advisories/34567","tags":["third-party-advisory","x_refsource_SECUNIA","x_transferred"]},{"url":"http://download.opensuse.org/update/10.3-test/repodata/patch-struts-5872.xml","tags":["x_refsource_CONFIRM","x_transferred","Patch","web"]},{"url":"http://secunia.com/advisories/34642","tags":["third-party-advisory","x_refsource_SECUNIA","x_transferred"]},{"url":"http://support.novell.com/security/cve/CVE-2008-2025.html","tags":["x_refsource_CONFIRM","x_transferred","web"]},{"url":"http://osvdb.org/53380","tags":["vdb-entry","x_refsource_OSVDB","x_transferred"]},{"url":"http://lists.opensuse.org/opensuse-security-announce/2009-04/msg00003.html","tags":["vendor-advisory","x_refsource_SUSE","x_transferred","web"]},{"url":"https://launchpad.net/bugs/cve/2008-2025","tags":["x_refsource_MISC","x_transferred","web"]},{"url":"https://bugzilla.novell.com/show_bug.cgi?id=385273","tags":["x_refsource_MISC","x_transferred","web"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2008-2025","tags":["advisory"]},{"url":"https://web.archive.org/web/20090410082732/http://secunia.com/advisories/34642","tags":["web"]},{"url":"https://web.archive.org/web/20090411051126/http://secunia.com/advisories/34567","tags":["web"]},{"url":"https://github.com/advisories/GHSA-wcgx-2hvx-5cwr"},{"url":"https://github.com/apache/struts","tags":["package"]}],"sources":{"cve":[{"id":"CVE-2008-2025","description":"Cross-site scripting (XSS) vulnerability in Apache Struts before 1.2.9-162.31.1 on SUSE Linux Enterprise (SLE) 11, before 1.2.9-108.2 on SUSE openSUSE 10.3, before 1.2.9-198.2 on SUSE openSUSE 11.0, and before 1.2.9-162.163.2 on SUSE openSUSE 11.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors related to \"insufficient quoting of parameters.\"","status":"published","published":"2009-04-09T15:00:00Z","modified":"2024-08-07T08:41:00.257Z","updated_at":"2026-11-02T14:34:44.675398Z"}],"euvd":[{"id":"EUVD-2022-5553","description":"Cross-site scripting (XSS) vulnerability in Apache Struts before 1.2.9-162.31.1 on SUSE Linux Enterprise (SLE) 11, before 1.2.9-108.2 on SUSE openSUSE 10.3, before 1.2.9-198.2 on SUSE openSUSE 11.0, and before 1.2.9-162.163.2 on SUSE openSUSE 11.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors related to \"insufficient quoting of parameters.\"","status":"published","published":"2009-04-09T15:00:00Z","modified":"2024-08-07T08:41:00Z","updated_at":"2026-11-03T01:38:58.693341Z"}],"ghsa":[{"id":"GHSA-wcgx-2hvx-5cwr","title":"Apache Struts Cross-site Scripting vulnerability","description":"Cross-site scripting (XSS) vulnerability in Apache Struts before 1.2.9-162.31.1 on SUSE Linux Enterprise (SLE) 11, before 1.2.9-108.2 on SUSE openSUSE 10.3, before 1.2.9-198.2 on SUSE openSUSE 11.0, and before 1.2.9-162.163.2 on SUSE openSUSE 11.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors related to \"insufficient quoting of parameters.\"","status":"published","published":"2022-05-01T23:46:00Z","modified":"2024-02-09T16:02:16Z","cwes":["CWE-79"],"updated_at":"2026-11-02T14:37:36.777238Z"}],"nvd":[{"id":"CVE-2008-2025","description":"Cross-site scripting (XSS) vulnerability in Apache Struts before 1.2.9-162.31.1 on SUSE Linux Enterprise (SLE) 11, before 1.2.9-108.2 on SUSE openSUSE 10.3, before 1.2.9-198.2 on SUSE openSUSE 11.0, and before 1.2.9-162.163.2 on SUSE openSUSE 11.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors related to \"insufficient quoting of parameters.\"","status":"published","published":"2009-04-09T15:08:35.483Z","modified":"2026-06-16T22:52:57.583Z","cvss":[{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:01:31.451035Z"}],"osv":[{"id":"GHSA-wcgx-2hvx-5cwr","title":"Apache Struts Cross-site Scripting vulnerability","description":"Cross-site scripting (XSS) vulnerability in Apache Struts before 1.2.9-162.31.1 on SUSE Linux Enterprise (SLE) 11, before 1.2.9-108.2 on SUSE openSUSE 10.3, before 1.2.9-198.2 on SUSE openSUSE 11.0, and before 1.2.9-162.163.2 on SUSE openSUSE 11.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors related to \"insufficient quoting of parameters.\"","status":"published","published":"2022-05-01T23:46:00Z","modified":"2024-12-05T05:35:08.394103Z","cwes":["CWE-79"],"updated_at":"2026-11-02T15:46:58.401149Z"}]}}
