{"id":"CVE-2008-5250","aliases":["DEBIAN-CVE-2008-5250","DSA-1901-1","DTSA-186-1","EUVD-2008-5227","GHSA-46r5-999x-h9xr"],"status":"published","title":"Cross-site scripting (XSS) vulnerability in MediaWiki before 1.6.11, 1.12.x before 1.12.2, and 1...","description":"Cross-site scripting (XSS) vulnerability in MediaWiki before 1.6.11, 1.12.x before 1.12.2, and 1.13.x before 1.13.3, when Internet Explorer is used and uploads are enabled, or an SVG scripting browser is used and SVG uploads are enabled, allows remote authenticated users to inject arbitrary web script or HTML by editing a wiki page.","severity":{"version":"2.0","score":3.5,"vector":"AV:N/AC:M/Au:S/C:N/I:P/A:N","level":"low","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-08","score":0.01066,"percentile":0.64986,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-79"],"published":"2008-12-19T17:00:00Z","modified":"2026-10-23T17:47:36Z","fixes":[{"ecosystem":"Debian:12","package":"mediawiki","fixed_in":["1:1.13.3-1"],"sources":["osv"]},{"ecosystem":"Debian:13","package":"mediawiki","fixed_in":["1:1.13.3-1"],"sources":["osv"]},{"ecosystem":"Debian:14","package":"mediawiki","fixed_in":["1:1.13.3-1"],"sources":["osv"]}],"affected":[{"source":"osv","ecosystem":"Debian:12","package":"mediawiki","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:1.13.3-1"}]}]},{"source":"osv","ecosystem":"Debian:13","package":"mediawiki","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:1.13.3-1"}]}]},{"source":"osv","ecosystem":"Debian:14","package":"mediawiki","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:1.13.3-1"}]}]},{"source":"osv","ecosystem":"Debian:4.0","package":"mediawiki1.7","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1.7.1-9etch1"}]}],"versions":["1.7.1-9etch0"],"bundled":4},{"source":"osv","ecosystem":"Debian:5.0","package":"mediawiki","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:1.12.0-2lenny2"}]}],"bundled":4}],"products":[{"vendor":"mediawiki","product":"mediawiki"}],"references":[{"url":"https://www.redhat.com/archives/fedora-package-announce/2008-December/msg01309.html","tags":["vendor-advisory","x_refsource_FEDORA","x_transferred","web"]},{"url":"http://www.debian.org/security/2009/dsa-1901","tags":["vendor-advisory","x_refsource_DEBIAN","x_transferred","advisory"]},{"url":"http://secunia.com/advisories/33133","tags":["third-party-advisory","x_refsource_SECUNIA","x_transferred","Patch","Vendor Advisory","advisory","fix"]},{"url":"http://lists.opensuse.org/opensuse-security-announce/2009-02/msg00002.html","tags":["vendor-advisory","x_refsource_SUSE","x_transferred","web"]},{"url":"http://lists.wikimedia.org/pipermail/mediawiki-announce/2008-December/000080.html","tags":["mailing-list","x_refsource_MLIST","x_transferred","Patch","Vendor Advisory","advisory","fix"]},{"url":"http://www.securityfocus.com/bid/32844","tags":["vdb-entry","x_refsource_BID","x_transferred","web"]},{"url":"https://www.redhat.com/archives/fedora-package-announce/2008-December/msg01256.html","tags":["vendor-advisory","x_refsource_FEDORA","x_transferred","web"]},{"url":"http://secunia.com/advisories/33349","tags":["third-party-advisory","x_refsource_SECUNIA","x_transferred","advisory"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2008-5250"},{"url":"https://github.com/advisories/GHSA-46r5-999x-h9xr"},{"url":"https://security-tracker.debian.org/tracker/CVE-2008-5250","tags":["advisory"]}],"sources":{"cve":[{"id":"CVE-2008-5250","description":"Cross-site scripting (XSS) vulnerability in MediaWiki before 1.6.11, 1.12.x before 1.12.2, and 1.13.x before 1.13.3, when Internet Explorer is used and uploads are enabled, or an SVG scripting browser is used and SVG uploads are enabled, allows remote authenticated users to inject arbitrary web script or HTML by editing a wiki page.","status":"published","published":"2008-12-19T17:00:00Z","modified":"2024-08-07T10:49:11.913Z","updated_at":"2026-11-02T14:34:44.297409Z"}],"euvd":[{"id":"EUVD-2008-5227","description":"Cross-site scripting (XSS) vulnerability in MediaWiki before 1.6.11, 1.12.x before 1.12.2, and 1.13.x before 1.13.3, when Internet Explorer is used and uploads are enabled, or an SVG scripting browser is used and SVG uploads are enabled, allows remote authenticated users to inject arbitrary web script or HTML by editing a wiki page.","status":"published","published":"2008-12-19T17:00:00Z","modified":"2024-08-07T10:49:11Z","updated_at":"2026-11-03T01:38:44.406504Z"}],"ghsa":[{"id":"GHSA-46r5-999x-h9xr","title":"Cross-site scripting (XSS) vulnerability in MediaWiki before 1.6.11, 1.12.x before 1.12.2, and 1...","description":"Cross-site scripting (XSS) vulnerability in MediaWiki before 1.6.11, 1.12.x before 1.12.2, and 1.13.x before 1.13.3, when Internet Explorer is used and uploads are enabled, or an SVG scripting browser is used and SVG uploads are enabled, allows remote authenticated users to inject arbitrary web script or HTML by editing a wiki page.","status":"published","published":"2022-05-17T05:51:55Z","modified":"2023-01-28T05:04:52Z","cwes":["CWE-79"],"updated_at":"2026-11-02T14:44:15.556193Z"}],"nvd":[{"id":"CVE-2008-5250","description":"Cross-site scripting (XSS) vulnerability in MediaWiki before 1.6.11, 1.12.x before 1.12.2, and 1.13.x before 1.13.3, when Internet Explorer is used and uploads are enabled, or an SVG scripting browser is used and SVG uploads are enabled, allows remote authenticated users to inject arbitrary web script or HTML by editing a wiki page.","status":"published","published":"2008-12-19T17:30:03.11Z","modified":"2026-06-16T22:59:34.707Z","cvss":[{"version":"2.0","score":3.5,"vector":"AV:N/AC:M/Au:S/C:N/I:P/A:N","level":"low","assessor":"primary"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:01:30.411919Z"}],"osv":[{"id":"CVE-2008-5250","description":"Cross-site scripting (XSS) vulnerability in MediaWiki before 1.6.11, 1.12.x before 1.12.2, and 1.13.x before 1.13.3, when Internet Explorer is used and uploads are enabled, or an SVG scripting browser is used and SVG uploads are enabled, allows remote authenticated users to inject arbitrary web script or HTML by editing a wiki page.","status":"published","published":"2008-12-19T17:30:03Z","modified":"2026-04-10T03:40:20.67067Z","updated_at":"2026-11-02T15:43:57.452479Z"},{"id":"DEBIAN-CVE-2008-5250","description":"Cross-site scripting (XSS) vulnerability in MediaWiki before 1.6.11, 1.12.x before 1.12.2, and 1.13.x before 1.13.3, when Internet Explorer is used and uploads are enabled, or an SVG scripting browser is used and SVG uploads are enabled, allows remote authenticated users to inject arbitrary web script or HTML by editing a wiki page.","status":"published","published":"2008-12-19T17:30:03.11Z","modified":"2026-10-23T17:47:36.056416748Z","updated_at":"2026-11-02T15:45:23.742363Z"},{"id":"DSA-1901-1","title":"mediawiki1.7 - several vulnerabilities","status":"published","published":"2009-10-05T00:00:00Z","modified":"2026-03-09T01:22:56.153336Z","updated_at":"2026-11-02T15:46:14.734124Z"},{"id":"DTSA-186-1","title":"mediawiki - several vulnerabilities","status":"published","published":"2009-01-25T00:00:00Z","modified":"2026-03-09T01:01:23.362332Z","updated_at":"2026-11-02T15:46:18.716547Z"}]}}
