{"id":"CVE-2008-5432","aliases":["DSA-1691-1","EUVD-2008-5409","GHSA-37mm-gc69-pw8r"],"status":"published","title":"Cross-site scripting (XSS) vulnerability in Moodle before 1.6.8, 1.7 before 1.7.6, 1.8 before 1.8...","description":"Cross-site scripting (XSS) vulnerability in Moodle before 1.6.8, 1.7 before 1.7.6, 1.8 before 1.8.7, and 1.9 before 1.9.3 allows remote attackers to inject arbitrary web script or HTML via a Wiki page name (aka page title).","severity":{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.01553,"percentile":0.75281,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":false},"cwes":["CWE-79"],"published":"2008-12-11T15:00:00Z","modified":"2026-06-16T22:59:58Z","affected":[{"source":"osv","ecosystem":"Debian:4.0","package":"moodle","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1.6.3-2+etch1"}]}],"versions":["1.6.3-2"],"bundled":9}],"products":[{"vendor":"moodle","product":"moodle"}],"references":[{"url":"http://lists.opensuse.org/opensuse-security-announce/2009-02/msg00000.html","tags":["vendor-advisory","x_refsource_SUSE","x_transferred"]},{"url":"http://www.securityfocus.com/bid/32714","tags":["vdb-entry","x_refsource_BID","x_transferred"]},{"url":"http://www.vupen.com/english/advisories/2008/3405","tags":["vdb-entry","x_refsource_VUPEN","x_transferred"]},{"url":"https://exchange.xforce.ibmcloud.com/vulnerabilities/47193","tags":["vdb-entry","x_refsource_XF","x_transferred"]},{"url":"http://secunia.com/advisories/33822","tags":["third-party-advisory","x_refsource_SECUNIA","x_transferred"]},{"url":"http://www.openwall.com/lists/oss-security/2008/12/09/4","tags":["mailing-list","x_refsource_MLIST","x_transferred"]},{"url":"http://www.debian.org/security/2008/dsa-1691","tags":["vendor-advisory","x_refsource_DEBIAN","x_transferred"]},{"url":"http://secunia.com/advisories/33079","tags":["third-party-advisory","x_refsource_SECUNIA","x_transferred"]},{"url":"http://moodle.org/mod/forum/discuss.php?d=108590","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2008-5432"},{"url":"https://github.com/advisories/GHSA-37mm-gc69-pw8r"}],"sources":{"cve":[{"id":"CVE-2008-5432","description":"Cross-site scripting (XSS) vulnerability in Moodle before 1.6.8, 1.7 before 1.7.6, 1.8 before 1.8.7, and 1.9 before 1.9.3 allows remote attackers to inject arbitrary web script or HTML via a Wiki page name (aka page title).","status":"published","published":"2008-12-11T15:00:00Z","modified":"2024-08-07T10:56:45.892Z","updated_at":"2026-11-02T14:34:43.943588Z"}],"euvd":[{"id":"EUVD-2008-5409","description":"Cross-site scripting (XSS) vulnerability in Moodle before 1.6.8, 1.7 before 1.7.6, 1.8 before 1.8.7, and 1.9 before 1.9.3 allows remote attackers to inject arbitrary web script or HTML via a Wiki page name (aka page title).","status":"published","published":"2008-12-11T15:00:00Z","modified":"2024-08-07T10:56:45Z","updated_at":"2026-11-03T01:38:43.439061Z"}],"ghsa":[{"id":"GHSA-37mm-gc69-pw8r","title":"Cross-site scripting (XSS) vulnerability in Moodle before 1.6.8, 1.7 before 1.7.6, 1.8 before 1.8...","description":"Cross-site scripting (XSS) vulnerability in Moodle before 1.6.8, 1.7 before 1.7.6, 1.8 before 1.8.7, and 1.9 before 1.9.3 allows remote attackers to inject arbitrary web script or HTML via a Wiki page name (aka page title).","status":"published","published":"2022-05-13T01:13:08Z","modified":"2023-02-01T05:03:54Z","cwes":["CWE-79"],"updated_at":"2026-11-02T14:50:06.799159Z"}],"nvd":[{"id":"CVE-2008-5432","description":"Cross-site scripting (XSS) vulnerability in Moodle before 1.6.8, 1.7 before 1.7.6, 1.8 before 1.8.7, and 1.9 before 1.9.3 allows remote attackers to inject arbitrary web script or HTML via a Wiki page name (aka page title).","status":"published","published":"2008-12-11T15:30:00.627Z","modified":"2026-06-16T22:59:58.003Z","cvss":[{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:01:30.411919Z"}],"osv":[{"id":"DSA-1691-1","title":"moodle - several vulnerabilities","status":"published","published":"2008-12-22T00:00:00Z","modified":"2026-03-09T01:01:40.529427Z","updated_at":"2026-11-02T15:46:14.734124Z"}]}}
