{"id":"CVE-2010-2958","aliases":["DEBIAN-CVE-2010-2958","EUVD-2010-2962","GHSA-frv8-xjcp-hrm2"],"status":"published","title":"phpMyAdmin Cross-site Scripting vulnerability","description":"Cross-site scripting (XSS) vulnerability in libraries/Error.class.php in phpMyAdmin 3.x before 3.3.6 allows remote attackers to inject arbitrary web script or HTML via vectors related to a PHP backtrace and error messages (aka debugging messages), a different vulnerability than CVE-2010-3056.","severity":{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-08","score":0.019,"percentile":0.79818,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-79"],"published":"2010-09-08T19:00:00Z","modified":"2026-10-23T17:47:48Z","fixes":[{"ecosystem":"Packagist","package":"phpmyadmin/phpmyadmin","fixed_in":["3.3.6"],"sources":["ghsa","osv"]},{"ecosystem":"Debian:12","package":"phpmyadmin","fixed_in":["4:3.3.6-1"],"sources":["osv"]},{"ecosystem":"Debian:13","package":"phpmyadmin","fixed_in":["4:3.3.6-1"],"sources":["osv"]},{"ecosystem":"Debian:14","package":"phpmyadmin","fixed_in":["4:3.3.6-1"],"sources":["osv"]}],"affected":[{"source":"ghsa","ecosystem":"Packagist","package":"phpmyadmin/phpmyadmin","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"3.0.0"},{"fixed":"3.3.6"}]}]},{"source":"osv","ecosystem":"Debian:12","package":"phpmyadmin","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"4:3.3.6-1"}]}]},{"source":"osv","ecosystem":"Debian:13","package":"phpmyadmin","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"4:3.3.6-1"}]}]},{"source":"osv","ecosystem":"Debian:14","package":"phpmyadmin","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"4:3.3.6-1"}]}]},{"source":"osv","ecosystem":"Packagist","package":"phpmyadmin/phpmyadmin","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"3.0.0"},{"fixed":"3.3.6"}]}]}],"products":[{"vendor":"phpmyadmin","product":"phpmyadmin"}],"references":[{"url":"http://secunia.com/advisories/41206","tags":["third-party-advisory","x_refsource_SECUNIA","x_transferred","Vendor Advisory","advisory"]},{"url":"http://www.openwall.com/lists/oss-security/2010/09/01/2","tags":["mailing-list","x_refsource_MLIST","x_transferred","web"]},{"url":"http://www.openwall.com/lists/oss-security/2010/09/01/3","tags":["mailing-list","x_refsource_MLIST","x_transferred","web"]},{"url":"http://www.phpmyadmin.net/home_page/security/PMASA-2010-6.php","tags":["x_refsource_CONFIRM","x_transferred","Patch","Vendor Advisory","advisory","fix","web"]},{"url":"http://www.vupen.com/english/advisories/2010/2242","tags":["vdb-entry","x_refsource_VUPEN","x_transferred","Patch","Vendor Advisory","advisory","fix"]},{"url":"http://phpmyadmin.git.sourceforge.net/git/gitweb.cgi?p=phpmyadmin/phpmyadmin%3Ba=commit%3Bh=133a77fac7d31a38703db2099a90c1b49de62e37","tags":["x_refsource_CONFIRM","x_transferred","web"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2010-2958","tags":["advisory"]},{"url":"http://phpmyadmin.git.sourceforge.net/git/gitweb.cgi?p=phpmyadmin/phpmyadmin;a=commit;h=133a77fac7d31a38703db2099a90c1b49de62e37","tags":["web"]},{"url":"https://github.com/advisories/GHSA-frv8-xjcp-hrm2"},{"url":"https://security-tracker.debian.org/tracker/CVE-2010-2958","tags":["advisory"]},{"url":"https://github.com/phpmyadmin/composer","tags":["package"]}],"sources":{"cve":[{"id":"CVE-2010-2958","description":"Cross-site scripting (XSS) vulnerability in libraries/Error.class.php in phpMyAdmin 3.x before 3.3.6 allows remote attackers to inject arbitrary web script or HTML via vectors related to a PHP backtrace and error messages (aka debugging messages), a different vulnerability than CVE-2010-3056.","status":"published","published":"2010-09-08T19:00:00Z","modified":"2024-08-07T02:55:46.503Z","updated_at":"2026-11-02T14:33:27.354104Z"}],"euvd":[{"id":"EUVD-2010-2962","description":"Cross-site scripting (XSS) vulnerability in libraries/Error.class.php in phpMyAdmin 3.x before 3.3.6 allows remote attackers to inject arbitrary web script or HTML via vectors related to a PHP backtrace and error messages (aka debugging messages), a different vulnerability than CVE-2010-3056.","status":"published","published":"2010-09-08T19:00:00Z","modified":"2024-08-07T02:55:46Z","updated_at":"2026-11-03T01:39:35.901913Z"}],"ghsa":[{"id":"GHSA-frv8-xjcp-hrm2","title":"phpMyAdmin Cross-site Scripting vulnerability","description":"Cross-site scripting (XSS) vulnerability in libraries/Error.class.php in phpMyAdmin 3.x before 3.3.6 allows remote attackers to inject arbitrary web script or HTML via vectors related to a PHP backtrace and error messages (aka debugging messages), a different vulnerability than CVE-2010-3056.","status":"published","published":"2022-05-17T05:48:25Z","modified":"2025-04-12T02:34:13Z","cvss":[{"version":"4.0","score":5.3,"vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","level":"medium"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:38:39.044439Z"}],"nvd":[{"id":"CVE-2010-2958","description":"Cross-site scripting (XSS) vulnerability in libraries/Error.class.php in phpMyAdmin 3.x before 3.3.6 allows remote attackers to inject arbitrary web script or HTML via vectors related to a PHP backtrace and error messages (aka debugging messages), a different vulnerability than CVE-2010-3056.","status":"published","published":"2010-09-08T20:00:03.59Z","modified":"2026-06-16T23:21:50.243Z","cvss":[{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:01:52.227027Z"}],"osv":[{"id":"GHSA-frv8-xjcp-hrm2","title":"phpMyAdmin Cross-site Scripting vulnerability","description":"Cross-site scripting (XSS) vulnerability in libraries/Error.class.php in phpMyAdmin 3.x before 3.3.6 allows remote attackers to inject arbitrary web script or HTML via vectors related to a PHP backtrace and error messages (aka debugging messages), a different vulnerability than CVE-2010-3056.","status":"published","published":"2022-05-17T05:48:25Z","modified":"2025-04-12T02:57:06.60862Z","cvss":[{"version":"4.0","score":5.3,"vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","level":"medium"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T15:46:46.760785Z"},{"id":"CVE-2010-2958","description":"Cross-site scripting (XSS) vulnerability in libraries/Error.class.php in phpMyAdmin 3.x before 3.3.6 allows remote attackers to inject arbitrary web script or HTML via vectors related to a PHP backtrace and error messages (aka debugging messages), a different vulnerability than CVE-2010-3056.","status":"published","published":"2010-09-08T20:00:03Z","modified":"2026-04-10T03:41:22.269657Z","updated_at":"2026-11-02T15:43:57.991581Z"},{"id":"DEBIAN-CVE-2010-2958","description":"Cross-site scripting (XSS) vulnerability in libraries/Error.class.php in phpMyAdmin 3.x before 3.3.6 allows remote attackers to inject arbitrary web script or HTML via vectors related to a PHP backtrace and error messages (aka debugging messages), a different vulnerability than CVE-2010-3056.","status":"published","published":"2010-09-08T20:00:03.59Z","modified":"2026-10-23T17:47:48.646888708Z","updated_at":"2026-11-02T15:45:24.316685Z"}]}}
