{"id":"CVE-2010-3685","aliases":["DSA-2113-1","EUVD-2010-3669","GHSA-qw6j-h2x2-j7fj"],"status":"published","title":"The OpenID module in Drupal 6.x before 6.18, and the OpenID module 5.x before 5.x-1.4 for Drupal,...","description":"The OpenID module in Drupal 6.x before 6.18, and the OpenID module 5.x before 5.x-1.4 for Drupal, violates the OpenID 2.0 protocol by not checking for reuse of openid.response_nonce values, which allows remote attackers to bypass authentication by leveraging an assertion from an OpenID provider.","severity":{"version":"2.0","score":5,"vector":"AV:N/AC:L/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.02372,"percentile":0.83936,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":false},"cwes":["CWE-287"],"published":"2010-09-20T00:00:00Z","modified":"2026-06-16T23:23:19Z","affected":[{"source":"osv","ecosystem":"Debian:5.0","package":"drupal6","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"6.6-3lenny6"}]}],"versions":["6.6-3","6.6-3lenny1","6.6-3lenny2","6.6-3lenny3","6.6-3lenny4","6.6-3lenny5"],"bundled":6}],"products":[{"vendor":"drupal","product":"drupal"},{"vendor":"peter_wolanin","product":"openid"}],"references":[{"url":"http://drupal.org/node/880480","tags":["x_refsource_CONFIRM","x_transferred","Patch","Vendor Advisory"]},{"url":"http://www.debian.org/security/2010/dsa-2113","tags":["vendor-advisory","x_refsource_DEBIAN","x_transferred"]},{"url":"http://marc.info/?l=oss-security\u0026m=128440896914512\u0026w=2","tags":["mailing-list","x_refsource_MLIST","x_transferred"]},{"url":"http://www.securityfocus.com/bid/42388","tags":["vdb-entry","x_refsource_BID","x_transferred"]},{"url":"http://drupal.org/node/880476","tags":["x_refsource_CONFIRM","x_transferred","Patch","Vendor Advisory"]},{"url":"http://marc.info/?l=oss-security\u0026m=128418560705305\u0026w=2","tags":["mailing-list","x_refsource_MLIST","x_transferred"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2010-3685"},{"url":"https://github.com/advisories/GHSA-qw6j-h2x2-j7fj"}],"sources":{"cve":[{"id":"CVE-2010-3685","description":"The OpenID module in Drupal 6.x before 6.18, and the OpenID module 5.x before 5.x-1.4 for Drupal, violates the OpenID 2.0 protocol by not checking for reuse of openid.response_nonce values, which allows remote attackers to bypass authentication by leveraging an assertion from an OpenID provider.","status":"published","published":"2010-09-29T16:00:00Z","modified":"2024-09-16T23:40:40.981Z","updated_at":"2026-11-02T14:33:27.739358Z"}],"euvd":[{"id":"EUVD-2010-3669","description":"The OpenID module in Drupal 6.x before 6.18, and the OpenID module 5.x before 5.x-1.4 for Drupal, violates the OpenID 2.0 protocol by not checking for reuse of openid.response_nonce values, which allows remote attackers to bypass authentication by leveraging an assertion from an OpenID provider.","status":"published","published":"2010-09-29T16:00:00Z","modified":"2024-09-16T23:40:40Z","updated_at":"2026-11-03T00:54:48.177577Z"}],"ghsa":[{"id":"GHSA-qw6j-h2x2-j7fj","title":"The OpenID module in Drupal 6.x before 6.18, and the OpenID module 5.x before 5.x-1.4 for Drupal,...","description":"The OpenID module in Drupal 6.x before 6.18, and the OpenID module 5.x before 5.x-1.4 for Drupal, violates the OpenID 2.0 protocol by not checking for reuse of openid.response_nonce values, which allows remote attackers to bypass authentication by leveraging an assertion from an OpenID provider.","status":"published","published":"2022-05-17T05:48:00Z","modified":"2023-01-28T05:04:25Z","cwes":["CWE-287"],"updated_at":"2026-11-02T14:44:10.41737Z"}],"nvd":[{"id":"CVE-2010-3685","description":"The OpenID module in Drupal 6.x before 6.18, and the OpenID module 5.x before 5.x-1.4 for Drupal, violates the OpenID 2.0 protocol by not checking for reuse of openid.response_nonce values, which allows remote attackers to bypass authentication by leveraging an assertion from an OpenID provider.","status":"published","published":"2010-09-29T17:00:05.79Z","modified":"2026-06-16T23:23:19.893Z","cvss":[{"version":"2.0","score":5,"vector":"AV:N/AC:L/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary"}],"cwes":["CWE-287"],"updated_at":"2026-11-02T14:01:52.227027Z"}],"osv":[{"id":"DSA-2113-1","title":"drupal6 - several vulnerabilities","status":"published","published":"2010-09-20T00:00:00Z","modified":"2026-03-09T01:19:35.95219Z","updated_at":"2026-11-02T15:46:15.108335Z"}]}}
