{"id":"CVE-2010-5294","aliases":["DEBIAN-CVE-2010-5294","EUVD-2010-5253","GHSA-3qv6-q4gp-2pm4"],"status":"published","title":"Multiple cross-site scripting (XSS) vulnerabilities in the request_filesystem_credentials...","description":"Multiple cross-site scripting (XSS) vulnerabilities in the request_filesystem_credentials function in wp-admin/includes/file.php in WordPress before 3.0.2 allow remote servers to inject arbitrary web script or HTML by providing a crafted error message for a (1) FTP or (2) SSH connection attempt.","severity":{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.01398,"percentile":0.726,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-79"],"published":"2014-01-21T01:00:00Z","modified":"2026-10-23T17:47:35Z","fixes":[{"ecosystem":"Debian:12","package":"wordpress","fixed_in":["3.0.2-1"],"sources":["osv"]},{"ecosystem":"Debian:13","package":"wordpress","fixed_in":["3.0.2-1"],"sources":["osv"]},{"ecosystem":"Debian:14","package":"wordpress","fixed_in":["3.0.2-1"],"sources":["osv"]}],"affected":[{"source":"osv","ecosystem":"Debian:12","package":"wordpress","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"3.0.2-1"}]}]},{"source":"osv","ecosystem":"Debian:13","package":"wordpress","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"3.0.2-1"}]}]},{"source":"osv","ecosystem":"Debian:14","package":"wordpress","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"3.0.2-1"}]}]}],"products":[{"vendor":"wordpress","product":"wordpress"}],"references":[{"url":"https://core.trac.wordpress.org/changeset/16367","tags":["x_refsource_CONFIRM","x_transferred","Exploit","Patch","evidence","fix"]},{"url":"http://codex.wordpress.org/Version_3.0.2","tags":["x_refsource_CONFIRM","x_transferred","Vendor Advisory","advisory"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2010-5294"},{"url":"https://github.com/advisories/GHSA-3qv6-q4gp-2pm4"},{"url":"https://security-tracker.debian.org/tracker/CVE-2010-5294","tags":["advisory"]}],"sources":{"cve":[{"id":"CVE-2010-5294","description":"Multiple cross-site scripting (XSS) vulnerabilities in the request_filesystem_credentials function in wp-admin/includes/file.php in WordPress before 3.0.2 allow remote servers to inject arbitrary web script or HTML by providing a crafted error message for a (1) FTP or (2) SSH connection attempt.","status":"published","published":"2014-01-21T01:00:00Z","modified":"2024-09-17T04:25:11.076Z","updated_at":"2026-11-02T14:33:26.665532Z"}],"euvd":[{"id":"EUVD-2010-5253","description":"Multiple cross-site scripting (XSS) vulnerabilities in the request_filesystem_credentials function in wp-admin/includes/file.php in WordPress before 3.0.2 allow remote servers to inject arbitrary web script or HTML by providing a crafted error message for a (1) FTP or (2) SSH connection attempt.","status":"published","published":"2014-01-21T01:00:00Z","modified":"2024-09-17T04:25:11Z","updated_at":"2026-11-03T00:28:23.116921Z"}],"ghsa":[{"id":"GHSA-3qv6-q4gp-2pm4","title":"Multiple cross-site scripting (XSS) vulnerabilities in the request_filesystem_credentials...","description":"Multiple cross-site scripting (XSS) vulnerabilities in the request_filesystem_credentials function in wp-admin/includes/file.php in WordPress before 3.0.2 allow remote servers to inject arbitrary web script or HTML by providing a crafted error message for a (1) FTP or (2) SSH connection attempt.","status":"published","published":"2022-05-17T04:54:15Z","modified":"2023-01-28T05:02:39Z","cwes":["CWE-79"],"updated_at":"2026-11-02T14:43:49.260703Z"}],"nvd":[{"id":"CVE-2010-5294","description":"Multiple cross-site scripting (XSS) vulnerabilities in the request_filesystem_credentials function in wp-admin/includes/file.php in WordPress before 3.0.2 allow remote servers to inject arbitrary web script or HTML by providing a crafted error message for a (1) FTP or (2) SSH connection attempt.","status":"published","published":"2014-01-21T01:55:03.217Z","modified":"2026-06-16T23:26:29.857Z","cvss":[{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:02:04.520133Z"}],"osv":[{"id":"CVE-2010-5294","description":"Multiple cross-site scripting (XSS) vulnerabilities in the request_filesystem_credentials function in wp-admin/includes/file.php in WordPress before 3.0.2 allow remote servers to inject arbitrary web script or HTML by providing a crafted error message for a (1) FTP or (2) SSH connection attempt.","status":"published","published":"2014-01-21T01:55:03Z","modified":"2026-04-10T03:41:35.619235Z","updated_at":"2026-11-02T15:43:57.991581Z"},{"id":"DEBIAN-CVE-2010-5294","description":"Multiple cross-site scripting (XSS) vulnerabilities in the request_filesystem_credentials function in wp-admin/includes/file.php in WordPress before 3.0.2 allow remote servers to inject arbitrary web script or HTML by providing a crafted error message for a (1) FTP or (2) SSH connection attempt.","status":"published","published":"2014-01-21T01:55:03.217Z","modified":"2026-10-23T17:47:35.672878968Z","updated_at":"2026-11-02T15:45:24.316685Z"}]}}
