{"id":"CVE-2011-1587","aliases":["DEBIAN-CVE-2011-1587","DSA-2366-1","EUVD-2011-1587","GHSA-28vc-7qpm-6gqr"],"status":"published","title":"Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or...","description":"Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html located before a ? (question mark) in a query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1578.","severity":{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.01711,"percentile":0.77504,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-79"],"published":"2011-04-27T00:00:00Z","modified":"2026-10-23T17:47:27Z","fixes":[{"ecosystem":"Debian:12","package":"mediawiki","fixed_in":["1:1.15.5-5"],"sources":["osv"]},{"ecosystem":"Debian:13","package":"mediawiki","fixed_in":["1:1.15.5-5"],"sources":["osv"]},{"ecosystem":"Debian:14","package":"mediawiki","fixed_in":["1:1.15.5-5"],"sources":["osv"]}],"affected":[{"source":"osv","ecosystem":"Debian:12","package":"mediawiki","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:1.15.5-5"}]}]},{"source":"osv","ecosystem":"Debian:13","package":"mediawiki","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:1.15.5-5"}]}]},{"source":"osv","ecosystem":"Debian:14","package":"mediawiki","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:1.15.5-5"}]}]},{"source":"osv","ecosystem":"Debian:6.0","package":"mediawiki","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:1.15.5-2squeeze2"}]}],"versions":["1:1.15.5-2","1:1.15.5-2squeeze1"],"bundled":6},{"source":"osv","ecosystem":"Debian:5.0","package":"mediawiki","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:1.12.0-2lenny9"}]}],"versions":["1:1.12.0-2lenny2","1:1.12.0-2lenny3","1:1.12.0-2lenny3~bpo40+1","1:1.12.0-2lenny4","1:1.12.0-2lenny5","1:1.12.0-2lenny6","1:1.12.0-2lenny7","1:1.12.0-2lenny8"],"bundled":6}],"products":[{"vendor":"mediawiki","product":"mediawiki"}],"references":[{"url":"http://openwall.com/lists/oss-security/2011/04/18/5","tags":["mailing-list","x_refsource_MLIST","x_transferred","Patch","fix"]},{"url":"http://www.debian.org/security/2011/dsa-2366","tags":["vendor-advisory","x_refsource_DEBIAN","x_transferred","advisory"]},{"url":"https://bugzilla.redhat.com/show_bug.cgi?id=696360","tags":["x_refsource_CONFIRM","x_transferred","Patch","fix"]},{"url":"http://lists.wikimedia.org/pipermail/mediawiki-announce/2011-April/000097.html","tags":["mailing-list","x_refsource_MLIST","x_transferred","Patch","Vendor Advisory","advisory","fix"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2011-1587"},{"url":"https://github.com/advisories/GHSA-28vc-7qpm-6gqr"},{"url":"https://security-tracker.debian.org/tracker/CVE-2011-1587","tags":["advisory"]}],"sources":{"cve":[{"id":"CVE-2011-1587","description":"Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html located before a ? (question mark) in a query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1578.","status":"published","published":"2011-04-27T00:00:00Z","modified":"2024-08-06T22:28:41.933Z","updated_at":"2026-11-02T14:35:38.711857Z"}],"euvd":[{"id":"EUVD-2011-1587","description":"Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html located before a ? (question mark) in a query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1578.","status":"published","published":"2011-04-27T00:00:00Z","modified":"2024-08-06T22:28:41Z","updated_at":"2026-11-03T01:55:56.243798Z"}],"ghsa":[{"id":"GHSA-28vc-7qpm-6gqr","title":"Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or...","description":"Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html located before a ? (question mark) in a query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1578.","status":"published","published":"2022-05-13T01:07:55Z","modified":"2023-02-01T05:03:15Z","cwes":["CWE-79"],"updated_at":"2026-11-02T14:50:02.204531Z"}],"nvd":[{"id":"CVE-2011-1587","description":"Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html located before a ? (question mark) in a query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1578.","status":"published","published":"2011-04-27T00:55:04.773Z","modified":"2026-06-16T23:29:41.16Z","cvss":[{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:02:07.221228Z"}],"osv":[{"id":"CVE-2011-1587","description":"Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html located before a ? (question mark) in a query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1578.","status":"published","published":"2011-04-27T00:55:04Z","modified":"2026-04-10T03:41:44.300915Z","updated_at":"2026-11-02T15:43:58.279353Z"},{"id":"DEBIAN-CVE-2011-1587","description":"Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html located before a ? (question mark) in a query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1578.","status":"published","published":"2011-04-27T00:55:04.773Z","modified":"2026-10-23T17:47:27.051006509Z","updated_at":"2026-11-02T15:45:24.612044Z"},{"id":"DSA-2366-1","title":"mediawiki - multiple","status":"published","published":"2011-12-18T00:00:00Z","modified":"2026-03-09T01:18:37.854939Z","updated_at":"2026-11-02T15:46:15.108335Z"}]}}
