{"id":"CVE-2011-2082","aliases":["DEBIAN-CVE-2011-2082","DSA-2480-1","EUVD-2011-2076","GHSA-pxc3-v4rj-fc78"],"status":"published","title":"The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4...","description":"The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4.0.6 does not update the password-hash algorithm for disabled user accounts, which makes it easier for context-dependent attackers to determine cleartext passwords, and possibly use these passwords after accounts are re-enabled, via a brute-force attack on the database.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-0009.","severity":{"version":"2.0","score":5,"vector":"AV:N/AC:L/Au:N/C:P/I:N/A:N","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-06","score":0.01178,"percentile":0.6779,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-255"],"published":"2012-05-24T00:00:00Z","modified":"2026-10-23T17:47:36Z","fixes":[{"ecosystem":"Debian:12","package":"request-tracker4","fixed_in":["4.0.5-3"],"sources":["osv"]}],"affected":[{"source":"osv","ecosystem":"Debian:12","package":"request-tracker4","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"4.0.5-3"}]}]},{"source":"osv","ecosystem":"Debian:6.0","package":"request-tracker3.8","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"3.8.8-7+squeeze2"}]}],"versions":["3.8.8-7","3.8.8-7+squeeze1","3.8.8-7+squeeze1~bpo50+1"],"bundled":7}],"products":[{"vendor":"bestpractical","product":"rt"}],"references":[{"url":"http://lists.bestpractical.com/pipermail/rt-announce/2012-May/000203.html","tags":["mailing-list","x_refsource_MLIST","x_transferred","Patch","fix"]},{"url":"http://secunia.com/advisories/49259","tags":["third-party-advisory","x_refsource_SECUNIA","x_transferred","advisory"]},{"url":"http://lists.bestpractical.com/pipermail/rt-announce/2012-May/000204.html","tags":["mailing-list","x_refsource_MLIST","x_transferred","Patch","fix"]},{"url":"http://lists.bestpractical.com/pipermail/rt-announce/2012-May/000202.html","tags":["mailing-list","x_refsource_MLIST","x_transferred","web"]},{"url":"http://www.securityfocus.com/bid/53660","tags":["vdb-entry","x_refsource_BID","x_transferred","web"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2011-2082"},{"url":"https://github.com/advisories/GHSA-pxc3-v4rj-fc78"},{"url":"https://security-tracker.debian.org/tracker/CVE-2011-2082","tags":["advisory"]}],"sources":{"cve":[{"id":"CVE-2011-2082","description":"The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4.0.6 does not update the password-hash algorithm for disabled user accounts, which makes it easier for context-dependent attackers to determine cleartext passwords, and possibly use these passwords after accounts are re-enabled, via a brute-force attack on the database.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-0009.","status":"published","published":"2012-06-04T19:00:00Z","modified":"2024-08-06T22:46:01.129Z","updated_at":"2026-11-02T14:35:36.603688Z"}],"euvd":[{"id":"EUVD-2011-2076","description":"The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4.0.6 does not update the password-hash algorithm for disabled user accounts, which makes it easier for context-dependent attackers to determine cleartext passwords, and possibly use these passwords after accounts are re-enabled, via a brute-force attack on the database.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-0009.","status":"published","published":"2012-06-04T19:00:00Z","modified":"2024-08-06T22:46:01Z","updated_at":"2026-11-03T01:55:54.133107Z"}],"ghsa":[{"id":"GHSA-pxc3-v4rj-fc78","title":"The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4...","description":"The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4.0.6 does not update the password-hash algorithm for disabled user accounts, which makes it easier for context-dependent attackers to determine cleartext passwords, and possibly use these passwords after accounts are re-enabled, via a brute-force attack on the database.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-0009.","status":"published","published":"2022-05-17T05:20:53Z","modified":"2023-01-28T05:03:49Z","updated_at":"2026-11-02T14:44:03.106355Z"}],"nvd":[{"id":"CVE-2011-2082","description":"The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4.0.6 does not update the password-hash algorithm for disabled user accounts, which makes it easier for context-dependent attackers to determine cleartext passwords, and possibly use these passwords after accounts are re-enabled, via a brute-force attack on the database.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-0009.","status":"published","published":"2012-06-04T19:55:01.54Z","modified":"2026-06-16T23:30:39.613Z","cvss":[{"version":"2.0","score":5,"vector":"AV:N/AC:L/Au:N/C:P/I:N/A:N","level":"medium","assessor":"primary"}],"cwes":["CWE-255"],"updated_at":"2026-11-02T14:02:12.272092Z"}],"osv":[{"id":"CVE-2011-2082","description":"The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4.0.6 does not update the password-hash algorithm for disabled user accounts, which makes it easier for context-dependent attackers to determine cleartext passwords, and possibly use these passwords after accounts are re-enabled, via a brute-force attack on the database.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-0009.","status":"published","published":"2012-06-04T19:55:01Z","modified":"2026-04-10T03:41:49.687387Z","updated_at":"2026-11-02T15:43:58.279353Z"},{"id":"DEBIAN-CVE-2011-2082","description":"The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4.0.6 does not update the password-hash algorithm for disabled user accounts, which makes it easier for context-dependent attackers to determine cleartext passwords, and possibly use these passwords after accounts are re-enabled, via a brute-force attack on the database.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-0009.","status":"published","published":"2012-06-04T19:55:01.54Z","modified":"2026-10-23T17:47:36.973937415Z","updated_at":"2026-11-02T15:45:24.612044Z"},{"id":"DSA-2480-1","title":"request-tracker3.8 - several","status":"published","published":"2012-05-24T00:00:00Z","modified":"2026-03-09T01:17:50.923357Z","updated_at":"2026-11-02T15:46:15.489951Z"}]}}
