{"id":"CVE-2011-3628","aliases":["DEBIAN-CVE-2011-3628","EUVD-2011-3587","GHSA-9hgw-rg97-xh38"],"status":"published","title":"Untrusted search path vulnerability in pam_motd (aka the MOTD module) in libpam-modules before 1...","description":"Untrusted search path vulnerability in pam_motd (aka the MOTD module) in libpam-modules before 1.1.3-2ubuntu2.1 on Ubuntu 11.10, before 1.1.2-2ubuntu8.4 on Ubuntu 11.04, before 1.1.1-4ubuntu2.4 on Ubuntu 10.10, before 1.1.1-2ubuntu5.4 on Ubuntu 10.04 LTS, and before 0.99.7.1-5ubuntu6.5 on Ubuntu 8.04 LTS, when using certain configurations such as \"session optional pam_motd.so\", allows local users to gain privileges by modifying the PATH environment variable to reference a malicious command, as demonstrated via uname.","severity":{"version":"2.0","score":6.9,"vector":"AV:L/AC:M/Au:N/C:C/I:C/A:C","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.00383,"percentile":0.32549,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"published":"2014-04-15T18:00:00Z","modified":"2026-10-23T17:47:44Z","fixes":[{"ecosystem":"Debian:12","package":"pam","fixed_in":["1.1.3-7"],"sources":["osv"]},{"ecosystem":"Debian:13","package":"pam","fixed_in":["1.1.3-7"],"sources":["osv"]},{"ecosystem":"Debian:14","package":"pam","fixed_in":["1.1.3-7"],"sources":["osv"]}],"affected":[{"source":"osv","ecosystem":"Debian:12","package":"pam","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1.1.3-7"}]}]},{"source":"osv","ecosystem":"Debian:13","package":"pam","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1.1.3-7"}]}]},{"source":"osv","ecosystem":"Debian:14","package":"pam","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1.1.3-7"}]}]}],"products":[{"vendor":"canonical","product":"libpam-modules"},{"vendor":"canonical","product":"ubuntu_linux"}],"references":[{"url":"https://bugs.launchpad.net/ubuntu/%2Bsource/pam/%2Bbug/610125","tags":["x_refsource_CONFIRM","x_transferred","web"]},{"url":"http://www.ubuntu.com/usn/USN-1237-1","tags":["vendor-advisory","x_refsource_UBUNTU","x_transferred","Vendor Advisory","advisory"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2011-3628"},{"url":"https://github.com/advisories/GHSA-9hgw-rg97-xh38"},{"url":"https://security-tracker.debian.org/tracker/CVE-2011-3628","tags":["advisory"]}],"sources":{"cve":[{"id":"CVE-2011-3628","description":"Untrusted search path vulnerability in pam_motd (aka the MOTD module) in libpam-modules before 1.1.3-2ubuntu2.1 on Ubuntu 11.10, before 1.1.2-2ubuntu8.4 on Ubuntu 11.04, before 1.1.1-4ubuntu2.4 on Ubuntu 10.10, before 1.1.1-2ubuntu5.4 on Ubuntu 10.04 LTS, and before 0.99.7.1-5ubuntu6.5 on Ubuntu 8.04 LTS, when using certain configurations such as \"session optional pam_motd.so\", allows local users to gain privileges by modifying the PATH environment variable to reference a malicious command, as demonstrated via uname.","status":"published","published":"2014-04-15T18:00:00Z","modified":"2024-08-06T23:37:48.655Z","updated_at":"2026-11-02T14:35:37.671707Z"}],"euvd":[{"id":"EUVD-2011-3587","description":"Untrusted search path vulnerability in pam_motd (aka the MOTD module) in libpam-modules before 1.1.3-2ubuntu2.1 on Ubuntu 11.10, before 1.1.2-2ubuntu8.4 on Ubuntu 11.04, before 1.1.1-4ubuntu2.4 on Ubuntu 10.10, before 1.1.1-2ubuntu5.4 on Ubuntu 10.04 LTS, and before 0.99.7.1-5ubuntu6.5 on Ubuntu 8.04 LTS, when using certain configurations such as \"session optional pam_motd.so\", allows local users to gain privileges by modifying the PATH environment variable to reference a malicious command, as demonstrated via uname.","status":"published","published":"2014-04-15T18:00:00Z","modified":"2024-08-06T23:37:48Z","updated_at":"2026-11-03T01:39:50.860626Z"}],"ghsa":[{"id":"GHSA-9hgw-rg97-xh38","title":"Untrusted search path vulnerability in pam_motd (aka the MOTD module) in libpam-modules before 1...","description":"Untrusted search path vulnerability in pam_motd (aka the MOTD module) in libpam-modules before 1.1.3-2ubuntu2.1 on Ubuntu 11.10, before 1.1.2-2ubuntu8.4 on Ubuntu 11.04, before 1.1.1-4ubuntu2.4 on Ubuntu 10.10, before 1.1.1-2ubuntu5.4 on Ubuntu 10.04 LTS, and before 0.99.7.1-5ubuntu6.5 on Ubuntu 8.04 LTS, when using certain configurations such as \"session optional pam_motd.so\", allows local users to gain privileges by modifying the PATH environment variable to reference a malicious command, as demonstrated via uname.","status":"published","published":"2022-05-17T04:46:59Z","modified":"2023-01-28T05:02:32Z","updated_at":"2026-11-02T14:43:47.783485Z"}],"nvd":[{"id":"CVE-2011-3628","description":"Untrusted search path vulnerability in pam_motd (aka the MOTD module) in libpam-modules before 1.1.3-2ubuntu2.1 on Ubuntu 11.10, before 1.1.2-2ubuntu8.4 on Ubuntu 11.04, before 1.1.1-4ubuntu2.4 on Ubuntu 10.10, before 1.1.1-2ubuntu5.4 on Ubuntu 10.04 LTS, and before 0.99.7.1-5ubuntu6.5 on Ubuntu 8.04 LTS, when using certain configurations such as \"session optional pam_motd.so\", allows local users to gain privileges by modifying the PATH environment variable to reference a malicious command, as demonstrated via uname.","status":"published","published":"2014-04-15T23:55:07.297Z","modified":"2026-06-16T23:33:39.273Z","cvss":[{"version":"2.0","score":6.9,"vector":"AV:L/AC:M/Au:N/C:C/I:C/A:C","level":"medium","assessor":"primary"}],"updated_at":"2026-11-02T14:02:12.639283Z"}],"osv":[{"id":"CVE-2011-3628","description":"Untrusted search path vulnerability in pam_motd (aka the MOTD module) in libpam-modules before 1.1.3-2ubuntu2.1 on Ubuntu 11.10, before 1.1.2-2ubuntu8.4 on Ubuntu 11.04, before 1.1.1-4ubuntu2.4 on Ubuntu 10.10, before 1.1.1-2ubuntu5.4 on Ubuntu 10.04 LTS, and before 0.99.7.1-5ubuntu6.5 on Ubuntu 8.04 LTS, when using certain configurations such as \"session optional pam_motd.so\", allows local users to gain privileges by modifying the PATH environment variable to reference a malicious command, as demonstrated via uname.","status":"published","published":"2014-04-15T23:55:07Z","modified":"2026-04-10T03:42:00.658995Z","updated_at":"2026-11-02T15:43:58.279353Z"},{"id":"DEBIAN-CVE-2011-3628","description":"Untrusted search path vulnerability in pam_motd (aka the MOTD module) in libpam-modules before 1.1.3-2ubuntu2.1 on Ubuntu 11.10, before 1.1.2-2ubuntu8.4 on Ubuntu 11.04, before 1.1.1-4ubuntu2.4 on Ubuntu 10.10, before 1.1.1-2ubuntu5.4 on Ubuntu 10.04 LTS, and before 0.99.7.1-5ubuntu6.5 on Ubuntu 8.04 LTS, when using certain configurations such as \"session optional pam_motd.so\", allows local users to gain privileges by modifying the PATH environment variable to reference a malicious command, as demonstrated via uname.","status":"published","published":"2014-04-15T23:55:07.297Z","modified":"2026-10-23T17:47:44.158270916Z","updated_at":"2026-11-02T15:45:24.612044Z"}]}}
