{"id":"CVE-2011-4306","aliases":["DSA-2338-1","EUVD-2022-5120","GHSA-r729-mx2r-j26j"],"status":"published","title":"Moodle XSS Vulnerability","description":"Cross-site scripting (XSS) vulnerability in course/editsection.html in Moodle 1.9.x before 1.9.14 allows remote authenticated users to inject arbitrary web script or HTML via crafted data.","severity":{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.01832,"percentile":0.7902,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-79"],"published":"2011-11-07T00:00:00Z","modified":"2026-06-16T23:34:44Z","fixes":[{"ecosystem":"Packagist","package":"moodle/moodle","fixed_in":["1.9.14"],"sources":["ghsa","osv"]}],"affected":[{"source":"ghsa","ecosystem":"Packagist","package":"moodle/moodle","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1.9.14"}]}]},{"source":"osv","ecosystem":"Debian:6.0","package":"moodle","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1.9.9.dfsg2-2.1+squeeze2"}]}],"versions":["1.9.9.dfsg2-2.1","1.9.9.dfsg2-2.1+squeeze1"],"bundled":5},{"source":"osv","ecosystem":"Packagist","package":"moodle/moodle","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1.9.14"}]}]}],"products":[{"vendor":"moodle","product":"moodle"}],"references":[{"url":"http://git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=4a2acd8c7e6c869d5fd5aa686e6e0a3f20c97f15","tags":["x_refsource_CONFIRM","x_transferred","web"]},{"url":"http://moodle.org/mod/forum/discuss.php?d=188319","tags":["x_refsource_CONFIRM","x_transferred","Vendor Advisory","web"]},{"url":"https://bugzilla.redhat.com/show_bug.cgi?id=747444","tags":["x_refsource_CONFIRM","x_transferred","web"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2011-4306","tags":["advisory"]},{"url":"http://git.moodle.org/gw?p=moodle.git;a=commit;h=4a2acd8c7e6c869d5fd5aa686e6e0a3f20c97f15","tags":["web"]},{"url":"https://github.com/moodle/moodle/commit/4a2acd8c7e6c869d5fd5aa686e6e0a3f20c97f15","tags":["web"]},{"url":"https://github.com/advisories/GHSA-r729-mx2r-j26j"}],"sources":{"cve":[{"id":"CVE-2011-4306","description":"Cross-site scripting (XSS) vulnerability in course/editsection.html in Moodle 1.9.x before 1.9.14 allows remote authenticated users to inject arbitrary web script or HTML via crafted data.","status":"published","published":"2012-07-11T10:00:00Z","modified":"2024-08-07T00:01:51.587Z","updated_at":"2026-11-02T14:35:37.989579Z"}],"euvd":[{"id":"EUVD-2022-5120","description":"Cross-site scripting (XSS) vulnerability in course/editsection.html in Moodle 1.9.x before 1.9.14 allows remote authenticated users to inject arbitrary web script or HTML via crafted data.","status":"published","published":"2012-07-11T10:00:00Z","modified":"2024-08-07T00:01:51Z","updated_at":"2026-11-03T01:39:48.961231Z"}],"ghsa":[{"id":"GHSA-r729-mx2r-j26j","title":"Moodle XSS Vulnerability","description":"Cross-site scripting (XSS) vulnerability in `course/editsection.html` in Moodle 1.9.x before 1.9.14 allows remote authenticated users to inject arbitrary web script or HTML via crafted data.","status":"published","published":"2022-05-13T01:13:11Z","modified":"2024-01-17T15:44:26Z","cwes":["CWE-79"],"updated_at":"2026-11-02T14:37:31.550603Z"}],"nvd":[{"id":"CVE-2011-4306","description":"Cross-site scripting (XSS) vulnerability in course/editsection.html in Moodle 1.9.x before 1.9.14 allows remote authenticated users to inject arbitrary web script or HTML via crafted data.","status":"published","published":"2012-07-11T10:26:11.157Z","modified":"2026-06-16T23:34:44.403Z","cvss":[{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:02:12.272092Z"}],"osv":[{"id":"DSA-2338-1","title":"moodle - several","status":"published","published":"2011-11-07T00:00:00Z","modified":"2026-03-09T01:22:18.007046Z","updated_at":"2026-11-02T15:46:15.108335Z"},{"id":"GHSA-r729-mx2r-j26j","title":"Moodle XSS Vulnerability","description":"Cross-site scripting (XSS) vulnerability in `course/editsection.html` in Moodle 1.9.x before 1.9.14 allows remote authenticated users to inject arbitrary web script or HTML via crafted data.","status":"published","published":"2022-05-13T01:13:11Z","modified":"2024-01-17T16:26:38.364684Z","cwes":["CWE-79"],"updated_at":"2026-11-02T15:46:55.480549Z"}]}}
