{"id":"CVE-2012-4422","aliases":["DEBIAN-CVE-2012-4422","EUVD-2012-4357","GHSA-r8hm-p65m-rc9p"],"status":"published","title":"wp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not...","description":"wp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not check for network-administrator privileges before performing a network-wide activation of an installed plugin, which might allow remote authenticated users to make unintended plugin changes by leveraging the Administrator role.","severity":{"version":"2.0","score":3.5,"vector":"AV:N/AC:M/Au:S/C:N/I:P/A:N","level":"low","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-08","score":0.01675,"percentile":0.77014,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-264"],"published":"2012-09-14T19:00:00Z","modified":"2026-10-23T17:47:50Z","fixes":[{"ecosystem":"Debian:12","package":"wordpress","fixed_in":["3.4.2+dfsg-1"],"sources":["osv"]},{"ecosystem":"Debian:13","package":"wordpress","fixed_in":["3.4.2+dfsg-1"],"sources":["osv"]},{"ecosystem":"Debian:14","package":"wordpress","fixed_in":["3.4.2+dfsg-1"],"sources":["osv"]}],"affected":[{"source":"osv","ecosystem":"Debian:12","package":"wordpress","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"3.4.2+dfsg-1"}]}]},{"source":"osv","ecosystem":"Debian:13","package":"wordpress","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"3.4.2+dfsg-1"}]}]},{"source":"osv","ecosystem":"Debian:14","package":"wordpress","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"3.4.2+dfsg-1"}]}]}],"products":[{"vendor":"wordpress","product":"wordpress"}],"references":[{"url":"http://openwall.com/lists/oss-security/2012/09/13/4","tags":["mailing-list","x_refsource_MLIST","x_transferred","web"]},{"url":"http://core.trac.wordpress.org/changeset?old_path=%2Ftags%2F3.4.1\u0026old=21780\u0026new_path=%2Ftags%2F3.4.2\u0026new=21780#file42","tags":["x_refsource_CONFIRM","x_transferred","Exploit","Patch","evidence","fix"]},{"url":"http://codex.wordpress.org/Version_3.4.2","tags":["x_refsource_CONFIRM","x_transferred","web"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2012-4422"},{"url":"https://github.com/advisories/GHSA-r8hm-p65m-rc9p"},{"url":"https://security-tracker.debian.org/tracker/CVE-2012-4422","tags":["advisory"]}],"sources":{"cve":[{"id":"CVE-2012-4422","description":"wp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not check for network-administrator privileges before performing a network-wide activation of an installed plugin, which might allow remote authenticated users to make unintended plugin changes by leveraging the Administrator role.","status":"published","published":"2012-09-14T19:00:00Z","modified":"2024-09-16T21:02:26.279Z","updated_at":"2026-11-02T14:34:51.937988Z"}],"euvd":[{"id":"EUVD-2012-4357","description":"wp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not check for network-administrator privileges before performing a network-wide activation of an installed plugin, which might allow remote authenticated users to make unintended plugin changes by leveraging the Administrator role.","status":"published","published":"2012-09-14T19:00:00Z","modified":"2024-09-16T21:02:26Z","updated_at":"2026-11-03T00:55:09.104839Z"}],"ghsa":[{"id":"GHSA-r8hm-p65m-rc9p","title":"wp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not...","description":"wp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not check for network-administrator privileges before performing a network-wide activation of an installed plugin, which might allow remote authenticated users to make unintended plugin changes by leveraging the Administrator role.","status":"published","published":"2022-05-17T05:22:20Z","modified":"2023-01-28T05:03:37Z","updated_at":"2026-11-02T14:44:00.703043Z"}],"nvd":[{"id":"CVE-2012-4422","description":"wp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not check for network-administrator privileges before performing a network-wide activation of an installed plugin, which might allow remote authenticated users to make unintended plugin changes by leveraging the Administrator role.","status":"published","published":"2012-09-14T19:55:01.823Z","modified":"2026-06-16T23:44:59.273Z","cvss":[{"version":"2.0","score":3.5,"vector":"AV:N/AC:M/Au:S/C:N/I:P/A:N","level":"low","assessor":"primary"}],"cwes":["CWE-264"],"updated_at":"2026-11-02T14:02:15.643902Z"}],"osv":[{"id":"CVE-2012-4422","description":"wp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not check for network-administrator privileges before performing a network-wide activation of an installed plugin, which might allow remote authenticated users to make unintended plugin changes by leveraging the Administrator role.","status":"published","published":"2012-09-14T19:55:01Z","modified":"2026-04-10T03:42:27.979852Z","updated_at":"2026-11-02T15:43:58.537032Z"},{"id":"DEBIAN-CVE-2012-4422","description":"wp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not check for network-administrator privileges before performing a network-wide activation of an installed plugin, which might allow remote authenticated users to make unintended plugin changes by leveraging the Administrator role.","status":"published","published":"2012-09-14T19:55:01.823Z","modified":"2026-10-23T17:47:50.624345586Z","updated_at":"2026-11-02T15:45:25.218101Z"}]}}
