{"id":"CVE-2013-4341","aliases":["EUVD-2013-4227","GHSA-8wf8-rc66-c638","MGASA-2013-0280","UBUNTU-CVE-2013-4341"],"status":"published","title":"Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.2.11, 2.3.x before 2.3.9,...","description":"Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.2.11, 2.3.x before 2.3.9, 2.4.x before 2.4.6, and 2.5.x before 2.5.2 allow remote attackers to inject arbitrary web script or HTML via a crafted blog link within an RSS feed.","severity":{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.21862,"percentile":0.97661,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":true,"fix_available":false},"cwes":["CWE-79"],"published":"2013-09-16T10:00:00Z","modified":"2026-06-16T23:57:03Z","exploits":[{"source":"exploitdb","id":"EDB-28174","title":"Moodle 2.3.8/2.4.5 - Multiple Vulnerabilities","type":"webapps","platform":"php","date":"2013-09-09","url":"https://www.exploit-db.com/exploits/28174"},{"source":"metasploit","id":"exploit/multi/http/moodle_spelling_binary_rce","title":"Moodle Authenticated Spelling Binary RCE","type":"exploit","platform":"Linux,Unix","date":"2013-10-30","verified":true,"url":"https://www.rapid7.com/db/modules/exploit/multi/http/moodle_spelling_binary_rce"}],"affected":[{"source":"osv","ecosystem":"Mageia:3","package":"moodle","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"2.4.6-1.mga3"}]}],"bundled":2}],"products":[{"vendor":"moodle","product":"moodle"}],"references":[{"url":"http://git.moodle.org/gw?p=moodle.git\u0026a=search\u0026h=HEAD\u0026st=commit\u0026s=MDL-41623","tags":["x_refsource_CONFIRM","x_transferred","Vendor Advisory","report"]},{"url":"https://moodle.org/mod/forum/discuss.php?d=238399","tags":["x_refsource_CONFIRM","x_transferred","Vendor Advisory","web","report"]},{"url":"http://packetstormsecurity.com/files/164479/Moodle-Authenticated-Spelling-Binary-Remote-Code-Execution.html","tags":["x_refsource_MISC","x_transferred","Exploit","Third Party Advisory","VDB Entry"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2013-4341"},{"url":"https://github.com/advisories/GHSA-8wf8-rc66-c638"},{"url":"https://advisories.mageia.org/MGASA-2013-0280.html","tags":["advisory"]},{"url":"https://moodle.org/mod/forum/discuss.php?d=238396","tags":["web"]},{"url":"http://docs.moodle.org/dev/Moodle_2.4.6_release_notes","tags":["web"]},{"url":"https://moodle.org/mod/forum/discuss.php?d=237413","tags":["web"]},{"url":"https://bugs.mageia.org/show_bug.cgi?id=11212","tags":["report"]},{"url":"https://ubuntu.com/security/CVE-2013-4341","tags":["report"]},{"url":"https://www.cve.org/CVERecord?id=CVE-2013-4341","tags":["report"]}],"sources":{"cve":[{"id":"CVE-2013-4341","description":"Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.2.11, 2.3.x before 2.3.9, 2.4.x before 2.4.6, and 2.5.x before 2.5.2 allow remote attackers to inject arbitrary web script or HTML via a crafted blog link within an RSS feed.","status":"published","published":"2013-09-16T10:00:00Z","modified":"2024-08-06T16:38:01.995Z","updated_at":"2026-11-02T14:34:58.193873Z"}],"euvd":[{"id":"EUVD-2013-4227","description":"Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.2.11, 2.3.x before 2.3.9, 2.4.x before 2.4.6, and 2.5.x before 2.5.2 allow remote attackers to inject arbitrary web script or HTML via a crafted blog link within an RSS feed.","status":"published","published":"2013-09-16T10:00:00Z","modified":"2024-08-06T16:38:01Z","updated_at":"2026-11-03T01:56:32.187151Z"}],"ghsa":[{"id":"GHSA-8wf8-rc66-c638","title":"Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.2.11, 2.3.x before 2.3.9,...","description":"Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.2.11, 2.3.x before 2.3.9, 2.4.x before 2.4.6, and 2.5.x before 2.5.2 allow remote attackers to inject arbitrary web script or HTML via a crafted blog link within an RSS feed.","status":"published","published":"2022-05-03T00:01:27Z","modified":"2023-02-01T05:00:56Z","cwes":["CWE-79"],"updated_at":"2026-11-02T14:49:37.776792Z"}],"nvd":[{"id":"CVE-2013-4341","description":"Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.2.11, 2.3.x before 2.3.9, 2.4.x before 2.4.6, and 2.5.x before 2.5.2 allow remote attackers to inject arbitrary web script or HTML via a crafted blog link within an RSS feed.","status":"published","published":"2013-09-16T13:02:48.083Z","modified":"2026-06-16T23:57:03.48Z","cvss":[{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:02:35.248411Z"}],"osv":[{"id":"MGASA-2013-0280","title":"Updated moodle package fixes multiple security vulnerabilities","description":"Updated moodle package fixes security vulnerabilities:\n\nNull characters were allowed in query strings in Moodle before 2.4.6, which\ncaused sql statements to terminate and fail, potentially allowing sql\ninjection in Moodle's SQL Server driver (CVE-2013-4313).\n\nLinks to external blogs were not being adequately cleaned in Moodle before\n2.4.6, potentially allowing for XSS attacks (CVE-2013-4341).\n","status":"published","published":"2013-09-19T09:33:27Z","modified":"2026-04-16T06:24:10.483260471Z","updated_at":"2026-11-02T15:49:39.121227Z"},{"id":"UBUNTU-CVE-2013-4341","description":"Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.2.11, 2.3.x before 2.3.9, 2.4.x before 2.4.6, and 2.5.x before 2.5.2 allow remote attackers to inject arbitrary web script or HTML via a crafted blog link within an RSS feed.","status":"withdrawn","published":"2013-09-16T13:02:00Z","modified":"2025-07-16T07:17:08.775057Z","updated_at":"2026-11-02T15:54:07.421078Z"}]}}
