{"id":"CVE-2013-7035","aliases":["GHSA-g53w-52xc-2j85"],"status":"published","title":"Cross-Site Scripting in react","description":"Affected versions of `react` are vulnerable to Cross-Site Scripting (XSS). The package fails to properly sanitize input used to create keys. This may allow attackers to execute arbitrary JavaScript if a key is generated from user input.\n\n\n## Recommendation\n\nIf you are using `react` 0.5.x, upgrade to version 0.5.2 or later.\nIf you are using `react` 0.4.x, upgrade to version 0.4.2 or later.","severity":{"version":"3.1","score":6.5,"vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","level":"medium","from":"ghsa"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-79"],"published":"2020-09-04T16:52:57Z","modified":"2023-11-08T03:57:27Z","fixes":[{"ecosystem":"npm","package":"react","fixed_in":["0.4.2","0.5.2"],"sources":["ghsa","osv"]}],"affected":[{"source":"ghsa","ecosystem":"npm","package":"react","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0.4.0"},{"fixed":"0.4.2"}]}]},{"source":"ghsa","ecosystem":"npm","package":"react","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0.5.0"},{"fixed":"0.5.2"}]}]},{"source":"osv","ecosystem":"npm","package":"react","ranges":[{"type":"SEMVER","events":[{"introduced":"0.4.0"},{"fixed":"0.4.2"}]}]},{"source":"osv","ecosystem":"npm","package":"react","ranges":[{"type":"SEMVER","events":[{"introduced":"0.5.0"},{"fixed":"0.5.2"}]}]}],"references":[{"url":"https://reactjs.org/blog/2013/12/18/react-v0.5.2-v0.4.2.html","tags":["web"]},{"url":"https://snyk.io/vuln/npm:react:20131217","tags":["web"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2013-7035","tags":["advisory"]},{"url":"https://github.com/facebook/react/commit/393a889aaceb761f058b09a701f889fa8f8b4e64","tags":["web"]},{"url":"https://github.com/facebook/react/commit/94a9a3e752fe089ab23f3a90c26d20d46d62ab10","tags":["web"]},{"url":"https://github.com/advisories/GHSA-g53w-52xc-2j85"},{"url":"https://github.com/facebook/react","tags":["package"]}],"sources":{"ghsa":[{"id":"GHSA-g53w-52xc-2j85","title":"Cross-Site Scripting in react","description":"Affected versions of `react` are vulnerable to Cross-Site Scripting (XSS). The package fails to properly sanitize input used to create keys. This may allow attackers to execute arbitrary JavaScript if a key is generated from user input.\n\n\n## Recommendation\n\nIf you are using `react` 0.5.x, upgrade to version 0.5.2 or later.\nIf you are using `react` 0.4.x, upgrade to version 0.4.2 or later.","status":"published","published":"2020-09-04T16:52:57Z","modified":"2023-05-22T18:28:20Z","cvss":[{"version":"3.1","score":6.5,"vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","level":"medium"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:36:53.103029Z"}],"osv":[{"id":"GHSA-g53w-52xc-2j85","title":"Cross-Site Scripting in react","description":"Affected versions of `react` are vulnerable to Cross-Site Scripting (XSS). The package fails to properly sanitize input used to create keys. This may allow attackers to execute arbitrary JavaScript if a key is generated from user input.\n\n\n## Recommendation\n\nIf you are using `react` 0.5.x, upgrade to version 0.5.2 or later.\nIf you are using `react` 0.4.x, upgrade to version 0.4.2 or later.","status":"published","published":"2020-09-04T16:52:57Z","modified":"2023-11-08T03:57:27.158332Z","cvss":[{"version":"3.1","score":6.5,"vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","level":"medium"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T15:46:47.119724Z"}]}}
