{"id":"CVE-2014-7192","aliases":["EUVD-2017-0167","GHSA-5726-g6r9-5f22","UBUNTU-CVE-2014-7192"],"status":"published","title":"Potential for Script Injection in syntax-error","description":"Eval injection vulnerability in index.js in the syntax-error package before 1.1.1 for Node.js 0.10.x, as used in IBM Rational Application Developer and other products, allows remote attackers to execute arbitrary code via a crafted file.","severity":{"version":"2.0","score":10,"vector":"AV:N/AC:L/Au:N/C:C/I:C/A:C","level":"high","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-08","score":0.13048,"percentile":0.9637,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":true,"fix_available":true},"cwes":["CWE-94"],"published":"2014-12-11T11:00:00Z","modified":"2026-06-17T00:14:32Z","exploits":[{"source":"exploitdb","id":"EDB-34090","title":"Node Browserify 4.2.0 - Remote Code Execution","type":"dos","platform":"multiple","date":"2014-07-16","url":"https://www.exploit-db.com/exploits/34090"}],"fixes":[{"ecosystem":"npm","package":"syntax-error","fixed_in":["1.1.1"],"sources":["ghsa","osv"]}],"affected":[{"source":"ghsa","ecosystem":"npm","package":"syntax-error","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1.1.1"}]}]},{"source":"osv","ecosystem":"npm","package":"syntax-error","ranges":[{"type":"SEMVER","events":[{"introduced":"0"},{"fixed":"1.1.1"}]}]},{"source":"osv","ecosystem":"Ubuntu:16.04:LTS","package":"libv8-3.14","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"}]}],"versions":["3.14.5.8-5ubuntu2"]},{"source":"osv","ecosystem":"Ubuntu:18.04:LTS","package":"libv8-3.14","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"}]}],"versions":["3.14.5.8-11ubuntu1"]}],"products":[{"vendor":"joyent","product":"node.js"}],"references":[{"url":"https://github.com/substack/node-syntax-error/commit/9aa4e66eb90ec595d2dba55e6f9c2dd9a668b309","tags":["x_refsource_CONFIRM","x_transferred","Exploit","web"]},{"url":"https://nodesecurity.io/advisories/syntax-error-potential-script-injection","tags":["x_refsource_CONFIRM","x_transferred","Vendor Advisory"]},{"url":"https://exchange.xforce.ibmcloud.com/vulnerabilities/96728","tags":["vdb-entry","x_refsource_XF","x_transferred","web"]},{"url":"http://www-01.ibm.com/support/docview.wss?uid=swg21690815","tags":["x_refsource_CONFIRM","x_transferred","web"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2014-7192","tags":["advisory"]},{"url":"https://github.com/advisories/GHSA-5726-g6r9-5f22","tags":["advisory"]},{"url":"https://www.npmjs.com/advisories/37","tags":["web"]},{"url":"https://github.com/substack/node-browserify/blob/master/changelog.markdown#421","tags":["web"]},{"url":"https://github.com/substack/node-syntax-error","tags":["package"]},{"url":"https://ubuntu.com/security/CVE-2014-7192","tags":["report"]},{"url":"https://www.cve.org/CVERecord?id=CVE-2014-7192","tags":["report"]}],"sources":{"cve":[{"id":"CVE-2014-7192","description":"Eval injection vulnerability in index.js in the syntax-error package before 1.1.1 for Node.js 0.10.x, as used in IBM Rational Application Developer and other products, allows remote attackers to execute arbitrary code via a crafted file.","status":"published","published":"2014-12-11T11:00:00Z","modified":"2024-08-06T12:40:19.222Z","updated_at":"2026-11-02T14:33:46.631905Z"}],"euvd":[{"id":"EUVD-2017-0167","description":"Eval injection vulnerability in index.js in the syntax-error package before 1.1.1 for Node.js 0.10.x, as used in IBM Rational Application Developer and other products, allows remote attackers to execute arbitrary code via a crafted file.","status":"published","published":"2014-12-11T11:00:00Z","modified":"2024-08-06T12:40:19Z","updated_at":"2026-11-03T01:56:55.992719Z"}],"ghsa":[{"id":"GHSA-5726-g6r9-5f22","title":"Potential for Script Injection in syntax-error","description":"Versions of `syntax-error` prior to 1.1.1 are affected by a cross-site scripting vulnerability which may allow a malicious file to execute code when browserified. \n\n## Recommendation\n\nUpdate to version 1.1.1 or later.","status":"published","published":"2017-10-24T18:33:36Z","modified":"2023-01-09T05:02:44Z","cwes":["CWE-94"],"updated_at":"2026-11-02T14:36:03.768255Z"}],"nvd":[{"id":"CVE-2014-7192","description":"Eval injection vulnerability in index.js in the syntax-error package before 1.1.1 for Node.js 0.10.x, as used in IBM Rational Application Developer and other products, allows remote attackers to execute arbitrary code via a crafted file.","status":"published","published":"2014-12-11T11:59:11.633Z","modified":"2026-06-17T00:14:32.41Z","cvss":[{"version":"2.0","score":10,"vector":"AV:N/AC:L/Au:N/C:C/I:C/A:C","level":"high","assessor":"primary"}],"cwes":["CWE-94"],"updated_at":"2026-11-02T14:02:57.680258Z"}],"osv":[{"id":"GHSA-5726-g6r9-5f22","title":"Potential for Script Injection in syntax-error","description":"Versions of `syntax-error` prior to 1.1.1 are affected by a cross-site scripting vulnerability which may allow a malicious file to execute code when browserified. \n\n## Recommendation\n\nUpdate to version 1.1.1 or later.","status":"published","published":"2017-10-24T18:33:36Z","modified":"2023-11-08T03:57:44.554728Z","cwes":["CWE-94"],"updated_at":"2026-11-02T15:46:37.864461Z"},{"id":"UBUNTU-CVE-2014-7192","description":"Eval injection vulnerability in index.js in the syntax-error package before 1.1.1 for Node.js 0.10.x, as used in IBM Rational Application Developer and other products, allows remote attackers to execute arbitrary code via a crafted file.","status":"published","published":"2014-12-11T11:59:00Z","modified":"2026-04-22T09:48:55.291041Z","updated_at":"2026-11-02T15:54:09.378953Z"}]}}
