{"id":"CVE-2014-9276","aliases":["EUVD-2014-9101","GHSA-4rrq-7p7h-pfq3","MGASA-2014-0506"],"status":"published","title":"Cross-site request forgery (CSRF) vulnerability in the Special:ExpandedTemplates page in...","description":"Cross-site request forgery (CSRF) vulnerability in the Special:ExpandedTemplates page in MediaWiki before 1.19.22, 1.20.x through 1.22.x before 1.22.14, and 1.23.x before 1.23.7, when $wgRawHTML is set to true, allows remote attackers to hijack the authentication of users with edit permissions for requests that cross-site scripting (XSS) attacks via the wpInput parameter, which is not properly handled in the preview.","severity":{"version":"2.0","score":5.1,"vector":"AV:N/AC:H/Au:N/C:P/I:P/A:P","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-08","score":0.00669,"percentile":0.5223,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":false},"cwes":["CWE-352"],"published":"2014-12-03T19:27:32Z","modified":"2026-06-17T00:18:02Z","affected":[{"source":"osv","ecosystem":"Mageia:4","package":"mediawiki","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1.23.7-1.mga4"}]}],"bundled":2}],"products":[{"vendor":"mediawiki","product":"mediawiki"}],"references":[{"url":"http://securitytracker.com/id?1031301","tags":["vdb-entry","x_refsource_SECTRACK","x_transferred"]},{"url":"http://www.openwall.com/lists/oss-security/2014/12/03/9","tags":["mailing-list","x_refsource_MLIST","x_transferred"]},{"url":"http://www.openwall.com/lists/oss-security/2014/12/04/16","tags":["mailing-list","x_refsource_MLIST","x_transferred"]},{"url":"https://phabricator.wikimedia.org/T73111","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://lists.wikimedia.org/pipermail/mediawiki-announce/2014-November/000170.html","tags":["mailing-list","x_refsource_MLIST","x_transferred","Patch","Vendor Advisory","web"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2014-9276"},{"url":"https://github.com/advisories/GHSA-4rrq-7p7h-pfq3"},{"url":"https://advisories.mageia.org/MGASA-2014-0506.html","tags":["advisory"]},{"url":"https://bugs.mageia.org/show_bug.cgi?id=14711","tags":["report"]},{"url":"http://openwall.com/lists/oss-security/2014/12/04/16","tags":["web"]}],"sources":{"cve":[{"id":"CVE-2014-9276","description":"Cross-site request forgery (CSRF) vulnerability in the Special:ExpandedTemplates page in MediaWiki before 1.19.22, 1.20.x through 1.22.x before 1.22.14, and 1.23.x before 1.23.7, when $wgRawHTML is set to true, allows remote attackers to hijack the authentication of users with edit permissions for requests that cross-site scripting (XSS) attacks via the wpInput parameter, which is not properly handled in the preview.","status":"published","published":"2015-01-04T21:00:00Z","modified":"2024-08-06T13:40:24.98Z","updated_at":"2026-11-02T14:33:42.882687Z"}],"euvd":[{"id":"EUVD-2014-9101","description":"Cross-site request forgery (CSRF) vulnerability in the Special:ExpandedTemplates page in MediaWiki before 1.19.22, 1.20.x through 1.22.x before 1.22.14, and 1.23.x before 1.23.7, when $wgRawHTML is set to true, allows remote attackers to hijack the authentication of users with edit permissions for requests that cross-site scripting (XSS) attacks via the wpInput parameter, which is not properly handled in the preview.","status":"published","published":"2015-01-04T21:00:00Z","modified":"2024-08-06T13:40:24Z","updated_at":"2026-11-03T01:56:49.729528Z"}],"ghsa":[{"id":"GHSA-4rrq-7p7h-pfq3","title":"Cross-site request forgery (CSRF) vulnerability in the Special:ExpandedTemplates page in...","description":"Cross-site request forgery (CSRF) vulnerability in the Special:ExpandedTemplates page in MediaWiki before 1.19.22, 1.20.x through 1.22.x before 1.22.14, and 1.23.x before 1.23.7, when $wgRawHTML is set to true, allows remote attackers to hijack the authentication of users with edit permissions for requests that cross-site scripting (XSS) attacks via the wpInput parameter, which is not properly handled in the preview.","status":"published","published":"2022-05-17T04:18:00Z","modified":"2023-01-28T05:01:34Z","cwes":["CWE-352"],"updated_at":"2026-11-02T14:43:35.107967Z"}],"nvd":[{"id":"CVE-2014-9276","description":"Cross-site request forgery (CSRF) vulnerability in the Special:ExpandedTemplates page in MediaWiki before 1.19.22, 1.20.x through 1.22.x before 1.22.14, and 1.23.x before 1.23.7, when $wgRawHTML is set to true, allows remote attackers to hijack the authentication of users with edit permissions for requests that cross-site scripting (XSS) attacks via the wpInput parameter, which is not properly handled in the preview.","status":"published","published":"2015-01-04T21:59:01.353Z","modified":"2026-06-17T00:18:02.307Z","cvss":[{"version":"2.0","score":5.1,"vector":"AV:N/AC:H/Au:N/C:P/I:P/A:P","level":"medium","assessor":"primary"}],"cwes":["CWE-352"],"updated_at":"2026-11-02T14:02:58.030217Z"}],"osv":[{"id":"MGASA-2014-0506","title":"Updated mediawiki packages fix security vulnerabilies","description":"In MediaWiki before 1.23.7, a missing CSRF check could allow reflected XSS\non wikis that allow raw HTML (CVE-2014-9276).\n\nMediaWiki's \u003ccross-domain-policy\u003e mangling, in MediaWiki before 1.23.7,\ncould allow an article editor to inject code into API consumers that blindly\nunserialize PHP representations of the page from the API (CVE-2014-9277).\n\nThis update provides MediaWiki 1.23.7, which fixes these security issues and\nother bugs.\n","status":"published","published":"2014-12-03T19:27:32Z","modified":"2026-04-16T06:26:02.421119278Z","updated_at":"2026-11-02T15:49:39.488462Z"}]}}
