{"id":"CVE-2014-9475","aliases":["DEBIAN-CVE-2014-9475","DSA-3110-1","EUVD-2014-9294","GHSA-68mq-r5mx-h5r5"],"status":"published","title":"Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.19.23, 1.2x before 1...","description":"Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.19.23, 1.2x before 1.22.15, 1.23.x before 1.23.8, and 1.24.x before 1.24.1 allows remote authenticated users to inject arbitrary web script or HTML via a wikitext message.","severity":{"version":"2.0","score":3.5,"vector":"AV:N/AC:M/Au:S/C:N/I:P/A:N","level":"low","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.01449,"percentile":0.73494,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-79"],"published":"2014-12-23T00:00:00Z","modified":"2026-10-23T15:47:38Z","fixes":[{"ecosystem":"Debian:12","package":"mediawiki","fixed_in":["1:1.19.20+dfsg-2.2"],"sources":["osv"]},{"ecosystem":"Debian:13","package":"mediawiki","fixed_in":["1:1.19.20+dfsg-2.2"],"sources":["osv"]},{"ecosystem":"Debian:14","package":"mediawiki","fixed_in":["1:1.19.20+dfsg-2.2"],"sources":["osv"]},{"ecosystem":"Debian:7","package":"mediawiki","fixed_in":["1:1.19.20+dfsg-0+deb7u3"],"sources":["osv"]}],"affected":[{"source":"osv","ecosystem":"Debian:12","package":"mediawiki","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:1.19.20+dfsg-2.2"}]}]},{"source":"osv","ecosystem":"Debian:13","package":"mediawiki","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:1.19.20+dfsg-2.2"}]}]},{"source":"osv","ecosystem":"Debian:14","package":"mediawiki","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:1.19.20+dfsg-2.2"}]}]},{"source":"osv","ecosystem":"Debian:7","package":"mediawiki","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:1.19.20+dfsg-0+deb7u3"}]}],"versions":["1:1.19.10+dfsg-1","1:1.19.11+dfsg-0+deb7u1","1:1.19.11+dfsg-1","1:1.19.12+dfsg-1","1:1.19.13+dfsg-1","1:1.19.14+dfsg-0+deb7u1","1:1.19.14+dfsg-0+deb7u2","1:1.19.14+dfsg-1","1:1.19.15+dfsg-0+deb7u1","1:1.19.15+dfsg-1","1:1.19.15+dfsg-2","1:1.19.16+dfsg-0+deb7u1","1:1.19.16+dfsg-1","1:1.19.17+dfsg-1","1:1.19.18+dfsg-0+deb7u1","1:1.19.18+dfsg-0.1","1:1.19.19+dfsg-0+deb7u1","1:1.19.19+dfsg-1","1:1.19.20+dfsg-0+deb7u1","1:1.19.20+dfsg-0+deb7u2","1:1.19.5-1","1:1.19.5-1+deb7u1","1:1.19.6-1","1:1.19.7+dfsg-1","1:1.19.7+dfsg-1.1","1:1.19.8+dfsg-1","1:1.19.8+dfsg-2","1:1.19.8+dfsg-2.1","1:1.19.8+dfsg-2.2","1:1.19.9+dfsg-1","1:1.19.9+dfsg-2"]}],"products":[{"vendor":"mediawiki","product":"mediawiki"}],"references":[{"url":"http://www.debian.org/security/2014/dsa-3110","tags":["vendor-advisory","x_refsource_DEBIAN","x_transferred","advisory"]},{"url":"http://www.openwall.com/lists/oss-security/2015/01/03/13","tags":["mailing-list","x_refsource_MLIST","x_transferred","web"]},{"url":"http://www.openwall.com/lists/oss-security/2014/12/21/2","tags":["mailing-list","x_refsource_MLIST","x_transferred","web"]},{"url":"http://www.mandriva.com/security/advisories?name=MDVSA-2015:006","tags":["vendor-advisory","x_refsource_MANDRIVA","x_transferred","advisory"]},{"url":"https://lists.wikimedia.org/pipermail/mediawiki-announce/2014-December/000173.html","tags":["mailing-list","x_refsource_MLIST","x_transferred","Vendor Advisory","advisory"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2014-9475"},{"url":"https://github.com/advisories/GHSA-68mq-r5mx-h5r5"},{"url":"https://security-tracker.debian.org/tracker/CVE-2014-9475","tags":["advisory"]}],"sources":{"cve":[{"id":"CVE-2014-9475","description":"Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.19.23, 1.2x before 1.22.15, 1.23.x before 1.23.8, and 1.24.x before 1.24.1 allows remote authenticated users to inject arbitrary web script or HTML via a wikitext message.","status":"published","published":"2015-01-16T16:00:00Z","modified":"2024-08-06T13:47:41.53Z","updated_at":"2026-11-02T14:33:42.882687Z"}],"euvd":[{"id":"EUVD-2014-9294","description":"Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.19.23, 1.2x before 1.22.15, 1.23.x before 1.23.8, and 1.24.x before 1.24.1 allows remote authenticated users to inject arbitrary web script or HTML via a wikitext message.","status":"published","published":"2015-01-16T16:00:00Z","modified":"2024-08-06T13:47:41Z","updated_at":"2026-11-03T01:56:48.88782Z"}],"ghsa":[{"id":"GHSA-68mq-r5mx-h5r5","title":"Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.19.23, 1.2x before 1...","description":"Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.19.23, 1.2x before 1.22.15, 1.23.x before 1.23.8, and 1.24.x before 1.24.1 allows remote authenticated users to inject arbitrary web script or HTML via a wikitext message.","status":"published","published":"2022-05-17T04:07:22Z","modified":"2023-01-28T05:01:05Z","cwes":["CWE-79"],"updated_at":"2026-11-02T14:43:28.853581Z"}],"nvd":[{"id":"CVE-2014-9475","description":"Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.19.23, 1.2x before 1.22.15, 1.23.x before 1.23.8, and 1.24.x before 1.24.1 allows remote authenticated users to inject arbitrary web script or HTML via a wikitext message.","status":"published","published":"2015-01-16T16:59:09.92Z","modified":"2026-06-17T00:18:26.617Z","cvss":[{"version":"2.0","score":3.5,"vector":"AV:N/AC:M/Au:S/C:N/I:P/A:N","level":"low","assessor":"primary"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:02:58.030217Z"}],"osv":[{"id":"CVE-2014-9475","description":"Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.19.23, 1.2x before 1.22.15, 1.23.x before 1.23.8, and 1.24.x before 1.24.1 allows remote authenticated users to inject arbitrary web script or HTML via a wikitext message.","status":"published","published":"2015-01-16T16:59:09Z","modified":"2026-04-10T03:44:50.277518Z","updated_at":"2026-11-02T15:44:00.097545Z"},{"id":"DEBIAN-CVE-2014-9475","description":"Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.19.23, 1.2x before 1.22.15, 1.23.x before 1.23.8, and 1.24.x before 1.24.1 allows remote authenticated users to inject arbitrary web script or HTML via a wikitext message.","status":"published","published":"2015-01-16T16:59:09.92Z","modified":"2026-10-23T15:47:38.630668998Z","updated_at":"2026-11-02T15:45:26.442161Z"},{"id":"DSA-3110-1","title":"mediawiki - security update","status":"published","published":"2014-12-23T00:00:00Z","modified":"2026-03-09T01:23:29.593862Z","updated_at":"2026-11-02T15:46:15.843838Z"}]}}
