{"id":"CVE-2015-3397","aliases":["EUVD-2022-5469","GHSA-w2xx-jp9f-gp8g"],"status":"published","title":"Yii Framework Cross-site Scripting Vulnerability","description":"Cross-site scripting (XSS) vulnerability in Yii Framework before 2.0.4 allows remote attackers to inject arbitrary web script or HTML via vectors related to JSON, arrays, and Internet Explorer 6 or 7.","severity":{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.02381,"percentile":0.83991,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-79"],"published":"2015-05-14T00:00:00Z","modified":"2026-06-17T00:25:52Z","fixes":[{"ecosystem":"Packagist","package":"yiisoft/yii2","fixed_in":["2.0.4"],"sources":["ghsa","osv"]}],"affected":[{"source":"ghsa","ecosystem":"Packagist","package":"yiisoft/yii2","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"2.0.4"}]}]},{"source":"osv","ecosystem":"Packagist","package":"yiisoft/yii2","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"2.0.4"}]}],"versions":["2.0.0","2.0.0-alpha","2.0.0-beta","2.0.0-rc","2.0.1","2.0.2","2.0.3"]}],"products":[{"vendor":"yiiframework","product":"yiiframework"}],"references":[{"url":"http://www.securityfocus.com/bid/74663","tags":["vdb-entry","x_refsource_BID","x_transferred","web"]},{"url":"http://www.yiiframework.com/news/86/yii-2-0-4-is-released/","tags":["x_refsource_CONFIRM","x_transferred","Patch","Vendor Advisory"]},{"url":"https://github.com/yiisoft/yii2/blob/2.0.4/framework/CHANGELOG.md","tags":["x_refsource_CONFIRM","x_transferred","Patch","web"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2015-3397","tags":["advisory"]},{"url":"https://web.archive.org/web/20210122155403/http://www.securityfocus.com/bid/74663","tags":["web"]},{"url":"https://github.com/FriendsOfPHP/security-advisories/blob/master/yiisoft/yii2/CVE-2015-3397.yaml","tags":["web"]},{"url":"https://www.yiiframework.com/news/86/yii-2-0-4-is-released/"},{"url":"https://github.com/advisories/GHSA-w2xx-jp9f-gp8g"},{"url":"https://www.yiiframework.com/news/86/yii-2-0-4-is-released","tags":["web"]},{"url":"http://www.yiiframework.com/news/86/yii-2-0-4-is-released","tags":["web"]}],"sources":{"cve":[{"id":"CVE-2015-3397","description":"Cross-site scripting (XSS) vulnerability in Yii Framework before 2.0.4 allows remote attackers to inject arbitrary web script or HTML via vectors related to JSON, arrays, and Internet Explorer 6 or 7.","status":"published","published":"2015-05-14T00:00:00Z","modified":"2024-08-06T05:47:57.434Z","updated_at":"2026-11-02T14:35:41.976732Z"}],"euvd":[{"id":"EUVD-2022-5469","description":"Cross-site scripting (XSS) vulnerability in Yii Framework before 2.0.4 allows remote attackers to inject arbitrary web script or HTML via vectors related to JSON, arrays, and Internet Explorer 6 or 7.","status":"published","published":"2015-05-14T00:00:00Z","modified":"2024-08-06T05:47:57Z","updated_at":"2026-11-03T02:22:07.516949Z"}],"ghsa":[{"id":"GHSA-w2xx-jp9f-gp8g","title":"Yii Framework Cross-site Scripting Vulnerability","description":"Cross-site scripting (XSS) vulnerability in Yii Framework before 2.0.4 allows remote attackers to inject arbitrary web script or HTML via vectors related to JSON, arrays, and Internet Explorer 6 or 7.","status":"published","published":"2022-05-17T03:30:00Z","modified":"2024-02-05T15:36:34Z","cwes":["CWE-79"],"updated_at":"2026-11-02T14:37:36.076201Z"}],"nvd":[{"id":"CVE-2015-3397","description":"Cross-site scripting (XSS) vulnerability in Yii Framework before 2.0.4 allows remote attackers to inject arbitrary web script or HTML via vectors related to JSON, arrays, and Internet Explorer 6 or 7.","status":"published","published":"2015-05-14T00:59:04.883Z","modified":"2026-06-17T00:25:52.227Z","cvss":[{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:03:04.906059Z"}],"osv":[{"id":"GHSA-w2xx-jp9f-gp8g","title":"Yii Framework Cross-site Scripting Vulnerability","description":"Cross-site scripting (XSS) vulnerability in Yii Framework before 2.0.4 allows remote attackers to inject arbitrary web script or HTML via vectors related to JSON, arrays, and Internet Explorer 6 or 7.","status":"published","published":"2022-05-17T03:30:00Z","modified":"2024-11-30T05:44:00.081747Z","cwes":["CWE-79"],"updated_at":"2026-11-02T15:46:58.04805Z"}]}}
