{"id":"CVE-2015-6674","aliases":["DEBIAN-CVE-2015-6674","DLA-276-1","DSA-3226-1","EUVD-2015-6612","GHSA-4466-cv44-w3q7","UBUNTU-CVE-2015-6674"],"status":"published","title":"Buffer underflow vulnerability in the Debian inspircd package before 2.0.5-1+deb7u1 for wheezy...","description":"Buffer underflow vulnerability in the Debian inspircd package before 2.0.5-1+deb7u1 for wheezy and before 2.0.16-1 for jessie and sid. NOTE: This issue exists as an additional issue from an incomplete fix of CVE-2012-1836.","severity":{"version":"3.0","score":9.8,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.02273,"percentile":0.83182,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-119"],"published":"2015-04-15T00:00:00Z","modified":"2026-09-09T07:01:35Z","fixes":[{"ecosystem":"Debian:12","package":"inspircd","fixed_in":["2.0.16-1"],"sources":["osv"]},{"ecosystem":"Debian:13","package":"inspircd","fixed_in":["2.0.16-1"],"sources":["osv"]},{"ecosystem":"Ubuntu:14.04:LTS","package":"inspircd","fixed_in":["2.0.5-1+deb7u1build0.14.04.1"],"sources":["osv"]}],"affected":[{"source":"osv","ecosystem":"Debian:12","package":"inspircd","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"2.0.16-1"}]}]},{"source":"osv","ecosystem":"Debian:13","package":"inspircd","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"2.0.16-1"}]}]},{"source":"osv","ecosystem":"Debian:6.0","package":"inspircd","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1.1.22+dfsg-4+squeeze2"}]}],"versions":["1.1.22+dfsg-4","1.1.22+dfsg-4+squeeze1"],"bundled":3},{"source":"osv","ecosystem":"Debian:7","package":"inspircd","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"2.0.5-1+deb7u1"}]}],"versions":["2.0.5-1"],"bundled":3},{"source":"osv","ecosystem":"Ubuntu:14.04:LTS","package":"inspircd","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"2.0.5-1+deb7u1build0.14.04.1"}]}],"versions":["2.0.5-1"]}],"products":[{"vendor":"debian","product":"debian_linux"},{"vendor":"inspircd","product":"inspircd"}],"references":[{"url":"https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=780880","tags":["x_refsource_CONFIRM","x_transferred","Patch","Third Party Advisory","advisory","fix"]},{"url":"https://security.gentoo.org/glsa/201512-13","tags":["vendor-advisory","x_refsource_GENTOO","x_transferred","Third Party Advisory","VDB Entry","advisory"]},{"url":"http://www.debian.org/security/2015/dsa-3226","tags":["vendor-advisory","x_refsource_DEBIAN","x_transferred","Third Party Advisory","advisory"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2015-6674"},{"url":"https://github.com/advisories/GHSA-4466-cv44-w3q7"},{"url":"https://security-tracker.debian.org/tracker/CVE-2015-6674","tags":["advisory"]},{"url":"https://ubuntu.com/security/CVE-2015-6674","tags":["report"]},{"url":"http://www.openwall.com/lists/oss-security/2015/03/29/5","tags":["report"]},{"url":"https://www.cve.org/CVERecord?id=CVE-2015-6674","tags":["report"]}],"sources":{"cve":[{"id":"CVE-2015-6674","description":"Buffer underflow vulnerability in the Debian inspircd package before 2.0.5-1+deb7u1 for wheezy and before 2.0.16-1 for jessie and sid. NOTE: This issue exists as an additional issue from an incomplete fix of CVE-2012-1836.","status":"published","published":"2017-04-13T14:00:00Z","modified":"2024-08-06T07:29:24.629Z","updated_at":"2026-11-02T14:35:42.680858Z"}],"euvd":[{"id":"EUVD-2015-6612","description":"Buffer underflow vulnerability in the Debian inspircd package before 2.0.5-1+deb7u1 for wheezy and before 2.0.16-1 for jessie and sid. NOTE: This issue exists as an additional issue from an incomplete fix of CVE-2012-1836.","status":"published","published":"2017-04-13T14:00:00Z","modified":"2024-08-06T07:29:24Z","updated_at":"2026-11-03T02:21:55.290228Z"}],"ghsa":[{"id":"GHSA-4466-cv44-w3q7","title":"Buffer underflow vulnerability in the Debian inspircd package before 2.0.5-1+deb7u1 for wheezy...","description":"Buffer underflow vulnerability in the Debian inspircd package before 2.0.5-1+deb7u1 for wheezy and before 2.0.16-1 for jessie and sid. NOTE: This issue exists as an additional issue from an incomplete fix of CVE-2012-1836.","status":"published","published":"2022-05-13T01:16:18Z","modified":"2023-02-01T05:04:52Z","cvss":[{"version":"3.0","score":9.8,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical"}],"cwes":["CWE-119"],"updated_at":"2026-11-02T14:50:11.446996Z"}],"nvd":[{"id":"CVE-2015-6674","description":"Buffer underflow vulnerability in the Debian inspircd package before 2.0.5-1+deb7u1 for wheezy and before 2.0.16-1 for jessie and sid. NOTE: This issue exists as an additional issue from an incomplete fix of CVE-2012-1836.","status":"published","published":"2017-04-13T14:59:00.807Z","modified":"2026-06-17T00:31:13.533Z","cvss":[{"version":"3.0","score":9.8,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical","assessor":"primary"},{"version":"2.0","score":7.5,"vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","level":"high","assessor":"primary"}],"cwes":["CWE-119"],"updated_at":"2026-11-02T14:03:17.368799Z"}],"osv":[{"id":"CVE-2015-6674","description":"Buffer underflow vulnerability in the Debian inspircd package before 2.0.5-1+deb7u1 for wheezy and before 2.0.16-1 for jessie and sid. NOTE: This issue exists as an additional issue from an incomplete fix of CVE-2012-1836.","status":"published","published":"2017-04-13T14:59:00Z","modified":"2026-04-10T03:46:26.133022Z","cvss":[{"version":"3.0","score":9.8,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical"}],"updated_at":"2026-11-02T15:44:00.594921Z"},{"id":"DEBIAN-CVE-2015-6674","description":"Buffer underflow vulnerability in the Debian inspircd package before 2.0.5-1+deb7u1 for wheezy and before 2.0.16-1 for jessie and sid. NOTE: This issue exists as an additional issue from an incomplete fix of CVE-2012-1836.","status":"published","published":"2017-04-13T14:59:00.807Z","modified":"2026-09-09T07:01:35.402148633Z","cvss":[{"version":"3.0","score":9.8,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical"}],"updated_at":"2026-11-02T15:45:27.04239Z"},{"id":"UBUNTU-CVE-2015-6674","description":"Buffer underflow vulnerability in the Debian inspircd package before 2.0.5-1+deb7u1 for wheezy and before 2.0.16-1 for jessie and sid. NOTE: This issue exists as an additional issue from an incomplete fix of CVE-2012-1836.","status":"published","published":"2017-04-13T14:59:00Z","modified":"2025-09-08T16:43:27Z","cvss":[{"version":"3.0","score":9.8,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical"}],"updated_at":"2026-11-02T15:54:10.385269Z"},{"id":"DLA-276-1","title":"inspircd - security update","status":"published","published":"2015-07-18T00:00:00Z","modified":"2026-03-09T01:18:28.518632Z","updated_at":"2026-11-02T15:46:11.189256Z"},{"id":"DSA-3226-1","title":"inspircd - security update","status":"published","published":"2015-04-15T00:00:00Z","modified":"2026-03-09T01:21:18.645363Z","updated_at":"2026-11-02T15:46:15.843838Z"}]}}
