{"id":"CVE-2015-7982","aliases":["GHSA-pjh3-jv7w-9jpr"],"status":"published","title":"Command Injection in gm","description":"Versions of `gm` prior to 1.21.1 are affected by a command injection vulnerability. The vulnerability is triggered when user input is passed into `gm.compare()`, which fails to sanitize input correctly before calling the graphics magic binary.\n\n\n## Recommendation\n\nUpdate to version 1.21.1 or later.","facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-77"],"published":"2020-09-01T15:18:55Z","modified":"2023-11-08T03:58:01Z","fixes":[{"ecosystem":"npm","package":"gm","fixed_in":["1.21.1"],"sources":["ghsa","osv"]}],"affected":[{"source":"ghsa","ecosystem":"npm","package":"gm","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"last_affected":"1.20.0"},{"fixed":"1.21.1"}]}]},{"source":"osv","ecosystem":"npm","package":"gm","ranges":[{"type":"SEMVER","events":[{"introduced":"0"},{"fixed":"1.21.1"}]}]}],"references":[{"url":"https://github.com/aheckmann/gm/commit/5f5c77490aa84ed313405c88905eb4566135be31","tags":["web"]},{"url":"https://www.npmjs.com/advisories/54","tags":["web"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2015-7982","tags":["advisory"]},{"url":"https://github.com/advisories/GHSA-pjh3-jv7w-9jpr"},{"url":"https://github.com/aheckmann/gm","tags":["package"]}],"sources":{"ghsa":[{"id":"GHSA-pjh3-jv7w-9jpr","title":"Command Injection in gm","description":"Versions of `gm` prior to 1.21.1 are affected by a command injection vulnerability. The vulnerability is triggered when user input is passed into `gm.compare()`, which fails to sanitize input correctly before calling the graphics magic binary.\n\n\n## Recommendation\n\nUpdate to version 1.21.1 or later.","status":"published","published":"2020-09-01T15:18:55Z","modified":"2023-01-09T05:04:00Z","cwes":["CWE-77"],"updated_at":"2026-11-02T14:36:07.581563Z"}],"osv":[{"id":"GHSA-pjh3-jv7w-9jpr","title":"Command Injection in gm","description":"Versions of `gm` prior to 1.21.1 are affected by a command injection vulnerability. The vulnerability is triggered when user input is passed into `gm.compare()`, which fails to sanitize input correctly before calling the graphics magic binary.\n\n\n## Recommendation\n\nUpdate to version 1.21.1 or later.","status":"published","published":"2020-09-01T15:18:55Z","modified":"2023-11-08T03:58:01.531987Z","cwes":["CWE-77"],"updated_at":"2026-11-02T15:46:53.244788Z"}]}}
