{"id":"CVE-2015-8027","aliases":["DEBIAN-CVE-2015-8027","EUVD-2015-7922","GHSA-pvxc-6v2c-cv7w","UBUNTU-CVE-2015-8027"],"status":"published","title":"Node.js 0.12.x before 0.12.9, 4.x before 4.2.3, and 5.x before 5.1.1 does not ensure the...","description":"Node.js 0.12.x before 0.12.9, 4.x before 4.2.3, and 5.x before 5.1.1 does not ensure the availability of a parser for each HTTP socket, which allows remote attackers to cause a denial of service (uncaughtException and service outage) via a pipelined HTTP request.","severity":{"version":"3.0","score":7.5,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","level":"high","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.05356,"percentile":0.92687,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-17"],"published":"2016-01-02T21:00:00Z","modified":"2026-09-09T07:01:22Z","fixes":[{"ecosystem":"Debian:12","package":"nodejs","fixed_in":["4.2.3~dfsg-1"],"sources":["osv"]},{"ecosystem":"Debian:13","package":"nodejs","fixed_in":["4.2.3~dfsg-1"],"sources":["osv"]},{"ecosystem":"Debian:14","package":"nodejs","fixed_in":["4.2.3~dfsg-1"],"sources":["osv"]}],"affected":[{"source":"osv","ecosystem":"Debian:12","package":"nodejs","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"4.2.3~dfsg-1"}]}]},{"source":"osv","ecosystem":"Debian:13","package":"nodejs","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"4.2.3~dfsg-1"}]}]},{"source":"osv","ecosystem":"Debian:14","package":"nodejs","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"4.2.3~dfsg-1"}]}]}],"products":[{"vendor":"nodejs","product":"node.js"}],"references":[{"url":"http://www-01.ibm.com/support/docview.wss?uid=swg1IV79524","tags":["vendor-advisory","x_refsource_AIXAPAR","x_transferred","Vendor Advisory","advisory"]},{"url":"http://www.securityfocus.com/bid/78207","tags":["vdb-entry","x_refsource_BID","x_transferred","web"]},{"url":"http://lists.opensuse.org/opensuse-updates/2016-01/msg00045.html","tags":["vendor-advisory","x_refsource_SUSE","x_transferred","web"]},{"url":"https://nodejs.org/en/blog/vulnerability/cve-2015-8027_cve-2015-6764/","tags":["x_refsource_CONFIRM","x_transferred","Vendor Advisory","advisory","report"]},{"url":"https://nodejs.org/en/blog/vulnerability/december-2015-security-releases/","tags":["x_refsource_CONFIRM","x_transferred","Vendor Advisory","advisory"]},{"url":"http://www-01.ibm.com/support/docview.wss?uid=swg21972419","tags":["x_refsource_CONFIRM","x_transferred","Vendor Advisory","advisory"]},{"url":"https://security.gentoo.org/glsa/201612-43","tags":["vendor-advisory","x_refsource_GENTOO","x_transferred","advisory"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2015-8027"},{"url":"https://nodejs.org/en/blog/vulnerability/cve-2015-8027_cve-2015-6764"},{"url":"https://nodejs.org/en/blog/vulnerability/december-2015-security-releases"},{"url":"https://github.com/advisories/GHSA-pvxc-6v2c-cv7w"},{"url":"https://security-tracker.debian.org/tracker/CVE-2015-8027","tags":["advisory"]},{"url":"https://ubuntu.com/security/CVE-2015-8027","tags":["report"]},{"url":"https://www.cve.org/CVERecord?id=CVE-2015-8027","tags":["report"]}],"sources":{"cve":[{"id":"CVE-2015-8027","description":"Node.js 0.12.x before 0.12.9, 4.x before 4.2.3, and 5.x before 5.1.1 does not ensure the availability of a parser for each HTTP socket, which allows remote attackers to cause a denial of service (uncaughtException and service outage) via a pipelined HTTP request.","status":"published","published":"2016-01-02T21:00:00Z","modified":"2024-08-06T08:06:31.544Z","updated_at":"2026-11-02T14:35:40.900357Z"}],"euvd":[{"id":"EUVD-2015-7922","description":"Node.js 0.12.x before 0.12.9, 4.x before 4.2.3, and 5.x before 5.1.1 does not ensure the availability of a parser for each HTTP socket, which allows remote attackers to cause a denial of service (uncaughtException and service outage) via a pipelined HTTP request.","status":"published","published":"2016-01-02T21:00:00Z","modified":"2024-08-06T08:06:31Z","updated_at":"2026-11-03T02:21:50.339607Z"}],"ghsa":[{"id":"GHSA-pvxc-6v2c-cv7w","title":"Node.js 0.12.x before 0.12.9, 4.x before 4.2.3, and 5.x before 5.1.1 does not ensure the...","description":"Node.js 0.12.x before 0.12.9, 4.x before 4.2.3, and 5.x before 5.1.1 does not ensure the availability of a parser for each HTTP socket, which allows remote attackers to cause a denial of service (uncaughtException and service outage) via a pipelined HTTP request.","status":"published","published":"2022-05-17T02:38:01Z","modified":"2025-04-12T12:56:29Z","cvss":[{"version":"3.0","score":7.5,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","level":"high"}],"updated_at":"2026-11-02T15:01:25.259545Z"}],"nvd":[{"id":"CVE-2015-8027","description":"Node.js 0.12.x before 0.12.9, 4.x before 4.2.3, and 5.x before 5.1.1 does not ensure the availability of a parser for each HTTP socket, which allows remote attackers to cause a denial of service (uncaughtException and service outage) via a pipelined HTTP request.","status":"published","published":"2016-01-02T21:59:17.83Z","modified":"2026-06-17T00:33:53.557Z","cvss":[{"version":"3.0","score":7.5,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","level":"high","assessor":"primary"},{"version":"2.0","score":5,"vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","level":"medium","assessor":"primary"}],"cwes":["CWE-17"],"updated_at":"2026-11-02T14:03:15.746629Z"}],"osv":[{"id":"CVE-2015-8027","description":"Node.js 0.12.x before 0.12.9, 4.x before 4.2.3, and 5.x before 5.1.1 does not ensure the availability of a parser for each HTTP socket, which allows remote attackers to cause a denial of service (uncaughtException and service outage) via a pipelined HTTP request.","status":"published","published":"2016-01-02T21:59:17Z","modified":"2026-04-10T03:45:29.558061Z","cvss":[{"version":"3.0","score":7.5,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","level":"high"}],"updated_at":"2026-11-02T15:44:01.068991Z"},{"id":"DEBIAN-CVE-2015-8027","description":"Node.js 0.12.x before 0.12.9, 4.x before 4.2.3, and 5.x before 5.1.1 does not ensure the availability of a parser for each HTTP socket, which allows remote attackers to cause a denial of service (uncaughtException and service outage) via a pipelined HTTP request.","status":"published","published":"2016-01-02T21:59:17.83Z","modified":"2026-09-09T07:01:22.397464989Z","cvss":[{"version":"3.0","score":7.5,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","level":"high"}],"updated_at":"2026-11-02T15:45:27.04239Z"},{"id":"UBUNTU-CVE-2015-8027","description":"Node.js 0.12.x before 0.12.9, 4.x before 4.2.3, and 5.x before 5.1.1 does not ensure the availability of a parser for each HTTP socket, which allows remote attackers to cause a denial of service (uncaughtException and service outage) via a pipelined HTTP request.","status":"withdrawn","published":"2016-01-02T21:59:00Z","modified":"2025-07-16T07:33:28.298487Z","cvss":[{"version":"3.0","score":7.5,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","level":"high"}],"updated_at":"2026-11-02T15:54:10.737723Z"}]}}
