{"id":"CVE-2016-10524","aliases":["EUVD-2019-0267","GHSA-97gv-3p2c-xw7j"],"status":"published","title":"Denial of Service and Content Injection in i18n-node-angular","description":"i18n-node-angular is a module used to interact between i18n and angular without using additional resources. A REST API endpoint that is used for development in i18n-node-angular before 1.4.0 was not disabled in production environments a malicious user could fill up the server causing a Denial of Service or content injection.","severity":{"version":"3.1","score":8.2,"vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:H","level":"high","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.00789,"percentile":0.56466,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-400","CWE-74"],"published":"2018-05-31T20:00:00Z","modified":"2026-10-20T10:45:16Z","fixes":[{"ecosystem":"npm","package":"i18n-node-angular","fixed_in":["1.4.0"],"sources":["ghsa","osv"]}],"affected":[{"source":"ghsa","ecosystem":"npm","package":"i18n-node-angular","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1.4.0"}]}]},{"source":"osv","ecosystem":"npm","package":"i18n-node-angular","ranges":[{"type":"SEMVER","events":[{"introduced":"0"},{"fixed":"1.4.0"}]}]}],"products":[{"vendor":"hackerone","product":"i18n-node-angular node module"},{"vendor":"i18n-node-angular_project","product":"i18n-node-angular"}],"references":[{"url":"https://nodesecurity.io/advisories/80","tags":["x_refsource_MISC","x_transferred","Broken Link","Third Party Advisory","advisory"]},{"url":"https://github.com/oliversalzburg/i18n-node-angular/commit/877720d2d9bb90dc8233706e81ffa03f99fc9dc8","tags":["x_refsource_MISC","x_transferred","Patch","Third Party Advisory","fix","web"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2016-10524","tags":["advisory"]},{"url":"https://github.com/advisories/GHSA-97gv-3p2c-xw7j","tags":["advisory"]},{"url":"https://www.npmjs.com/advisories/80","tags":["web"]},{"url":"https://github.com/oliversalzburg/i18n-node-angular","tags":["package"]}],"sources":{"cve":[{"id":"CVE-2016-10524","description":"i18n-node-angular is a module used to interact between i18n and angular without using additional resources. A REST API endpoint that is used for development in i18n-node-angular before 1.4.0 was not disabled in production environments a malicious user could fill up the server causing a Denial of Service or content injection.","status":"published","published":"2018-05-31T20:00:00Z","modified":"2024-09-16T17:27:42.388Z","cwes":["CWE-400"],"updated_at":"2026-11-02T14:33:31.450804Z"}],"euvd":[{"id":"EUVD-2019-0267","description":"i18n-node-angular is a module used to interact between i18n and angular without using additional resources. A REST API endpoint that is used for development in i18n-node-angular before 1.4.0 was not disabled in production environments a malicious user could fill up the server causing a Denial of Service or content injection.","status":"published","published":"2018-05-31T20:00:00Z","modified":"2024-09-16T17:27:42Z","updated_at":"2026-11-03T00:55:41.925187Z"}],"ghsa":[{"id":"GHSA-97gv-3p2c-xw7j","title":"Denial of Service and Content Injection in i18n-node-angular","description":"Versions of `i18n-node-angular` prior to 1.4.0 are affected by denial of service and cross-site scripting vulnerabilities. The vulnerabilities exist in a REST endpoint that was created for development purposes, but was not disabled in production in affected versions.\n\n\n## Recommendation\n\nUpdate to version 1.4.0 or later.","status":"published","published":"2019-02-18T23:39:06Z","modified":"2023-02-01T05:03:38Z","cvss":[{"version":"3.0","score":8.2,"vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:H","level":"high"}],"cwes":["CWE-74","CWE-400"],"updated_at":"2026-11-02T14:36:31.364752Z"}],"nvd":[{"id":"CVE-2016-10524","description":"i18n-node-angular is a module used to interact between i18n and angular without using additional resources. A REST API endpoint that is used for development in i18n-node-angular before 1.4.0 was not disabled in production environments a malicious user could fill up the server causing a Denial of Service or content injection.","status":"published","published":"2018-05-31T20:29:00.767Z","modified":"2026-06-17T00:39:52.52Z","cvss":[{"version":"3.1","score":8.2,"vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:H","level":"high","assessor":"primary"},{"version":"2.0","score":6,"vector":"AV:N/AC:M/Au:S/C:P/I:P/A:P","level":"medium","assessor":"primary"}],"cwes":["CWE-400"],"updated_at":"2026-11-02T14:03:39.176887Z"}],"osv":[{"id":"CVE-2016-10524","description":"i18n-node-angular is a module used to interact between i18n and angular without using additional resources. A REST API endpoint that is used for development in i18n-node-angular before 1.4.0 was not disabled in production environments a malicious user could fill up the server causing a Denial of Service or content injection.","status":"published","published":"2018-05-31T20:29:00.767Z","modified":"2026-10-20T10:45:16.671167663Z","cvss":[{"version":"3.1","score":8.2,"vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:H","level":"high"}],"updated_at":"2026-11-02T15:44:01.531338Z"},{"id":"GHSA-97gv-3p2c-xw7j","title":"Denial of Service and Content Injection in i18n-node-angular","description":"Versions of `i18n-node-angular` prior to 1.4.0 are affected by denial of service and cross-site scripting vulnerabilities. The vulnerabilities exist in a REST endpoint that was created for development purposes, but was not disabled in production in affected versions.\n\n\n## Recommendation\n\nUpdate to version 1.4.0 or later.","status":"published","published":"2019-02-18T23:39:06Z","modified":"2023-11-08T03:58:10.479392Z","cvss":[{"version":"3.0","score":8.2,"vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:H","level":"high"}],"cwes":["CWE-400","CWE-74"],"updated_at":"2026-11-02T15:46:43.524801Z"}]}}
