{"id":"CVE-2016-10527","aliases":["EUVD-2019-0324","GHSA-pp4v-55vr-9gxh"],"status":"published","title":"Regular Expression Denial of Service in riot-compiler","description":"The riot-compiler version version 2.3.21 has an issue in a regex (Catastrophic Backtracking) thats make it unusable under certain conditions.","severity":{"version":"3.0","score":7.5,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","level":"high","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.01573,"percentile":0.75564,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-399","CWE-400"],"published":"2018-05-31T20:00:00Z","modified":"2026-10-20T10:45:16Z","fixes":[{"ecosystem":"npm","package":"riot-compiler","fixed_in":["2.3.22"],"sources":["ghsa","osv"]}],"affected":[{"source":"ghsa","ecosystem":"npm","package":"riot-compiler","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"2.3.22"}]}]},{"source":"osv","ecosystem":"npm","package":"riot-compiler","ranges":[{"type":"SEMVER","events":[{"introduced":"0"},{"fixed":"2.3.22"}]}]}],"products":[{"vendor":"hackerone","product":"riot-compiler node module"},{"vendor":"riot.js","product":"riot-compiler"}],"references":[{"url":"https://nodesecurity.io/advisories/86","tags":["x_refsource_MISC","x_transferred","Third Party Advisory","advisory"]},{"url":"https://github.com/riot/compiler/issues/46","tags":["x_refsource_MISC","x_transferred","Third Party Advisory","advisory","web"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2016-10527","tags":["advisory"]},{"url":"https://github.com/advisories/GHSA-pp4v-55vr-9gxh","tags":["advisory"]},{"url":"https://www.npmjs.com/advisories/86","tags":["web"]}],"sources":{"cve":[{"id":"CVE-2016-10527","description":"The riot-compiler version version 2.3.21 has an issue in a regex (Catastrophic Backtracking) thats make it unusable under certain conditions.","status":"published","published":"2018-05-31T20:00:00Z","modified":"2024-09-17T01:16:35.976Z","cwes":["CWE-400"],"updated_at":"2026-11-02T14:33:31.764001Z"}],"euvd":[{"id":"EUVD-2019-0324","description":"The riot-compiler version version 2.3.21 has an issue in a regex (Catastrophic Backtracking) thats make it unusable under certain conditions.","status":"published","published":"2018-05-31T20:00:00Z","modified":"2024-09-17T01:16:35Z","updated_at":"2026-11-03T00:28:51.310992Z"}],"ghsa":[{"id":"GHSA-pp4v-55vr-9gxh","title":"Regular Expression Denial of Service in riot-compiler","description":"Affected versions of `riot-compiler` are susceptible to a regular expression denial of service vulnerability.\n\n\n## Recommendation\n\nUpdate to version 2.3.22 or later.","status":"published","published":"2019-02-18T23:39:13Z","modified":"2023-09-12T18:42:41Z","cvss":[{"version":"3.0","score":7.5,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","level":"high"}],"cwes":["CWE-400"],"updated_at":"2026-11-02T14:37:04.447845Z"}],"nvd":[{"id":"CVE-2016-10527","description":"The riot-compiler version version 2.3.21 has an issue in a regex (Catastrophic Backtracking) thats make it unusable under certain conditions.","status":"published","published":"2018-05-31T20:29:00.847Z","modified":"2026-06-17T00:39:52.843Z","cvss":[{"version":"3.0","score":7.5,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","level":"high","assessor":"primary"},{"version":"2.0","score":5,"vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","level":"medium","assessor":"primary"}],"cwes":["CWE-400","CWE-399"],"updated_at":"2026-11-02T14:03:39.176887Z"}],"osv":[{"id":"CVE-2016-10527","description":"The riot-compiler version version 2.3.21 has an issue in a regex (Catastrophic Backtracking) thats make it unusable under certain conditions.","status":"published","published":"2018-05-31T20:29:00.847Z","modified":"2026-10-20T10:45:16.739620282Z","cvss":[{"version":"3.0","score":7.5,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","level":"high"}],"updated_at":"2026-11-02T15:44:01.531338Z"},{"id":"GHSA-pp4v-55vr-9gxh","title":"Regular Expression Denial of Service in riot-compiler","description":"Affected versions of `riot-compiler` are susceptible to a regular expression denial of service vulnerability.\n\n\n## Recommendation\n\nUpdate to version 2.3.22 or later.","status":"published","published":"2019-02-18T23:39:13Z","modified":"2023-11-08T03:58:10.661609Z","cvss":[{"version":"3.0","score":7.5,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","level":"high"}],"cwes":["CWE-400"],"updated_at":"2026-11-02T15:46:53.244788Z"}]}}
