{"id":"CVE-2016-1504","aliases":["DEBIAN-CVE-2016-1504","EUVD-2016-2602","GHSA-f982-2cvq-99qg","MGASA-2016-0034","UBUNTU-CVE-2016-1504"],"status":"published","title":"dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash...","description":"dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to the option length.","severity":{"version":"3.0","score":7.5,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","level":"high","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-06","score":0.02904,"percentile":0.87025,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-119"],"published":"2016-01-21T21:38:47Z","modified":"2026-10-24T10:30:55Z","fixes":[{"ecosystem":"Debian:12","package":"dhcpcd5","fixed_in":["6.10.1-1"],"sources":["osv"]}],"affected":[{"source":"osv","ecosystem":"Debian:12","package":"dhcpcd5","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"6.10.1-1"}]}]},{"source":"osv","ecosystem":"Mageia:5","package":"dhcpcd","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"6.10.0-1.mga5"}]}],"bundled":2},{"source":"osv","ecosystem":"Ubuntu:Pro:14.04:LTS","package":"dhcpcd5","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"}]}],"versions":["5.5.6-1","6.0.5-1ubuntu1","6.0.5-1.1","6.0.5-2build0.14.04.1","6.0.5-2+deb8u1build0.14.04.1~esm1"]}],"products":[{"vendor":"dhcpcd_project","product":"dhcpcd"}],"references":[{"url":"http://www.openwall.com/lists/oss-security/2016/01/07/3","tags":["mailing-list","x_refsource_MLIST","x_transferred","Mailing List","Third Party Advisory","advisory"]},{"url":"http://www.openwall.com/lists/oss-security/2016/01/07/4","tags":["mailing-list","x_refsource_MLIST","x_transferred","Mailing List","Third Party Advisory","advisory"]},{"url":"http://roy.marples.name/projects/dhcpcd/info/595883e2a431f65d8fabf33059aa4689cca17403","tags":["x_refsource_CONFIRM","x_transferred","Patch","Vendor Advisory","fix","report"]},{"url":"https://security.gentoo.org/glsa/201606-07","tags":["vendor-advisory","x_refsource_GENTOO","x_transferred","advisory"]},{"url":"http://roy.marples.name/projects/dhcpcd/timeline?r=trunk\u0026nd\u0026c=2016-01-07+16%3A47%3A19\u0026n=200","tags":["x_refsource_CONFIRM","x_transferred","Release Notes","Vendor Advisory","advisory"]},{"url":"http://www.securitytracker.com/id/1034601","tags":["vdb-entry","x_refsource_SECTRACK","x_transferred","web"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2016-1504"},{"url":"https://github.com/advisories/GHSA-f982-2cvq-99qg"},{"url":"https://security-tracker.debian.org/tracker/CVE-2016-1504","tags":["advisory"]},{"url":"https://advisories.mageia.org/MGASA-2016-0034.html","tags":["advisory"]},{"url":"https://bugs.mageia.org/show_bug.cgi?id=17462","tags":["report"]},{"url":"http://roy.marples.name/archives/dhcpcd-discuss/2015/1001.html","tags":["web"]},{"url":"http://roy.marples.name/archives/dhcpcd-discuss/2015/1004.html","tags":["web"]},{"url":"http://roy.marples.name/archives/dhcpcd-discuss/2015/1012.html","tags":["web"]},{"url":"http://roy.marples.name/archives/dhcpcd-discuss/2015/1018.html","tags":["web"]},{"url":"http://roy.marples.name/archives/dhcpcd-discuss/2015/1058.html","tags":["web"]},{"url":"http://roy.marples.name/archives/dhcpcd-discuss/2015/1089.html","tags":["web"]},{"url":"http://roy.marples.name/archives/dhcpcd-discuss/2015/1093.html","tags":["web"]},{"url":"http://roy.marples.name/archives/dhcpcd-discuss/2015/1129.html","tags":["web"]},{"url":"http://roy.marples.name/archives/dhcpcd-discuss/2016/1143.html","tags":["web"]},{"url":"http://openwall.com/lists/oss-security/2016/01/07/4","tags":["web"]},{"url":"https://ubuntu.com/security/CVE-2016-1504","tags":["report"]},{"url":"https://www.cve.org/CVERecord?id=CVE-2016-1504","tags":["report"]}],"sources":{"cve":[{"id":"CVE-2016-1504","description":"dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to the option length.","status":"published","published":"2017-02-07T15:00:00Z","modified":"2024-08-05T22:55:14.831Z","updated_at":"2026-11-02T14:33:35.841056Z"}],"euvd":[{"id":"EUVD-2016-2602","description":"dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to the option length.","status":"published","published":"2017-02-07T15:00:00Z","modified":"2024-08-05T22:55:14Z","updated_at":"2026-11-03T02:22:56.986033Z"}],"ghsa":[{"id":"GHSA-f982-2cvq-99qg","title":"dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash...","description":"dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to the option length.","status":"published","published":"2022-05-17T01:08:10Z","modified":"2023-02-03T05:03:08Z","cvss":[{"version":"3.0","score":7.5,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","level":"high"}],"cwes":["CWE-119"],"updated_at":"2026-11-02T14:53:18.133628Z"}],"nvd":[{"id":"CVE-2016-1504","description":"dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to the option length.","status":"published","published":"2017-02-07T15:59:00.21Z","modified":"2026-06-17T00:42:05.837Z","cvss":[{"version":"3.0","score":7.5,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","level":"high","assessor":"primary"},{"version":"2.0","score":5,"vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","level":"medium","assessor":"primary"}],"cwes":["CWE-119"],"updated_at":"2026-11-02T14:03:35.822579Z"}],"osv":[{"id":"CVE-2016-1504","description":"dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to the option length.","status":"published","published":"2017-02-07T15:59:00.21Z","modified":"2026-10-24T10:30:55.648511573Z","cvss":[{"version":"3.0","score":7.5,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","level":"high"}],"updated_at":"2026-11-02T15:44:02.114472Z"},{"id":"DEBIAN-CVE-2016-1504","description":"dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to the option length.","status":"published","published":"2017-02-07T15:59:00.21Z","modified":"2026-09-22T07:01:24.563041075Z","cvss":[{"version":"3.0","score":7.5,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","level":"high"}],"updated_at":"2026-11-02T15:45:27.323751Z"},{"id":"UBUNTU-CVE-2016-1504","description":"dhcpcd before 6.10.0 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to the option length.","status":"published","published":"2017-02-07T15:59:00Z","modified":"2025-09-08T16:43:36Z","cvss":[{"version":"3.0","score":7.5,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","level":"high"}],"updated_at":"2026-11-02T15:54:11.492576Z"},{"id":"MGASA-2016-0034","title":"Updated dhcpcd packages fix security vulnerability","description":"Possible heap overflow in dhcpcd before 6.10.0 caused by malformed dhcp\nresponses due to incorrect option length values (CVE-2016-1503).\n\nPossible invalid read in dhcpcd before 6.10.0 caused by malformed dhcp\nresponses can lead to a crash (CVE-2016-1504).\n\nThe dhcpcd package has been updated to version 6.10.0 which fixes these\nissues and has several other bug fixes and enhancements.\n","status":"published","published":"2016-01-21T21:38:47Z","modified":"2026-04-16T06:24:19.884356898Z","updated_at":"2026-11-02T15:49:39.792687Z"}]}}
