{"id":"CVE-2016-1513","aliases":["DEBIAN-CVE-2016-1513","DLA-591-1","EUVD-2016-2610","GHSA-f753-7547-p2rj"],"status":"published","title":"The Impress tool in Apache OpenOffice 4.1.2 and earlier allows remote attackers to cause a denial...","description":"The Impress tool in Apache OpenOffice 4.1.2 and earlier allows remote attackers to cause a denial of service (out-of-bounds read or write) or execute arbitrary code via crafted MetaActions in an (1) ODP or (2) OTP file.","severity":{"version":"3.0","score":7.8,"vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","level":"high","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-08","score":0.04336,"percentile":0.91263,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-125","CWE-787"],"published":"2016-08-05T14:00:00Z","modified":"2026-09-22T07:01:25Z","fixes":[{"ecosystem":"Debian:12","package":"libreoffice","fixed_in":["1:4.3.3-1"],"sources":["osv"]},{"ecosystem":"Debian:13","package":"libreoffice","fixed_in":["1:4.3.3-1"],"sources":["osv"]},{"ecosystem":"Debian:14","package":"libreoffice","fixed_in":["1:4.3.3-1"],"sources":["osv"]},{"ecosystem":"Debian:7","package":"libreoffice","fixed_in":["1:3.5.4+dfsg2-0+deb7u8"],"sources":["osv"]}],"affected":[{"source":"osv","ecosystem":"Debian:12","package":"libreoffice","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:4.3.3-1"}]}]},{"source":"osv","ecosystem":"Debian:13","package":"libreoffice","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:4.3.3-1"}]}]},{"source":"osv","ecosystem":"Debian:14","package":"libreoffice","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:4.3.3-1"}]}]},{"source":"osv","ecosystem":"Debian:7","package":"libreoffice","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1:3.5.4+dfsg2-0+deb7u8"}]}],"versions":["1:3.5.4+dfsg-4","1:3.5.4+dfsg2-0+deb7u1","1:3.5.4+dfsg2-0+deb7u2","1:3.5.4+dfsg2-0+deb7u3","1:3.5.4+dfsg2-0+deb7u4","1:3.5.4+dfsg2-0+deb7u4~bpo60+1","1:3.5.4+dfsg2-0+deb7u5","1:3.5.4+dfsg2-0+deb7u6","1:3.5.4+dfsg2-0+deb7u7"]}],"products":[{"vendor":"apache","product":"openoffice"}],"references":[{"url":"https://bz.apache.org/ooo/show_bug.cgi?id=127045","tags":["x_refsource_MISC","x_transferred","Issue Tracking","report"]},{"url":"http://www.securityfocus.com/bid/92079","tags":["vdb-entry","x_refsource_BID","x_transferred","Third Party Advisory","VDB Entry","advisory"]},{"url":"https://security.gentoo.org/glsa/201703-01","tags":["vendor-advisory","x_refsource_GENTOO","x_transferred","advisory"]},{"url":"http://www.securitytracker.com/id/1036443","tags":["vdb-entry","x_refsource_SECTRACK","x_transferred","web"]},{"url":"http://www.ubuntu.com/usn/USN-3046-1","tags":["vendor-advisory","x_refsource_UBUNTU","x_transferred","advisory"]},{"url":"http://www.talosintelligence.com/reports/TALOS-2016-0051/","tags":["x_refsource_MISC","x_transferred","Third Party Advisory","advisory"]},{"url":"http://www.openoffice.org/security/cves/CVE-2016-1513.html","tags":["x_refsource_CONFIRM","x_transferred","Vendor Advisory","advisory"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2016-1513"},{"url":"http://www.talosintelligence.com/reports/TALOS-2016-0051"},{"url":"https://github.com/advisories/GHSA-f753-7547-p2rj"},{"url":"https://security-tracker.debian.org/tracker/CVE-2016-1513","tags":["advisory"]}],"sources":{"cve":[{"id":"CVE-2016-1513","description":"The Impress tool in Apache OpenOffice 4.1.2 and earlier allows remote attackers to cause a denial of service (out-of-bounds read or write) or execute arbitrary code via crafted MetaActions in an (1) ODP or (2) OTP file.","status":"published","published":"2016-08-05T14:00:00Z","modified":"2024-08-05T22:55:14.94Z","updated_at":"2026-11-02T14:33:35.488991Z"}],"euvd":[{"id":"EUVD-2016-2610","description":"The Impress tool in Apache OpenOffice 4.1.2 and earlier allows remote attackers to cause a denial of service (out-of-bounds read or write) or execute arbitrary code via crafted MetaActions in an (1) ODP or (2) OTP file.","status":"published","published":"2016-08-05T14:00:00Z","modified":"2024-08-05T22:55:14Z","updated_at":"2026-11-03T02:22:56.986033Z"}],"ghsa":[{"id":"GHSA-f753-7547-p2rj","title":"The Impress tool in Apache OpenOffice 4.1.2 and earlier allows remote attackers to cause a denial...","description":"The Impress tool in Apache OpenOffice 4.1.2 and earlier allows remote attackers to cause a denial of service (out-of-bounds read or write) or execute arbitrary code via crafted MetaActions in an (1) ODP or (2) OTP file.","status":"published","published":"2022-05-17T01:21:38Z","modified":"2025-04-12T13:04:06Z","cvss":[{"version":"3.0","score":7.8,"vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","level":"high"}],"cwes":["CWE-125"],"updated_at":"2026-11-02T15:01:29.190007Z"}],"nvd":[{"id":"CVE-2016-1513","description":"The Impress tool in Apache OpenOffice 4.1.2 and earlier allows remote attackers to cause a denial of service (out-of-bounds read or write) or execute arbitrary code via crafted MetaActions in an (1) ODP or (2) OTP file.","status":"published","published":"2016-08-05T14:59:00.407Z","modified":"2026-06-17T00:42:06.1Z","cvss":[{"version":"3.0","score":7.8,"vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","level":"high","assessor":"primary"},{"version":"2.0","score":6.8,"vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","level":"medium","assessor":"primary"}],"cwes":["CWE-125","CWE-787"],"updated_at":"2026-11-02T14:03:28.854267Z"}],"osv":[{"id":"CVE-2016-1513","description":"The Impress tool in Apache OpenOffice 4.1.2 and earlier allows remote attackers to cause a denial of service (out-of-bounds read or write) or execute arbitrary code via crafted MetaActions in an (1) ODP or (2) OTP file.","status":"published","published":"2016-08-05T14:59:00.407Z","modified":"2026-03-15T22:05:13.773904Z","cvss":[{"version":"3.0","score":7.8,"vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","level":"high"}],"updated_at":"2026-11-02T15:44:02.114472Z"},{"id":"DEBIAN-CVE-2016-1513","description":"The Impress tool in Apache OpenOffice 4.1.2 and earlier allows remote attackers to cause a denial of service (out-of-bounds read or write) or execute arbitrary code via crafted MetaActions in an (1) ODP or (2) OTP file.","status":"published","published":"2016-08-05T14:59:00.407Z","modified":"2026-09-22T07:01:25.215349355Z","cvss":[{"version":"3.0","score":7.8,"vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","level":"high"}],"updated_at":"2026-11-02T15:45:27.323751Z"},{"id":"DLA-591-1","title":"libreoffice - security update","status":"published","published":"2016-08-09T00:00:00Z","modified":"2026-03-09T02:08:52.823643Z","updated_at":"2026-11-02T15:46:13.207219Z"}]}}
