{"id":"CVE-2016-4566","aliases":["DEBIAN-CVE-2016-4566","EUVD-2016-5553","GHSA-cv88-x229-26m4","UBUNTU-CVE-2016-4566"],"status":"published","title":"Cross-site scripting (XSS) vulnerability in plupload.flash.swf in Plupload before 2.1.9, as used...","description":"Cross-site scripting (XSS) vulnerability in plupload.flash.swf in Plupload before 2.1.9, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via a Same-Origin Method Execution (SOME) attack.","severity":{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.05995,"percentile":0.93364,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-79"],"published":"2016-05-22T01:00:00Z","modified":"2026-10-24T10:31:03Z","fixes":[{"ecosystem":"Debian:12","package":"wordpress","fixed_in":["4.5.2+dfsg-1"],"sources":["osv"]},{"ecosystem":"Debian:13","package":"wordpress","fixed_in":["4.5.2+dfsg-1"],"sources":["osv"]},{"ecosystem":"Debian:14","package":"wordpress","fixed_in":["4.5.2+dfsg-1"],"sources":["osv"]}],"affected":[{"source":"osv","ecosystem":"Debian:12","package":"wordpress","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"4.5.2+dfsg-1"}]}]},{"source":"osv","ecosystem":"Debian:13","package":"wordpress","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"4.5.2+dfsg-1"}]}]},{"source":"osv","ecosystem":"Debian:14","package":"wordpress","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"4.5.2+dfsg-1"}]}]},{"source":"osv","ecosystem":"Ubuntu:16.04:LTS","package":"wordpress","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"}]}],"versions":["4.3+dfsg-1","4.3.1+dfsg-1","4.4+dfsg-1","4.4.1+dfsg-1","4.4.2+dfsg-1","4.4.2+dfsg-1ubuntu1"]}],"products":[{"vendor":"plupload","product":"plupload"},{"vendor":"wordpress","product":"wordpress"}],"references":[{"url":"https://core.trac.wordpress.org/changeset/37382/","tags":["x_refsource_CONFIRM","x_transferred","Patch","fix"]},{"url":"http://www.openwall.com/lists/oss-security/2016/05/07/2","tags":["mailing-list","x_refsource_MLIST","x_transferred","web","report"]},{"url":"http://www.plupload.com/punbb/viewtopic.php?pid=28690","tags":["x_refsource_CONFIRM","x_transferred","Vendor Advisory","advisory"]},{"url":"https://wpvulndb.com/vulnerabilities/8489","tags":["x_refsource_MISC","x_transferred","Third Party Advisory","advisory"]},{"url":"https://codex.wordpress.org/Version_4.5.2","tags":["x_refsource_CONFIRM","x_transferred","Patch","fix"]},{"url":"http://www.securitytracker.com/id/1035818","tags":["vdb-entry","x_refsource_SECTRACK","x_transferred","Third Party Advisory","VDB Entry","advisory"]},{"url":"https://wordpress.org/news/2016/05/wordpress-4-5-2/","tags":["x_refsource_CONFIRM","x_transferred","Patch","Vendor Advisory","fix","report"]},{"url":"https://gist.github.com/cure53/09a81530a44f6b8173f545accc9ed07e","tags":["x_refsource_MISC","x_transferred","Third Party Advisory","advisory"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2016-4566"},{"url":"https://core.trac.wordpress.org/changeset/37382"},{"url":"https://wordpress.org/news/2016/05/wordpress-4-5-2"},{"url":"https://github.com/advisories/GHSA-cv88-x229-26m4"},{"url":"https://security-tracker.debian.org/tracker/CVE-2016-4566","tags":["advisory"]},{"url":"https://ubuntu.com/security/CVE-2016-4566","tags":["report"]},{"url":"https://www.cve.org/CVERecord?id=CVE-2016-4566","tags":["report"]}],"sources":{"cve":[{"id":"CVE-2016-4566","description":"Cross-site scripting (XSS) vulnerability in plupload.flash.swf in Plupload before 2.1.9, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via a Same-Origin Method Execution (SOME) attack.","status":"published","published":"2016-05-22T01:00:00Z","modified":"2024-08-06T00:32:25.823Z","updated_at":"2026-11-02T14:33:35.488991Z"}],"euvd":[{"id":"EUVD-2016-5553","description":"Cross-site scripting (XSS) vulnerability in plupload.flash.swf in Plupload before 2.1.9, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via a Same-Origin Method Execution (SOME) attack.","status":"published","published":"2016-05-22T01:00:00Z","modified":"2024-08-06T00:32:25Z","updated_at":"2026-11-03T02:22:45.901874Z"}],"ghsa":[{"id":"GHSA-cv88-x229-26m4","title":"Cross-site scripting (XSS) vulnerability in plupload.flash.swf in Plupload before 2.1.9, as used...","description":"Cross-site scripting (XSS) vulnerability in plupload.flash.swf in Plupload before 2.1.9, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via a Same-Origin Method Execution (SOME) attack.","status":"published","published":"2022-05-17T03:35:09Z","modified":"2025-04-12T13:01:28Z","cvss":[{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T15:01:28.050499Z"}],"nvd":[{"id":"CVE-2016-4566","description":"Cross-site scripting (XSS) vulnerability in plupload.flash.swf in Plupload before 2.1.9, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via a Same-Origin Method Execution (SOME) attack.","status":"published","published":"2016-05-22T01:59:30.247Z","modified":"2026-06-17T00:47:47.947Z","cvss":[{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium","assessor":"primary"},{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:03:25.366449Z"}],"osv":[{"id":"CVE-2016-4566","description":"Cross-site scripting (XSS) vulnerability in plupload.flash.swf in Plupload before 2.1.9, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via a Same-Origin Method Execution (SOME) attack.","status":"published","published":"2016-05-22T01:59:30.247Z","modified":"2026-10-24T10:31:03.161038308Z","cvss":[{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium"}],"updated_at":"2026-11-02T15:44:02.454775Z"},{"id":"DEBIAN-CVE-2016-4566","description":"Cross-site scripting (XSS) vulnerability in plupload.flash.swf in Plupload before 2.1.9, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via a Same-Origin Method Execution (SOME) attack.","status":"published","published":"2016-05-22T01:59:30.247Z","modified":"2026-09-22T07:02:05.509906309Z","cvss":[{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium"}],"updated_at":"2026-11-02T15:45:27.627285Z"},{"id":"UBUNTU-CVE-2016-4566","description":"Cross-site scripting (XSS) vulnerability in plupload.flash.swf in Plupload before 2.1.9, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via a Same-Origin Method Execution (SOME) attack.","status":"published","published":"2016-05-22T01:59:00Z","modified":"2025-10-24T04:45:46Z","cvss":[{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium"}],"updated_at":"2026-11-02T15:54:12.261906Z"}]}}
