{"id":"CVE-2017-0357","aliases":["DEBIAN-CVE-2017-0357","EUVD-2017-0713","GHSA-29vx-f64r-92xh","UBUNTU-CVE-2017-0357","USN-3186-1","openSUSE-SU-2024:10867-1"],"status":"published","title":"iucode-tool: heap buffer overflow on -tr loader","description":"A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.","severity":{"version":"3.0","score":9.8,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.02838,"percentile":0.86737,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-119"],"published":"2017-01-17T00:00:00Z","modified":"2026-10-20T10:47:33Z","fixes":[{"ecosystem":"Debian:12","package":"iucode-tool","fixed_in":["2.1.1-1"],"sources":["osv"]},{"ecosystem":"Debian:13","package":"iucode-tool","fixed_in":["2.1.1-1"],"sources":["osv"]},{"ecosystem":"Debian:14","package":"iucode-tool","fixed_in":["2.1.1-1"],"sources":["osv"]},{"ecosystem":"Ubuntu:16.04:LTS","package":"iucode-tool","fixed_in":["1.5.1-1ubuntu0.1"],"sources":["osv"]},{"ecosystem":"openSUSE:Tumbleweed","package":"iucode-tool","fixed_in":["2.3.1-1.13"],"sources":["osv"]}],"affected":[{"source":"osv","ecosystem":"Debian:12","package":"iucode-tool","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"2.1.1-1"}]}]},{"source":"osv","ecosystem":"Debian:13","package":"iucode-tool","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"2.1.1-1"}]}]},{"source":"osv","ecosystem":"Debian:14","package":"iucode-tool","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"2.1.1-1"}]}]},{"source":"osv","ecosystem":"Ubuntu:16.04:LTS","package":"iucode-tool","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1.5.1-1ubuntu0.1"}]}],"versions":["1.3-1","1.5-1","1.5.1-1"]},{"source":"osv","ecosystem":"Ubuntu:16.04:LTS","package":"iucode-tool","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"1.5.1-1ubuntu0.1"}]}],"versions":["1.3-1","1.5-1","1.5.1-1"]},{"source":"osv","ecosystem":"openSUSE:Tumbleweed","package":"iucode-tool","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"2.3.1-1.13"}]}]}],"products":[{"vendor":"debian","product":"debian_linux"},{"vendor":"iucode-tool","product":"iucode-tool"},{"vendor":"iucode-tool_project","product":"iucode-tool"}],"references":[{"url":"https://security-tracker.debian.org/tracker/CVE-2017-0357","tags":["x_refsource_CONFIRM","x_transferred","Third Party Advisory","advisory"]},{"url":"https://gitlab.com/iucode-tool/iucode-tool/issues/3","tags":["x_refsource_CONFIRM","x_transferred","Patch","Third Party Advisory","fix","report"]},{"url":"http://www.securityfocus.com/bid/95432","tags":["vdb-entry","x_refsource_BID","x_transferred","Third Party Advisory","VDB Entry","advisory"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2017-0357"},{"url":"https://github.com/advisories/GHSA-29vx-f64r-92xh"},{"url":"https://ubuntu.com/security/CVE-2017-0357","tags":["report"]},{"url":"https://ubuntu.com/security/notices/USN-3186-1","tags":["advisory"]},{"url":"https://www.cve.org/CVERecord?id=CVE-2017-0357","tags":["report"]},{"url":"","tags":["advisory"]},{"url":"https://www.suse.com/security/cve/CVE-2017-0357","tags":["web"]}],"sources":{"cve":[{"id":"CVE-2017-0357","title":"iucode-tool: heap buffer overflow on -tr loader","description":"A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.","status":"published","published":"2018-04-13T15:00:00Z","modified":"2024-09-17T00:51:08.814Z","updated_at":"2026-11-02T14:33:22.381225Z"}],"euvd":[{"id":"EUVD-2017-0713","description":"A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.","status":"published","published":"2018-04-13T15:00:00Z","modified":"2024-09-17T00:51:08Z","updated_at":"2026-11-03T00:28:55.3353Z"}],"ghsa":[{"id":"GHSA-29vx-f64r-92xh","title":"A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1...","description":"A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.","status":"published","published":"2022-05-14T03:22:32Z","modified":"2023-02-02T05:08:08Z","cvss":[{"version":"3.0","score":9.8,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical"}],"cwes":["CWE-119"],"updated_at":"2026-11-02T14:52:40.390802Z"}],"nvd":[{"id":"CVE-2017-0357","description":"A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.","status":"published","published":"2018-04-13T15:29:00.337Z","modified":"2026-06-17T00:57:33.677Z","cvss":[{"version":"3.0","score":9.8,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical","assessor":"primary"},{"version":"2.0","score":7.5,"vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","level":"high","assessor":"primary"}],"cwes":["CWE-119"],"updated_at":"2026-11-02T14:04:17.032862Z"}],"osv":[{"id":"CVE-2017-0357","description":"A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.","status":"published","published":"2018-04-13T15:29:00.337Z","modified":"2026-10-20T10:47:33.12610762Z","cvss":[{"version":"3.0","score":9.8,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical"}],"updated_at":"2026-11-02T15:44:03.472693Z"},{"id":"DEBIAN-CVE-2017-0357","description":"A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.","status":"published","published":"2018-04-13T15:29:00.337Z","modified":"2026-09-01T20:03:40.55813072Z","cvss":[{"version":"3.0","score":9.8,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical"}],"updated_at":"2026-11-02T15:45:28.207321Z"},{"id":"UBUNTU-CVE-2017-0357","description":"A heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.","status":"published","published":"2017-01-17T00:00:00Z","modified":"2026-02-04T02:46:14.977441Z","cvss":[{"version":"3.0","score":9.8,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical"}],"updated_at":"2026-11-02T15:54:13.356796Z"},{"id":"openSUSE-SU-2024:10867-1","title":"iucode-tool-2.3.1-1.13 on GA media","description":"These are all security issues fixed in the iucode-tool-2.3.1-1.13 package on the GA media of openSUSE Tumbleweed.","status":"published","published":"2024-06-15T00:00:00Z","modified":"2026-02-04T02:15:18.598284Z","updated_at":"2026-11-02T16:58:34.894275Z"},{"id":"USN-3186-1","title":"iucode-tool vulnerability","description":"It was discovered that iucode-tool incorrectly handled certain microcodes\nwhen using the -tr loader. If a user were tricked into processing a\nspecially crafted microcode, a remote attacker could use this issue to\ncause iucode-tool to crash, resulting in a denial of service, or possibly\nexecute arbitrary code.\n","status":"published","published":"2017-02-01T18:23:17Z","modified":"2026-02-10T04:41:05Z","updated_at":"2026-11-02T16:58:10.303275Z"}]}}
