{"id":"CVE-2017-1000488","aliases":["EUVD-2021-0512","GHSA-qjhr-c23f-w76q"],"status":"published","title":"Inline JS XSS vulnerability in Mautic","description":"Mautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.","severity":{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-08","score":0.00843,"percentile":0.58198,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-79"],"published":"2018-01-03T16:00:00Z","modified":"2026-10-24T10:48:54Z","fixes":[{"ecosystem":"Packagist","package":"mautic/core","fixed_in":["2.12.0"],"sources":["ghsa","osv"]}],"affected":[{"source":"ghsa","ecosystem":"Packagist","package":"mautic/core","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"2.1.0"},{"fixed":"2.12.0"}]}]},{"source":"osv","ecosystem":"Packagist","package":"mautic/core","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"2.1.0"},{"fixed":"2.12.0"}]}],"versions":["2.1.0","2.1.1","2.10.0","2.10.0-beta","2.10.1","2.11.0","2.11.0-beta","2.12.0-beta","2.2.0","2.2.1","2.3.0","2.4.0","2.5.0","2.5.1","2.6.0","2.6.1","2.7.0","2.7.1","2.8.0","2.8.1","2.8.2","2.9.0","2.9.0-beta","2.9.1","2.9.2"]}],"products":[{"vendor":"acquia","product":"mautic"},{"vendor":"mautic","product":"mautic"}],"references":[{"url":"https://github.com/mautic/mautic/releases/tag/2.12.0","tags":["x_refsource_MISC","x_transferred","Exploit","Release Notes","Third Party Advisory","evidence","web"]},{"url":"https://github.com/mautic/mautic/security/advisories/GHSA-qjhr-c23f-w76q","tags":["web"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2017-1000488","tags":["advisory"]},{"url":"https://github.com/mautic/mautic/commit/bda60c0eefbd19c759589e975e63ab1d201c1b8e","tags":["web"]},{"url":"https://github.com/advisories/GHSA-qjhr-c23f-w76q"}],"sources":{"cve":[{"id":"CVE-2017-1000488","description":"Mautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.","status":"published","published":"2018-01-03T16:00:00Z","modified":"2024-09-16T23:46:50.151Z","updated_at":"2026-11-02T14:33:21.142987Z"}],"euvd":[{"id":"EUVD-2021-0512","description":"Mautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.","status":"published","published":"2018-01-03T16:00:00Z","modified":"2024-09-16T23:46:50Z","updated_at":"2026-11-03T00:29:04.923307Z"}],"ghsa":[{"id":"GHSA-qjhr-c23f-w76q","title":"Inline JS XSS vulnerability in Mautic","description":"### Impact\n\nMautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.\n\n### Patches\nUpgrade to 2.12.0 or later.\n\n### Workarounds\nNone\n\n### References\nhttps://github.com/mautic/mautic/releases/tag/2.12.0\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Email us at [security@mautic.org](mailto:security@mautic.org)","status":"published","published":"2021-01-19T21:16:24Z","modified":"2023-02-01T05:05:05Z","cvss":[{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:36:32.918681Z"}],"nvd":[{"id":"CVE-2017-1000488","description":"Mautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.","status":"published","published":"2018-01-03T16:29:00.183Z","modified":"2026-06-17T00:59:15.773Z","cvss":[{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium","assessor":"primary"},{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:04:12.690425Z"}],"osv":[{"id":"CVE-2017-1000488","description":"Mautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.","status":"published","published":"2018-01-03T16:29:00.183Z","modified":"2026-10-24T10:48:54.217306707Z","cvss":[{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium"}],"updated_at":"2026-11-02T15:44:03.851821Z"},{"id":"GHSA-qjhr-c23f-w76q","title":"Inline JS XSS vulnerability in Mautic","description":"### Impact\n\nMautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.\n\n### Patches\nUpgrade to 2.12.0 or later.\n\n### Workarounds\nNone\n\n### References\nhttps://github.com/mautic/mautic/releases/tag/2.12.0\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Email us at [security@mautic.org](mailto:security@mautic.org)","status":"published","published":"2021-01-19T21:16:24Z","modified":"2023-11-08T03:58:47.335813Z","cvss":[{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T15:46:54.760124Z"}]}}
