{"id":"CVE-2017-14721","aliases":["DEBIAN-CVE-2017-14721","DLA-1151-1","DSA-3997-1","EUVD-2017-6218","GHSA-xw73-224j-wrf4","UBUNTU-CVE-2017-14721"],"status":"published","title":"Before version 4.8.2, WordPress allowed Cross-Site scripting in the plugin editor via a crafted...","description":"Before version 4.8.2, WordPress allowed Cross-Site scripting in the plugin editor via a crafted plugin name.","severity":{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.02123,"percentile":0.82002,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-79"],"published":"2017-09-23T20:00:00Z","modified":"2026-10-24T10:30:52Z","fixes":[{"ecosystem":"Debian:12","package":"wordpress","fixed_in":["4.8.2+dfsg-1"],"sources":["osv"]},{"ecosystem":"Debian:13","package":"wordpress","fixed_in":["4.8.2+dfsg-1"],"sources":["osv"]},{"ecosystem":"Debian:14","package":"wordpress","fixed_in":["4.8.2+dfsg-1"],"sources":["osv"]}],"affected":[{"source":"osv","ecosystem":"Debian:12","package":"wordpress","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"4.8.2+dfsg-1"}]}]},{"source":"osv","ecosystem":"Debian:13","package":"wordpress","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"4.8.2+dfsg-1"}]}]},{"source":"osv","ecosystem":"Debian:14","package":"wordpress","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"4.8.2+dfsg-1"}]}]},{"source":"osv","ecosystem":"Debian:7","package":"wordpress","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"3.6.1+dfsg-1~deb7u17"}]}],"versions":["3.5.1+dfsg-2","3.5.2+dfsg-1","3.5.2+dfsg-1~deb6u1","3.5.2+dfsg-1~deb7u1","3.6+dfsg-1","3.6.1+dfsg-1~deb6u1","3.6.1+dfsg-1~deb6u2","3.6.1+dfsg-1~deb6u3","3.6.1+dfsg-1~deb6u4","3.6.1+dfsg-1~deb6u5","3.6.1+dfsg-1~deb6u6","3.6.1+dfsg-1~deb6u7","3.6.1+dfsg-1~deb6u8","3.6.1+dfsg-1~deb6u9","3.6.1+dfsg-1~deb7u1","3.6.1+dfsg-1~deb7u10","3.6.1+dfsg-1~deb7u11","3.6.1+dfsg-1~deb7u12","3.6.1+dfsg-1~deb7u13","3.6.1+dfsg-1~deb7u14","3.6.1+dfsg-1~deb7u15","3.6.1+dfsg-1~deb7u16","3.6.1+dfsg-1~deb7u2","3.6.1+dfsg-1~deb7u3","3.6.1+dfsg-1~deb7u4","3.6.1+dfsg-1~deb7u5","3.6.1+dfsg-1~deb7u6","3.6.1+dfsg-1~deb7u8","3.6.1+dfsg-1~deb7u9"],"bundled":8},{"source":"osv","ecosystem":"Debian:8","package":"wordpress","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"4.1+dfsg-1+deb8u15"}]}],"versions":["4.1+dfsg-1","4.1+dfsg-1+deb8u1","4.1+dfsg-1+deb8u10","4.1+dfsg-1+deb8u11","4.1+dfsg-1+deb8u12","4.1+dfsg-1+deb8u13","4.1+dfsg-1+deb8u14","4.1+dfsg-1+deb8u2","4.1+dfsg-1+deb8u3","4.1+dfsg-1+deb8u4","4.1+dfsg-1+deb8u5","4.1+dfsg-1+deb8u6","4.1+dfsg-1+deb8u7","4.1+dfsg-1+deb8u8","4.1+dfsg-1+deb8u9"],"bundled":9},{"source":"osv","ecosystem":"Debian:9","package":"wordpress","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"4.7.5+dfsg-2+deb9u1"}]}],"versions":["4.7.5+dfsg-2","4.7.5+dfsg-2+deb9u1~bpo8+1"],"bundled":9},{"source":"osv","ecosystem":"Ubuntu:16.04:LTS","package":"wordpress","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"}]}],"versions":["4.3+dfsg-1","4.3.1+dfsg-1","4.4+dfsg-1","4.4.1+dfsg-1","4.4.2+dfsg-1","4.4.2+dfsg-1ubuntu1"]}],"products":[{"vendor":"wordpress","product":"wordpress"}],"references":[{"url":"https://www.debian.org/security/2017/dsa-3997","tags":["vendor-advisory","x_refsource_DEBIAN","x_transferred","advisory"]},{"url":"http://www.securityfocus.com/bid/100912","tags":["vdb-entry","x_refsource_BID","x_transferred","Third Party Advisory","VDB Entry","advisory"]},{"url":"http://www.securitytracker.com/id/1039553","tags":["vdb-entry","x_refsource_SECTRACK","x_transferred","web"]},{"url":"https://wordpress.org/news/2017/09/wordpress-4-8-2-security-and-maintenance-release/","tags":["x_refsource_MISC","x_transferred","Patch","Release Notes","Vendor Advisory","fix","report"]},{"url":"https://core.trac.wordpress.org/changeset/41412","tags":["x_refsource_MISC","x_transferred","Patch","Vendor Advisory","fix","report"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2017-14721"},{"url":"https://wordpress.org/news/2017/09/wordpress-4-8-2-security-and-maintenance-release"},{"url":"https://github.com/advisories/GHSA-xw73-224j-wrf4"},{"url":"https://security-tracker.debian.org/tracker/CVE-2017-14721","tags":["advisory"]},{"url":"https://ubuntu.com/security/CVE-2017-14721","tags":["report"]},{"url":"https://www.cve.org/CVERecord?id=CVE-2017-14721","tags":["report"]}],"sources":{"cve":[{"id":"CVE-2017-14721","description":"Before version 4.8.2, WordPress allowed Cross-Site scripting in the plugin editor via a crafted plugin name.","status":"published","published":"2017-09-23T20:00:00Z","modified":"2024-08-05T19:34:39.851Z","updated_at":"2026-11-02T14:33:12.267141Z"}],"euvd":[{"id":"EUVD-2017-6218","description":"Before version 4.8.2, WordPress allowed Cross-Site scripting in the plugin editor via a crafted plugin name.","status":"published","published":"2017-09-23T20:00:00Z","modified":"2024-08-05T19:34:39Z","updated_at":"2026-11-03T02:23:16.177631Z"}],"ghsa":[{"id":"GHSA-xw73-224j-wrf4","title":"Before version 4.8.2, WordPress allowed Cross-Site scripting in the plugin editor via a crafted...","description":"Before version 4.8.2, WordPress allowed Cross-Site scripting in the plugin editor via a crafted plugin name.","status":"published","published":"2022-05-17T00:25:07Z","modified":"2025-04-20T03:46:50Z","cvss":[{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T15:01:53.348802Z"}],"nvd":[{"id":"CVE-2017-14721","description":"Before version 4.8.2, WordPress allowed Cross-Site scripting in the plugin editor via a crafted plugin name.","status":"published","published":"2017-09-23T20:29:00.343Z","modified":"2026-06-17T01:06:40.333Z","cvss":[{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium","assessor":"primary"},{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:03:59.716532Z"}],"osv":[{"id":"CVE-2017-14721","description":"Before version 4.8.2, WordPress allowed Cross-Site scripting in the plugin editor via a crafted plugin name.","status":"published","published":"2017-09-23T20:29:00.343Z","modified":"2026-10-24T10:30:52.58190326Z","cvss":[{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium"}],"updated_at":"2026-11-02T15:44:04.572713Z"},{"id":"DEBIAN-CVE-2017-14721","description":"Before version 4.8.2, WordPress allowed Cross-Site scripting in the plugin editor via a crafted plugin name.","status":"published","published":"2017-09-23T20:29:00.343Z","modified":"2026-09-01T20:03:44.106654555Z","cvss":[{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium"}],"updated_at":"2026-11-02T15:45:28.801885Z"},{"id":"UBUNTU-CVE-2017-14721","description":"Before version 4.8.2, WordPress allowed Cross-Site scripting in the plugin editor via a crafted plugin name.","status":"published","published":"2017-09-23T20:29:00Z","modified":"2025-10-24T04:46:31Z","cvss":[{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium"}],"updated_at":"2026-11-02T15:54:14.563448Z"},{"id":"DLA-1151-1","title":"wordpress - security update","status":"published","published":"2017-10-31T00:00:00Z","modified":"2026-03-09T01:01:54.996523Z","updated_at":"2026-11-02T15:46:09.336894Z"},{"id":"DSA-3997-1","title":"wordpress - security update","status":"published","published":"2017-10-10T00:00:00Z","modified":"2026-03-09T02:11:31.400923Z","updated_at":"2026-11-02T15:46:16.523846Z"}]}}
