{"id":"CVE-2017-15719","aliases":["EUVD-2022-4840","GHSA-pwpc-hqq2-hx2x"],"status":"published","title":"Cross-site Scripting in wicket-jquery-ui","description":"In Wicket jQuery UI 6.28.0 and earlier, 7.9.1 and earlier, and 8.0.0-M8 and earlier, a security issue has been discovered in the WYSIWYG editor that allows an attacker to submit arbitrary JS code to WYSIWYG editor.","severity":{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.00874,"percentile":0.59158,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-79"],"published":"2018-03-12T13:00:00Z","modified":"2026-10-24T10:30:25Z","fixes":[{"ecosystem":"Maven","package":"com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent","fixed_in":["6.28.1","7.9.2","8.0.0-M8.1"],"sources":["ghsa","osv"]}],"affected":[{"source":"ghsa","ecosystem":"Maven","package":"com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"6.28.1"}]}]},{"source":"ghsa","ecosystem":"Maven","package":"com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"7.0.0"},{"fixed":"7.9.2"}]}]},{"source":"ghsa","ecosystem":"Maven","package":"com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"8.0.0-M1"},{"fixed":"8.0.0-M8.1"}]}]},{"source":"osv","ecosystem":"Maven","package":"com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"6.28.1"}]}],"versions":["1.5.10","1.5.11","6.10.0","6.11.0","6.12.0","6.13.0","6.13.1","6.14.0","6.15.0","6.16.0","6.17.0","6.18.0","6.18.1","6.19.0","6.19.1","6.19.2","6.19.3","6.20.0","6.20.1","6.20.2","6.20.3","6.21.0","6.21.1","6.21.2","6.22.0","6.22.1","6.22.2","6.23.0","6.24.0","6.25.0","6.25.1","6.26.0","6.27.0","6.28.0","6.7.0","6.8.0","6.8.1","6.9.0","6.9.1"]},{"source":"osv","ecosystem":"Maven","package":"com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"7.0.0"},{"fixed":"7.9.2"}]}],"versions":["7.0.0","7.0.1","7.0.2","7.1.0","7.2.0","7.2.1","7.3.0","7.3.1","7.4.0","7.5.0","7.6.0","7.7.0","7.8.0","7.9.0","7.9.1"]},{"source":"osv","ecosystem":"Maven","package":"com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"8.0.0-M1"},{"fixed":"8.0.0-M8.1"}]}],"versions":["8.0.0-M1","8.0.0-M1.1","8.0.0-M2","8.0.0-M3","8.0.0-M4","8.0.0-M4.1","8.0.0-M5","8.0.0-M6","8.0.0-M7","8.0.0-M8"]}],"products":[{"vendor":"apache software foundation","product":"wicket jquery ui"},{"vendor":"wicket-jquery-ui_project","product":"wicket-jquery-ui"}],"references":[{"url":"https://github.com/sebfz1/wicket-jquery-ui/wiki#cve-2017-15719---xss-in-wysiwyg-editor","tags":["x_refsource_CONFIRM","x_transferred","Third Party Advisory","advisory","web"]},{"url":"http://openmeetings.apache.org/security.html#_toc_cve-2017-15719_-_wicket_jquery_ui_xss_in_wysiwyg_e","tags":["x_refsource_CONFIRM","x_transferred","Third Party Advisory","advisory","web"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2017-15719","tags":["advisory"]},{"url":"https://github.com/advisories/GHSA-pwpc-hqq2-hx2x"}],"sources":{"cve":[{"id":"CVE-2017-15719","description":"In Wicket jQuery UI 6.28.0 and earlier, 7.9.1 and earlier, and 8.0.0-M8 and earlier, a security issue has been discovered in the WYSIWYG editor that allows an attacker to submit arbitrary JS code to WYSIWYG editor.","status":"published","published":"2018-03-12T13:00:00Z","modified":"2024-09-17T02:11:55.065Z","updated_at":"2026-11-02T14:33:14.556599Z"}],"euvd":[{"id":"EUVD-2022-4840","description":"In Wicket jQuery UI 6.28.0 and earlier, 7.9.1 and earlier, and 8.0.0-M8 and earlier, a security issue has been discovered in the WYSIWYG editor that allows an attacker to submit arbitrary JS code to WYSIWYG editor.","status":"published","published":"2018-03-12T13:00:00Z","modified":"2024-09-17T02:11:55Z","updated_at":"2026-11-03T00:28:42.412483Z"}],"ghsa":[{"id":"GHSA-pwpc-hqq2-hx2x","title":"Cross-site Scripting in wicket-jquery-ui","description":"In Wicket jQuery UI 6.28.0 and earlier, 7.9.1 and earlier, and 8.0.0-M8 and earlier, a security issue has been discovered in the WYSIWYG editor that allows an attacker to submit arbitrary JS code to WYSIWYG editor.","status":"published","published":"2022-05-14T00:58:28Z","modified":"2023-02-01T05:04:19Z","cvss":[{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:36:32.120868Z"}],"nvd":[{"id":"CVE-2017-15719","description":"In Wicket jQuery UI 6.28.0 and earlier, 7.9.1 and earlier, and 8.0.0-M8 and earlier, a security issue has been discovered in the WYSIWYG editor that allows an attacker to submit arbitrary JS code to WYSIWYG editor.","status":"published","published":"2018-03-12T13:29:00.273Z","modified":"2026-06-17T01:08:09.67Z","cvss":[{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium","assessor":"primary"},{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:04:16.247048Z"}],"osv":[{"id":"CVE-2017-15719","description":"In Wicket jQuery UI 6.28.0 and earlier, 7.9.1 and earlier, and 8.0.0-M8 and earlier, a security issue has been discovered in the WYSIWYG editor that allows an attacker to submit arbitrary JS code to WYSIWYG editor.","status":"published","published":"2018-03-12T13:29:00.273Z","modified":"2026-10-24T10:30:25.463001872Z","cvss":[{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium"}],"updated_at":"2026-11-02T15:44:04.853379Z"},{"id":"GHSA-pwpc-hqq2-hx2x","title":"Cross-site Scripting in wicket-jquery-ui","description":"In Wicket jQuery UI 6.28.0 and earlier, 7.9.1 and earlier, and 8.0.0-M8 and earlier, a security issue has been discovered in the WYSIWYG editor that allows an attacker to submit arbitrary JS code to WYSIWYG editor.","status":"published","published":"2022-05-14T00:58:28Z","modified":"2023-11-08T03:58:58.731157Z","cvss":[{"version":"3.0","score":6.1,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T15:46:53.700556Z"}]}}
