{"id":"CVE-2017-20206","aliases":["EUVD-2017-18924","GHSA-7mpm-gf56-q8wv"],"status":"published","title":"Appointments \u003c= 2.2.1 - Unauthenticated PHP Object Injection","description":"The Appointments plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 2.2.1 via deserialization of untrusted input from the `wpmudev_appointments` cookie. This allows unauthenticated attackers to inject a PHP Object. Attackers were actively exploiting this vulnerability with the WP_Theme() class to create backdoors.","severity":{"version":"3.1","score":9.8,"vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical","assessor":"cna","from":"cve"},"epss":{"day":"2026-11-07","score":0.00735,"percentile":0.54662,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":false},"cwes":["CWE-502"],"published":"2025-10-18T03:33:24Z","modified":"2026-06-17T01:15:24Z","products":[{"vendor":"wpmudev","product":"appointments"}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/7e8f230e-3f96-4efd-806d-72725b960303?source=cve","tags":["Third Party Advisory"]},{"url":"https://www.wordfence.com/blog/2017/10/3-zero-day-plugin-vulnerabilities-exploited-wild/","tags":["Press/Media Coverage","Third Party Advisory"]},{"url":"https://plugins.trac.wordpress.org/changeset/1733186/appointments","tags":["Patch"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2017-20206"},{"url":"https://www.wordfence.com/blog/2017/10/3-zero-day-plugin-vulnerabilities-exploited-wild"},{"url":"https://github.com/advisories/GHSA-7mpm-gf56-q8wv"}],"sources":{"cve":[{"id":"CVE-2017-20206","title":"Appointments \u003c= 2.2.1 - Unauthenticated PHP Object Injection","description":"The Appointments plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 2.2.1 via deserialization of untrusted input from the `wpmudev_appointments` cookie. This allows unauthenticated attackers to inject a PHP Object. Attackers were actively exploiting this vulnerability with the WP_Theme() class to create backdoors.","status":"published","published":"2025-10-18T03:33:24.194Z","modified":"2026-04-08T17:03:10.542Z","cvss":[{"version":"3.1","score":9.8,"vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical","assessor":"cna"}],"cwes":["CWE-502"],"updated_at":"2026-11-02T14:33:11.59359Z"}],"euvd":[{"id":"EUVD-2017-18924","description":"The Appointments plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 2.2.1 via deserialization of untrusted input from the `wpmudev_appointments` cookie. This allows unauthenticated attackers to inject a PHP Object. Attackers were actively exploiting this vulnerability with the WP_Theme() class to create backdoors.","status":"published","published":"2025-10-18T03:33:24Z","modified":"2026-04-08T17:03:10Z","cvss":[{"version":"3.1","score":9.8,"vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical"}],"updated_at":"2026-11-02T19:24:52.04573Z"}],"ghsa":[{"id":"GHSA-7mpm-gf56-q8wv","title":"The Appointments plugin for WordPress is vulnerable to PHP Object Injection in versions up to,...","description":"The Appointments plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 2.2.1 via deserialization of untrusted input from the `wpmudev_appointments` cookie. This allows unauthenticated attackers to inject a PHP Object. Attackers were actively exploiting this vulnerability with the WP_Theme() class to create backdoors.","status":"published","published":"2025-10-18T06:30:25Z","modified":"2025-10-18T06:30:31Z","cvss":[{"version":"3.1","score":9.8,"vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical"}],"cwes":["CWE-502"],"updated_at":"2026-11-02T15:04:01.823376Z"}],"nvd":[{"id":"CVE-2017-20206","description":"The Appointments plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 2.2.1 via deserialization of untrusted input from the `wpmudev_appointments` cookie. This allows unauthenticated attackers to inject a PHP Object. Attackers were actively exploiting this vulnerability with the WP_Theme() class to create backdoors.","status":"published","published":"2025-10-18T04:15:43.243Z","modified":"2026-06-17T01:15:24.563Z","cvss":[{"version":"3.1","score":9.8,"vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical","assessor":"secondary"}],"cwes":["CWE-502"],"updated_at":"2026-11-02T14:04:21.76411Z"}]}}
