{"id":"CVE-2017-2096","aliases":["EUVD-2022-3682","GHSA-f489-655r-x6gr"],"status":"published","title":"smalruby and smalruby-editor vulnerable to OS Command Injection","description":"smalruby-editor v0.4.0 and earlier allows remote attackers to execute arbitrary OS commands via unspecified vectors.","severity":{"version":"3.1","score":9.8,"vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-08","score":0.06183,"percentile":0.93543,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":true},"cwes":["CWE-78"],"published":"2017-04-28T16:00:00Z","modified":"2026-10-24T10:30:45Z","fixes":[{"ecosystem":"RubyGems","package":"smalruby-editor","fixed_in":["0.4.1"],"sources":["ghsa","osv"]},{"ecosystem":"RubyGems","package":"smalruby","fixed_in":["0.1.11"],"sources":["ghsa","osv"]}],"affected":[{"source":"ghsa","ecosystem":"RubyGems","package":"smalruby-editor","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"0.4.1"}]}]},{"source":"ghsa","ecosystem":"RubyGems","package":"smalruby","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"0.1.11"}]}]},{"source":"osv","ecosystem":"RubyGems","package":"smalruby-editor","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"0.4.1"}]}],"versions":["0.0.1","0.0.10","0.0.11","0.0.12","0.0.2","0.0.3","0.0.4","0.0.5","0.0.6","0.0.7","0.0.8","0.0.9","0.1.0","0.1.1","0.1.10","0.1.11","0.1.12","0.1.13","0.1.14","0.1.15","0.1.16","0.1.17","0.1.18","0.1.19","0.1.2","0.1.20","0.1.21","0.1.22","0.1.23","0.1.24","0.1.3","0.1.4","0.1.5","0.1.6","0.1.7","0.1.8","0.1.9","0.2.0","0.2.1","0.2.2","0.2.3","0.2.4","0.2.5","0.2.6","0.2.7","0.3.0","0.3.1","0.3.2","0.3.3","0.3.4","0.3.5","0.4.0"]},{"source":"osv","ecosystem":"RubyGems","package":"smalruby","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"0.1.11"}]}],"versions":["0.0.1","0.0.10","0.0.11","0.0.12","0.0.13","0.0.14","0.0.15","0.0.16","0.0.17","0.0.18","0.0.19","0.0.2","0.0.20","0.0.21","0.0.22","0.0.23","0.0.24","0.0.25","0.0.26","0.0.27","0.0.28","0.0.29","0.0.3","0.0.30","0.0.31","0.0.32","0.0.4","0.0.5","0.0.6","0.0.7","0.0.8","0.0.9","0.1.0","0.1.1","0.1.10","0.1.2","0.1.3","0.1.4","0.1.5","0.1.6","0.1.7","0.1.8","0.1.9"]}],"products":[{"vendor":"ruby programming shounendan","product":"smalruby-editor"},{"vendor":"smalruby","product":"smalruby-editor"}],"references":[{"url":"http://jvn.jp/en/jp/JVN50197114/index.html","tags":["third-party-advisory","x_refsource_JVN","x_transferred","Third Party Advisory","VDB Entry","advisory","web"]},{"url":"http://www.securityfocus.com/bid/95775","tags":["vdb-entry","x_refsource_BID","x_transferred","Third Party Advisory","VDB Entry","advisory"]},{"url":"http://smalruby.jp/blog/2017/01/14/smalruby-editor-0-4-1-has-been-released-english.html","tags":["x_refsource_MISC","x_transferred","Release Notes","Vendor Advisory","advisory","web"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2017-2096","tags":["advisory"]},{"url":"https://web.archive.org/web/20200227194312/http://www.securityfocus.com/bid/95775","tags":["web"]},{"url":"https://github.com/rubysec/ruby-advisory-db/blob/master/gems/smalruby/CVE-2017-2096.yml","tags":["web"]},{"url":"https://github.com/advisories/GHSA-f489-655r-x6gr"},{"url":"https://github.com/smalruby/smalruby-editor","tags":["package"]}],"sources":{"cve":[{"id":"CVE-2017-2096","description":"smalruby-editor v0.4.0 and earlier allows remote attackers to execute arbitrary OS commands via unspecified vectors.","status":"published","published":"2017-04-28T16:00:00Z","modified":"2024-08-05T13:39:32.293Z","updated_at":"2026-11-02T14:33:15.543086Z"}],"euvd":[{"id":"EUVD-2022-3682","description":"smalruby-editor v0.4.0 and earlier allows remote attackers to execute arbitrary OS commands via unspecified vectors.","status":"published","published":"2017-04-28T16:00:00Z","modified":"2024-08-05T13:39:32Z","updated_at":"2026-11-03T02:39:22.420171Z"}],"ghsa":[{"id":"GHSA-f489-655r-x6gr","title":"smalruby and smalruby-editor vulnerable to OS Command Injection","description":"smalruby-editor prior to 0.4.1 and smalruby prior to 0.1.11 allows remote attackers to execute arbitrary OS commands via unspecified vectors.","status":"published","published":"2022-05-13T01:16:27Z","modified":"2023-03-06T20:43:52Z","cvss":[{"version":"3.1","score":9.8,"vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical"}],"cwes":["CWE-78"],"updated_at":"2026-11-02T14:36:47.279442Z"}],"nvd":[{"id":"CVE-2017-2096","description":"smalruby-editor v0.4.0 and earlier allows remote attackers to execute arbitrary OS commands via unspecified vectors.","status":"published","published":"2017-04-28T16:59:00.577Z","modified":"2026-06-17T01:15:32.63Z","cvss":[{"version":"3.1","score":9.8,"vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical","assessor":"primary"},{"version":"2.0","score":10,"vector":"AV:N/AC:L/Au:N/C:C/I:C/A:C","level":"high","assessor":"primary"}],"cwes":["CWE-78"],"updated_at":"2026-11-02T14:03:46.08744Z"}],"osv":[{"id":"CVE-2017-2096","description":"smalruby-editor v0.4.0 and earlier allows remote attackers to execute arbitrary OS commands via unspecified vectors.","status":"published","published":"2017-04-28T16:59:00.577Z","modified":"2026-10-24T10:30:45.811350172Z","cvss":[{"version":"3.1","score":9.8,"vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical"}],"updated_at":"2026-11-02T15:44:05.486486Z"},{"id":"GHSA-f489-655r-x6gr","title":"smalruby and smalruby-editor vulnerable to OS Command Injection","description":"smalruby-editor prior to 0.4.1 and smalruby prior to 0.1.11 allows remote attackers to execute arbitrary OS commands via unspecified vectors.","status":"published","published":"2022-05-13T01:16:27Z","modified":"2023-11-08T03:59:18.087584Z","cvss":[{"version":"3.1","score":9.8,"vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical"}],"cwes":["CWE-78"],"updated_at":"2026-11-02T15:46:46.006631Z"}]}}
