{"id":"CVE-2017-7512","aliases":["EUVD-2017-16529","GHSA-6574-p8rp-gxqh","MGASA-2017-0224"],"status":"published","title":"Red Hat 3scale (aka RH-3scale) API Management Platform (AMP) before 2.0.0 would permit creation...","description":"Red Hat 3scale (aka RH-3scale) API Management Platform (AMP) before 2.0.0 would permit creation of an access token without a client secret. An attacker could use this flaw to circumvent authentication controls and gain access to restricted APIs. NOTE: some sources have a typo in which CVE-2017-7512 maps to an OpenVPN vulnerability. The proper CVE ID for that OpenVPN vulnerability is CVE-2017-7521. Specifically, CVE-2017-7521 is the correct CVE ID for TWO closely related findings in OpenVPN. Any source that lists BOTH CVE-2017-7512 and CVE-2017-7521 for OpenVPN should have listed ONLY CVE-2017-7521.","severity":{"version":"3.0","score":9.8,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-08","score":0.02163,"percentile":0.82351,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":false},"cwes":["CWE-863"],"published":"2017-07-07T22:00:00Z","modified":"2026-06-17T01:24:30Z","affected":[{"source":"osv","ecosystem":"Mageia:5","package":"openvpn","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"fixed":"2.3.17-1.mga5"}]}],"bundled":4}],"products":[{"vendor":"redhat","product":"3scale_api_management_platform"}],"references":[{"url":"https://access.redhat.com/security/cve/cve-2017-7512","tags":["x_refsource_CONFIRM","x_transferred","Vendor Advisory"]},{"url":"https://access.redhat.com/errata/RHSA-2017:1712","tags":["vendor-advisory","x_refsource_REDHAT","x_transferred"]},{"url":"https://bugzilla.redhat.com/show_bug.cgi?id=1457997","tags":["x_refsource_CONFIRM","x_transferred","Issue Tracking","Vendor Advisory"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2017-7512"},{"url":"https://github.com/advisories/GHSA-6574-p8rp-gxqh"},{"url":"https://advisories.mageia.org/MGASA-2017-0224.html","tags":["advisory"]},{"url":"https://bugs.mageia.org/show_bug.cgi?id=21125","tags":["report"]},{"url":"https://community.openvpn.net/openvpn/wiki/VulnerabilitiesFixedInOpenVPN243","tags":["web"]},{"url":"https://lists.opensuse.org/opensuse-security-announce/2017-06/msg00027.html","tags":["web"]},{"url":"https://www.ubuntu.com/usn/usn-3339-1/","tags":["web"]}],"sources":{"cve":[{"id":"CVE-2017-7512","description":"Red Hat 3scale (aka RH-3scale) API Management Platform (AMP) before 2.0.0 would permit creation of an access token without a client secret. An attacker could use this flaw to circumvent authentication controls and gain access to restricted APIs. NOTE: some sources have a typo in which CVE-2017-7512 maps to an OpenVPN vulnerability. The proper CVE ID for that OpenVPN vulnerability is CVE-2017-7521. Specifically, CVE-2017-7521 is the correct CVE ID for TWO closely related findings in OpenVPN. Any source that lists BOTH CVE-2017-7512 and CVE-2017-7521 for OpenVPN should have listed ONLY CVE-2017-7521.","status":"published","published":"2017-07-07T22:00:00Z","modified":"2024-08-05T16:04:11.853Z","updated_at":"2026-11-02T14:33:20.843976Z"}],"euvd":[{"id":"EUVD-2017-16529","description":"Red Hat 3scale (aka RH-3scale) API Management Platform (AMP) before 2.0.0 would permit creation of an access token without a client secret. An attacker could use this flaw to circumvent authentication controls and gain access to restricted APIs. NOTE: some sources have a typo in which CVE-2017-7512 maps to an OpenVPN vulnerability. The proper CVE ID for that OpenVPN vulnerability is CVE-2017-7521. Specifically, CVE-2017-7521 is the correct CVE ID for TWO closely related findings in OpenVPN. Any source that lists BOTH CVE-2017-7512 and CVE-2017-7521 for OpenVPN should have listed ONLY CVE-2017-7521.","status":"published","published":"2017-07-07T22:00:00Z","modified":"2024-08-05T16:04:11Z","updated_at":"2026-11-03T02:39:08.024596Z"}],"ghsa":[{"id":"GHSA-6574-p8rp-gxqh","title":"Red Hat 3scale (aka RH-3scale) API Management Platform (AMP) before 2.0.0 would permit creation...","description":"Red Hat 3scale (aka RH-3scale) API Management Platform (AMP) before 2.0.0 would permit creation of an access token without a client secret. An attacker could use this flaw to circumvent authentication controls and gain access to restricted APIs. NOTE: some sources have a typo in which CVE-2017-7512 maps to an OpenVPN vulnerability. The proper CVE ID for that OpenVPN vulnerability is CVE-2017-7521. Specifically, CVE-2017-7521 is the correct CVE ID for TWO closely related findings in OpenVPN. Any source that lists BOTH CVE-2017-7512 and CVE-2017-7521 for OpenVPN should have listed ONLY CVE-2017-7521.","status":"published","published":"2022-05-13T01:46:59Z","modified":"2023-02-02T05:01:34Z","cvss":[{"version":"3.0","score":9.8,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical"}],"cwes":["CWE-863"],"updated_at":"2026-11-02T14:51:12.922336Z"}],"nvd":[{"id":"CVE-2017-7512","description":"Red Hat 3scale (aka RH-3scale) API Management Platform (AMP) before 2.0.0 would permit creation of an access token without a client secret. An attacker could use this flaw to circumvent authentication controls and gain access to restricted APIs. NOTE: some sources have a typo in which CVE-2017-7512 maps to an OpenVPN vulnerability. The proper CVE ID for that OpenVPN vulnerability is CVE-2017-7521. Specifically, CVE-2017-7521 is the correct CVE ID for TWO closely related findings in OpenVPN. Any source that lists BOTH CVE-2017-7512 and CVE-2017-7521 for OpenVPN should have listed ONLY CVE-2017-7521.","status":"published","published":"2017-07-07T22:29:00.177Z","modified":"2026-06-17T01:24:30.013Z","cvss":[{"version":"3.0","score":9.8,"vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","level":"critical","assessor":"primary"},{"version":"2.0","score":7.5,"vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","level":"high","assessor":"primary"}],"cwes":["CWE-863"],"updated_at":"2026-11-02T14:03:54.012105Z"}],"osv":[{"id":"MGASA-2017-0224","title":"Updated openvpn packages fix security vulnerabilities","description":"It was possible to trigger an assertion by sending a malformed IPv6\npacket. That issue could have been abused to remotely shutdown an\nopenvpn server or client, if IPv6 and --mssfix were enabled and if the\nIPv6 networks used inside the VPN were known (CVE-2017-7508).\n\nSome parts of the certificate-parsing code did not always clear all\nallocated memory. This would have allowed clients to leak a few bytes of\nmemory for each connection attempt, thereby facilitating a (quite\ninefficient) DoS attack on the server (CVE-2017-7512).\n\nIf clients used a HTTP proxy with NTLM authentication, a\nman-in-the-middle attacker between client and proxy could cause the\nclient to crash or disclose at most 96 bytes of stack memory. The\ndisclosed stack memory was likely to contain the proxy password. If the\nproxy password had not been reused, this was unlikely to compromise the\nsecurity of the OpenVPN tunnel itself. Clients who did not use the\n--http-proxy option with ntlm2 authentication were not affected\n(CVE-2017-7520).\n\nThe ASN1 parsing code contained a bug that could have resulted in some\nbuffers being free()d twice, and this issue could have potentially been\ntriggered remotely by a VPN peer (CVE-2017-7521).\n","status":"published","published":"2017-07-28T18:12:15Z","modified":"2026-04-16T06:23:39.550256709Z","updated_at":"2026-11-02T15:49:40.103088Z"}]}}
