{"id":"CVE-2019-17606","aliases":["EUVD-2022-3913","GHSA-g784-q3p3-26rm"],"status":"published","title":"hexo-admin plugin for Node.js XSS Vulnerability","description":"The Post editor functionality in the hexo-admin plugin versions 2.3.0 and earlier for Node.js is vulnerable to stored XSS via the content of a post.","severity":{"version":"3.1","score":6.1,"vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium","assessor":"primary","from":"nvd"},"epss":{"day":"2026-11-07","score":0.01035,"percentile":0.64086,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":false},"cwes":["CWE-79"],"published":"2019-10-23T16:18:14Z","modified":"2026-10-20T10:51:38Z","affected":[{"source":"ghsa","ecosystem":"npm","package":"hexo-admin","ranges":[{"type":"ECOSYSTEM","events":[{"introduced":"0"},{"last_affected":"2.3.0"}]}]},{"source":"osv","ecosystem":"npm","package":"hexo-admin","ranges":[{"type":"SEMVER","events":[{"introduced":"0"},{"last_affected":"2.3.0"}]}]}],"products":[{"vendor":"hexo-admin_project","product":"hexo-admin"}],"references":[{"url":"https://github.com/jaredly/hexo-admin/commits/master","tags":["x_refsource_MISC","x_transferred","Patch","Third Party Advisory","fix"]},{"url":"https://www.npmjs.com/advisories","tags":["x_refsource_MISC","x_transferred","Third Party Advisory","advisory"]},{"url":"https://mega.nz/#%218MYnUQzC%21ZCqixrGyHdBhimCmrszSXdFmI2feImhuZZMcnplNBQQ","tags":["x_refsource_MISC","x_transferred","web"]},{"url":"https://www.npmjs.com/advisories/1211","tags":["x_refsource_CONFIRM","x_transferred","Third Party Advisory","advisory"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2019-17606","tags":["advisory"]},{"url":"https://github.com/jaredly/hexo-admin/issues/185","tags":["web"]},{"url":"https://github.com/418sec/hexo-admin/pull/2","tags":["web"]},{"url":"https://github.com/jaredly/hexo-admin/pull/203","tags":["web"]},{"url":"https://github.com/advisories/GHSA-g784-q3p3-26rm"},{"url":"https://github.com/jaredly/hexo-admin","tags":["package"]}],"sources":{"cve":[{"id":"CVE-2019-17606","description":"The Post editor functionality in the hexo-admin plugin versions 2.3.0 and earlier for Node.js is vulnerable to stored XSS via the content of a post.","status":"published","published":"2019-10-23T16:18:14Z","modified":"2024-08-05T01:47:13.203Z","updated_at":"2026-11-02T14:20:24.678649Z"}],"euvd":[{"id":"EUVD-2022-3913","description":"The Post editor functionality in the hexo-admin plugin versions 2.3.0 and earlier for Node.js is vulnerable to stored XSS via the content of a post.","status":"published","published":"2019-10-23T16:18:14Z","modified":"2024-08-05T01:47:13Z","updated_at":"2026-11-03T02:40:28.860423Z"}],"ghsa":[{"id":"GHSA-g784-q3p3-26rm","title":"hexo-admin plugin for Node.js XSS Vulnerability","description":"The Post editor functionality in the hexo-admin plugin versions 2.3.0 and earlier for Node.js is vulnerable to stored XSS via the content of a post.","status":"published","published":"2022-05-24T16:59:45Z","modified":"2023-09-26T16:55:02Z","cvss":[{"version":"3.1","score":6.1,"vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:37:06.234371Z"}],"nvd":[{"id":"CVE-2019-17606","description":"The Post editor functionality in the hexo-admin plugin versions 2.3.0 and earlier for Node.js is vulnerable to stored XSS via the content of a post.","status":"published","published":"2019-10-23T17:15:12.91Z","modified":"2026-06-17T02:24:16.32Z","cvss":[{"version":"3.1","score":6.1,"vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium","assessor":"primary"},{"version":"2.0","score":4.3,"vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","level":"medium","assessor":"primary"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T14:05:32.982925Z"}],"osv":[{"id":"CVE-2019-17606","description":"The Post editor functionality in the hexo-admin plugin versions 2.3.0 and earlier for Node.js is vulnerable to stored XSS via the content of a post.","status":"published","published":"2019-10-23T17:15:12.91Z","modified":"2026-10-20T10:51:38.2634362Z","cvss":[{"version":"3.1","score":6.1,"vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium"}],"updated_at":"2026-11-02T15:44:11.673963Z"},{"id":"GHSA-g784-q3p3-26rm","title":"hexo-admin plugin for Node.js XSS Vulnerability","description":"The Post editor functionality in the hexo-admin plugin versions 2.3.0 and earlier for Node.js is vulnerable to stored XSS via the content of a post.","status":"published","published":"2022-05-24T16:59:45Z","modified":"2023-11-08T04:01:25.107723Z","cvss":[{"version":"3.1","score":6.1,"vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","level":"medium"}],"cwes":["CWE-79"],"updated_at":"2026-11-02T15:46:47.472172Z"}]}}
