{"id":"CVE-2024-1978","aliases":["EUVD-2024-17695","GHSA-xq36-jhc6-fxw2"],"status":"published","title":"Friends \u003c= 2.8.5 - Authenticated (Admin+) Blind Server-Side Request Forgery","description":"The Friends plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.8.5 via the discover_available_feeds function. This makes it possible for authenticated attackers, with administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.","severity":{"version":"3.1","score":5.5,"vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N","level":"medium","assessor":"cna","from":"cve"},"epss":{"day":"2026-11-08","score":0.00459,"percentile":0.4002,"model":"v2026.06.15"},"facts":{"in_kev":false,"known_exploited":false,"public_exploit":false,"fix_available":false},"cwes":["CWE-918"],"published":"2024-02-29T06:47:57Z","modified":"2026-10-28T02:31:11Z","products":[{"vendor":"akirk","product":"friends"},{"vendor":"alex.kirk","product":"friends"}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/72e1fbce-86ae-4518-a613-7c322193acf4?source=cve","tags":["x_transferred","Third Party Advisory","web"]},{"url":"https://github.com/akirk/friends/pull/290","tags":["x_transferred","Patch","fix"]},{"url":"https://plugins.trac.wordpress.org/changeset?sfp_email=\u0026sfph_mail=\u0026reponame=\u0026old=3036987%40friends\u0026new=3036987%40friends\u0026sfp_email=\u0026sfph_mail=","tags":["x_transferred","Patch","web"]},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2024-1978","tags":["advisory"]},{"url":"https://github.com/advisories/GHSA-xq36-jhc6-fxw2"},{"url":"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/1xxx/CVE-2024-1978.json","tags":["advisory"]}],"sources":{"cve":[{"id":"CVE-2024-1978","title":"Friends \u003c= 2.8.5 - Authenticated (Admin+) Blind Server-Side Request Forgery","description":"The Friends plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.8.5 via the discover_available_feeds function. This makes it possible for authenticated attackers, with administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.","status":"published","published":"2024-02-29T06:47:57.113Z","modified":"2026-04-08T17:00:51.515Z","cvss":[{"version":"3.1","score":5.5,"vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N","level":"medium","assessor":"cna"}],"cwes":["CWE-918"],"updated_at":"2026-11-02T14:34:18.259965Z"}],"euvd":[{"id":"EUVD-2024-17695","description":"The Friends plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.8.5 via the discover_available_feeds function. This makes it possible for authenticated attackers, with administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.","status":"published","published":"2024-02-29T06:47:57Z","modified":"2026-04-08T17:00:51Z","cvss":[{"version":"3.1","score":5.5,"vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N","level":"medium"}],"updated_at":"2026-11-02T19:24:53.902095Z"}],"ghsa":[{"id":"GHSA-xq36-jhc6-fxw2","title":"The Friends plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up...","description":"The Friends plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.8.5 via the discover_available_feeds function. This makes it possible for authenticated attackers, with administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.","status":"published","published":"2024-02-29T09:30:34Z","modified":"2025-01-16T21:32:00Z","cvss":[{"version":"3.1","score":5.5,"vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N","level":"medium"}],"cwes":["CWE-918"],"updated_at":"2026-11-02T14:59:35.190753Z"}],"nvd":[{"id":"CVE-2024-1978","description":"The Friends plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.8.5 via the discover_available_feeds function. This makes it possible for authenticated attackers, with administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.","status":"published","published":"2024-02-29T07:15:06.603Z","modified":"2026-06-17T07:05:33.83Z","cvss":[{"version":"3.1","score":5.5,"vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N","level":"medium","assessor":"secondary"}],"cwes":["CWE-918"],"updated_at":"2026-11-02T14:09:38.473056Z"}],"osv":[{"id":"CVE-2024-1978","title":"Friends \u003c= 2.8.5 - Authenticated (Admin+) Blind Server-Side Request Forgery","description":"The Friends plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.8.5 via the discover_available_feeds function. This makes it possible for authenticated attackers, with administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.","status":"published","published":"2024-02-29T06:47:57.113Z","modified":"2026-10-28T02:31:11.993626042Z","cvss":[{"version":"3.1","score":5.5,"vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N","level":"medium"}],"cwes":["CWE-918"],"updated_at":"2026-11-02T15:44:37.917085Z"}]}}
