CVE-2016-2537
Regular Expression Denial of Service in is-my-json-valid
The is-my-json-valid package before 2.12.4 for Node.js has an incorrect exports['utc-millisec'] regular expression, which allows remote attackers to cause a denial of service (blocked event loop) via a crafted string.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
The is-my-json-valid package before 2.12.4 for Node.js has an incorrect exports['utc-millisec'] regular expression, which allows remote attackers to cause a denial of service (blocked event loop) via a crafted string.
- Record
CVE-2016-2537- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
The is-my-json-valid package before 2.12.4 for Node.js has an incorrect exports['utc-millisec'] regular expression, which allows remote attackers to cause a denial of service (blocked event loop) via a crafted string.
- Record
CVE-2016-2537- Updated
- 2026-11-02
EUVDEUVD-2017-0222 No score
The is-my-json-valid package before 2.12.4 for Node.js has an incorrect exports['utc-millisec'] regular expression, which allows remote attackers to cause a denial of service (blocked event loop) via a crafted string.
- Record
EUVD-2017-0222- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f522-ffg8-j8r6
7.5
Regular Expression Denial of Service in is-my-json-valid
Version of is-my-json-valid before 2.12.4 are vulnerable to regular expression denial of service (ReDoS) via the email validation function.
Recommendation
Update to version 2.12.4 or later.
- Record
GHSA-f522-ffg8-j8r6- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-1333
- Updated
- 2026-11-02
OSV
7.5
The is-my-json-valid package before 2.12.4 for Node.js has an incorrect exports['utc-millisec'] regular expression, which allows remote attackers to cause a denial of service (blocked event loop) via a crafted string.
- Record
CVE-2016-2537- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-f522-ffg8-j8r6
7.5
Regular Expression Denial of Service in is-my-json-valid
Version of is-my-json-valid before 2.12.4 are vulnerable to regular expression denial of service (ReDoS) via the email validation function.
Recommendation
Update to version 2.12.4 or later.
- Record
GHSA-f522-ffg8-j8r6- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-1333
- Updated
- 2026-11-02
OSVCLSA-2026-1773015272 No score
TuxCare security update for is-my-json-valid (2 CVEs)
TuxCare rebuilt is-my-json-valid to address 2 CVEs. Fixed in 2.12.2-tuxcare.1.
- Record
CLSA-2026-1773015272- Updated
- 2026-11-02
OSVCLSA-2026-1773793045 No score
TuxCare security update for is-my-json-valid (2 CVEs)
TuxCare rebuilt is-my-json-valid to address 2 CVEs. Fixed in 2.10.1-tuxcare.1.
- Record
CLSA-2026-1773793045- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
is-my-json-validnpm |
before 2.12.4 | 2.12.4 |
is-my-json-validTuxCare:npm From an advisory covering 2 CVEs |
2.12.2-tuxcare.0 up to 2.12.2-tuxcare.1, plus listed versions 2.12.2 |
2.12.2-tuxcare.1 |
is-my-json-validTuxCare:npm From an advisory covering 2 CVEs |
2.10.1-tuxcare.0 up to 2.10.1-tuxcare.1, plus listed versions 2.10.1 |
2.10.1-tuxcare.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-2537 is a high vulnerability (CVSS 7.5) in Is My Json Valid Project My Json Valid, published February 23, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.85%, the 79th percentile. Fixed in is-my-json-valid 2.12.4.
References
nodesecurity.io/advisories/76
github.com/mafintosh/is-my-json-valid/commit/eca4beb21e61877d76fdf6bea771f72f39544d9b
nvd.nist.gov/vuln/detail/CVE-2016-2537
github.com/mafintosh/is-my-json-valid/pull/159
github.com/mafintosh/is-my-json-valid/commit/b3051b277f7caa08cd2edc6f74f50aeda65d2976
github.com/advisories/GHSA-f522-ffg8-j8r6