Every CVE Search/ Get API key

CVE-2000-1219

The -ftrapv compiler option in gcc and g++ 3.3.3 and earlier does not handle all types of integer...

7.5 HighFix available

The -ftrapv compiler option in gcc and g++ 3.3.3 and earlier does not handle all types of integer overflows, which may leave applications vulnerable to vulnerabilities related to overflows.

Exploit likelihood

1.36%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The -ftrapv compiler option in gcc and g++ 3.3.3 and earlier does not handle all types of integer overflows, which may leave applications vulnerable to vulnerabilities related to overflows.

Record
CVE-2000-1219
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

The -ftrapv compiler option in gcc and g++ 3.3.3 and earlier does not handle all types of integer overflows, which may leave applications vulnerable to vulnerabilities related to overflows.

Record
CVE-2000-1219
Updated
2026-11-02
EUVDEUVD-2000-1201 No score

The -ftrapv compiler option in gcc and g++ 3.3.3 and earlier does not handle all types of integer overflows, which may leave applications vulnerable to vulnerabilities related to overflows.

Record
EUVD-2000-1201
Updated
2026-11-03
GitHub AdvisoriesGHSA-wp4f-j236-w785 No score

The -ftrapv compiler option in gcc and g++ 3.3.3 and earlier does not handle all types of integer...

The -ftrapv compiler option in gcc and g++ 3.3.3 and earlier does not handle all types of integer overflows, which may leave applications vulnerable to vulnerabilities related to overflows.

Record
GHSA-wp4f-j236-w785
Updated
2026-11-02
OSV No score

The -ftrapv compiler option in gcc and g++ 3.3.3 and earlier does not handle all types of integer overflows, which may leave applications vulnerable to vulnerabilities related to overflows.

Record
CVE-2000-1219
Updated
2026-11-02
OSVDEBIAN-CVE-2000-1219 No score

The -ftrapv compiler option in gcc and g++ 3.3.3 and earlier does not handle all types of integer overflows, which may leave applications vulnerable to vulnerabilities related to overflows.

Record
DEBIAN-CVE-2000-1219
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gcc-3.3
Debian:12
before 1:3.3.4-1
1:3.3.4-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2000-1219 is a high vulnerability (CVSS 7.5) in Gnu Gcc, published November 1, 2000. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.36%, the 71st percentile. Fixed in gcc-3.3 1:3.3.4-1.

References

MoveEnter Open