Every CVE Search/ Get API key

CVE-2002-0170

Zope does not properly verify the access for objects with proxy roles

7.5 HighFix available

CVE-2002-0170 is a high vulnerability (CVSS 7.5) in Zope, published April 22, 2002. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.58%, the 75th percentile. Fixed in zope 2.4.4.

Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy roles, which could allow some users to access documents in violation of the intended configuration.

Exploit likelihood

1.58%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy roles, which could allow some users to access documents in violation of the intended configuration.

Record
CVE-2002-0170
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy roles, which could allow some users to access documents in violation of the intended configuration.

Record
CVE-2002-0170
Updated
2026-11-02
EUVDEUVD-2022-1701 No score

Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy roles, which could allow some users to access documents in violation of the intended configuration.

Record
EUVD-2022-1701
Updated
2026-11-03
GitHub AdvisoriesGHSA-c3rp-4cjh-cp38 No score

Zope does not properly verify the access for objects with proxy roles

Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy roles, which could allow some users to access documents in violation of the intended configuration.

Record
GHSA-c3rp-4cjh-cp38
Weakness
CWE-284
Updated
2026-11-02
OSVGHSA-c3rp-4cjh-cp38 No score

Zope does not properly verify the access for objects with proxy roles

Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy roles, which could allow some users to access documents in violation of the intended configuration.

Record
GHSA-c3rp-4cjh-cp38
Weakness
CWE-284
Updated
2026-11-02
OSVPYSEC-2026-758 No score

Zope does not properly verify the access for objects with proxy roles

Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy roles, which could allow some users to access documents in violation of the intended configuration.

Record
PYSEC-2026-758
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zope
PyPI
2.2.0 up to 2.4.4
2.4.4
zope
PyPI
2.5.0 up to 2.5.1
2.5.1
zope
PyPI
2.2.0 up to 2.4.4, 2.5.0 up to 2.5.1
2.4.42.5.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 8 moreShow less
MoveEnter Open