Every CVE Search/ Get API key

CVE-2002-0687

Zope Server vulnerable to DoS via header injection

5.0 MediumFix available

The "through the web code" capability for Zope 2.0 through 2.5.1 b1 allows untrusted users to shut down the Zope server via certain headers.

Exploit likelihood

1.48%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The "through the web code" capability for Zope 2.0 through 2.5.1 b1 allows untrusted users to shut down the Zope server via certain headers.

Record
CVE-2002-0687
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

The "through the web code" capability for Zope 2.0 through 2.5.1 b1 allows untrusted users to shut down the Zope server via certain headers.

Record
CVE-2002-0687
Updated
2026-11-02
EUVDEUVD-2022-1845 No score

The "through the web code" capability for Zope 2.0 through 2.5.1 b1 allows untrusted users to shut down the Zope server via certain headers.

Record
EUVD-2022-1845
Updated
2026-11-03
GitHub AdvisoriesGHSA-vwrc-g9q6-f675 No score

Zope Server vulnerable to DoS via header injection

Zope is a Web application server for Linux. Zope versions 2.0 through 2.5.1 b1 are vulnerable to a denial of service attack, caused by a vulnerability that occurs when using the "through the Web code" capability. A remote attacker could inject malicious headers into a response to cause the vulnerable system to crash.

Record
GHSA-vwrc-g9q6-f675
Weakness
CWE-400
Updated
2026-11-02
OSVGHSA-vwrc-g9q6-f675 No score

Zope Server vulnerable to DoS via header injection

Zope is a Web application server for Linux. Zope versions 2.0 through 2.5.1 b1 are vulnerable to a denial of service attack, caused by a vulnerability that occurs when using the "through the Web code" capability. A remote attacker could inject malicious headers into a response to cause the vulnerable system to crash.

Record
GHSA-vwrc-g9q6-f675
Weakness
CWE-400
Updated
2026-11-02
OSVPYSEC-2026-761 No score

Zope Server vulnerable to DoS via header injection

Zope is a Web application server for Linux. Zope versions 2.0 through 2.5.1 b1 are vulnerable to a denial of service attack, caused by a vulnerability that occurs when using the "through the Web code" capability. A remote attacker could inject malicious headers into a response to cause the vulnerable system to crash.

Record
PYSEC-2026-761
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zope
PyPI
2.0.0 up to 2.4.4b2
2.4.4b2
zope
PyPI
2.5.0 up to 2.5.1b2
2.5.1b2
zope
PyPI
2.0.0 up to 2.4.4b2, 2.5.0 up to 2.5.1b2
2.4.4b22.5.1b2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2002-0687 is a medium vulnerability (CVSS 5.0) in Zope, published July 23, 2002. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.48%, the 73rd percentile. Fixed in zope 2.4.4b2.

References

Show 7 moreShow less
MoveEnter Open