Every CVE Search/ Get API key

CVE-2002-0688

ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions

7.5 HighFix available

ZCatalog plug-in index support capability for Zope 2.4.0 through 2.5.1 allows anonymous users and untrusted code to bypass access restrictions and call arbitrary methods of catalog indexes.

Exploit likelihood

1.44%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

ZCatalog plug-in index support capability for Zope 2.4.0 through 2.5.1 allows anonymous users and untrusted code to bypass access restrictions and call arbitrary methods of catalog indexes.

Record
CVE-2002-0688
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

ZCatalog plug-in index support capability for Zope 2.4.0 through 2.5.1 allows anonymous users and untrusted code to bypass access restrictions and call arbitrary methods of catalog indexes.

Record
CVE-2002-0688
Updated
2026-11-02
EUVDEUVD-2022-1662 No score

ZCatalog plug-in index support capability for Zope 2.4.0 through 2.5.1 allows anonymous users and untrusted code to bypass access restrictions and call arbitrary methods of catalog indexes.

Record
EUVD-2022-1662
Updated
2026-11-03
GitHub AdvisoriesGHSA-7944-h5rw-qmjx No score

ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions

ZCatalog plug-in index support capability for Zope 2.4.0 through 2.5.1 allows anonymous users and untrusted code to bypass access restrictions and call arbitrary methods of catalog indexes.

Record
GHSA-7944-h5rw-qmjx
Updated
2026-11-02
OSVGHSA-7944-h5rw-qmjx No score

ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions

ZCatalog plug-in index support capability for Zope 2.4.0 through 2.5.1 allows anonymous users and untrusted code to bypass access restrictions and call arbitrary methods of catalog indexes.

Record
GHSA-7944-h5rw-qmjx
Updated
2026-11-02
OSVPYSEC-2026-755 No score

ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions

ZCatalog plug-in index support capability for Zope 2.4.0 through 2.5.1 allows anonymous users and untrusted code to bypass access restrictions and call arbitrary methods of catalog indexes.

Record
PYSEC-2026-755
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zope
PyPI
2.4.0 to 2.5.1
2.6.0
zope
Debian:3.0
before 2.5.1-1woody1
2.5.1-1woody1
zope
PyPI
2.4.0 up to 2.6.0
2.6.0

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2002-0688 is a high vulnerability (CVSS 7.5) in Zope, published July 23, 2002. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.44%, the 73rd percentile. Fixed in zope 2.6.0.

References

Show 7 moreShow less
MoveEnter Open