CVE-2002-0844
Off-by-one overflow in the CVS PreservePermissions of rcs.c for CVSD before 1.11.2 allows local...
CVE-2002-0844 is a high vulnerability (CVSS 7.8) in Distrotech Cvs, published August 12, 2002. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.65%, the 51st percentile. Fixed in cvs 1:1.11.2.
Off-by-one overflow in the CVS PreservePermissions of rcs.c for CVSD before 1.11.2 allows local users to execute arbitrary code.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
Off-by-one overflow in the CVS PreservePermissions of rcs.c for CVSD before 1.11.2 allows local users to execute arbitrary code.
- Record
CVE-2002-0844- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 4.6 Medium
AV:L/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-193
- Updated
- 2026-11-02
CVE List No score
Off-by-one overflow in the CVS PreservePermissions of rcs.c for CVSD before 1.11.2 allows local users to execute arbitrary code.
- Record
CVE-2002-0844- Updated
- 2026-11-02
EUVDEUVD-2002-0836 No score
Off-by-one overflow in the CVS PreservePermissions of rcs.c for CVSD before 1.11.2 allows local users to execute arbitrary code.
- Record
EUVD-2002-0836- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-g4rc-px2p-4hv3 No score
Off-by-one overflow in the CVS PreservePermissions of rcs.c for CVSD before 1.11.2 allows local...
Off-by-one overflow in the CVS PreservePermissions of rcs.c for CVSD before 1.11.2 allows local users to execute arbitrary code.
- Record
GHSA-g4rc-px2p-4hv3- Updated
- 2026-11-02
OSV
7.8
Off-by-one overflow in the CVS PreservePermissions of rcs.c for CVSD before 1.11.2 allows local users to execute arbitrary code.
- Record
CVE-2002-0844- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2002-0844
7.8
Off-by-one overflow in the CVS PreservePermissions of rcs.c for CVSD before 1.11.2 allows local users to execute arbitrary code.
- Record
DEBIAN-CVE-2002-0844- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
cvsDebian:12 |
before 1:1.11.2 | 1:1.11.2 |
cvsDebian:13 |
before 1:1.11.2 | 1:1.11.2 |
cvsDebian:14 |
before 1:1.11.2 | 1:1.11.2 |
cvsRed Hat:enterprise_linux:3::as |
before 0:1.11.2-14 | 0:1.11.2-14 |
cvsRed Hat:enterprise_linux:3::desktop |
before 0:1.11.2-14 | 0:1.11.2-14 |
cvsRed Hat:enterprise_linux:3::es |
before 0:1.11.2-14 | 0:1.11.2-14 |
cvsRed Hat:enterprise_linux:3::ws |
before 0:1.11.2-14 | 0:1.11.2-14 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
redhat.com/support/errata/RHSA-2004-004.html
archives.neohapsis.com/archives/vulnwatch/2002-q2/0081.html
exchange.xforce.ibmcloud.com/vulnerabilities/9175
securityfocus.com/bid/4829
marc.info?l=bugtraq&m=102233767925177&w=2
nvd.nist.gov/vuln/detail/CVE-2002-0844
Show 13 moreShow less
github.com/advisories/GHSA-g4rc-px2p-4hv3
security-tracker.debian.org/tracker/CVE-2002-0844
access.redhat.com/errata/RHSA-2004:004
access.redhat.com/security/updates/classification
ccvs.cvshome.org/servlets/NewsItemView?newsID=84
security.access.redhat.com/data/csaf/v2/advisories/2004/rhsa-2004_004.json
access.redhat.com/security/cve/CVE-2002-0844
bugzilla.redhat.com/show_bug.cgi?id=1616825
cve.org/CVERecord?id=CVE-2002-0844
access.redhat.com/security/cve/CVE-2003-0977
bugzilla.redhat.com/show_bug.cgi?id=1617113
cve.org/CVERecord?id=CVE-2003-0977
nvd.nist.gov/vuln/detail/CVE-2003-0977