Every CVE Search/ Get API key

CVE-2002-0984

The IRC script included in Light 2.7.x before 2.7.30p5, and 2.8.x before 2.8pre10, running EPIC...

7.5 HighFix available

The IRC script included in Light 2.7.x before 2.7.30p5, and 2.8.x before 2.8pre10, running EPIC allows remote attackers to execute arbitrary code if the user joins a channel whose topic includes EPIC4 code.

Exploit likelihood

3.74%Down 2.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The IRC script included in Light 2.7.x before 2.7.30p5, and 2.8.x before 2.8pre10, running EPIC allows remote attackers to execute arbitrary code if the user joins a channel whose topic includes EPIC4 code.

Record
CVE-2002-0984
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

The IRC script included in Light 2.7.x before 2.7.30p5, and 2.8.x before 2.8pre10, running EPIC allows remote attackers to execute arbitrary code if the user joins a channel whose topic includes EPIC4 code.

Record
CVE-2002-0984
Updated
2026-11-02
EUVDEUVD-2002-0973 No score

The IRC script included in Light 2.7.x before 2.7.30p5, and 2.8.x before 2.8pre10, running EPIC allows remote attackers to execute arbitrary code if the user joins a channel whose topic includes EPIC4 code.

Record
EUVD-2002-0973
Updated
2026-11-03
GitHub AdvisoriesGHSA-jhj6-m7gv-vv45 No score

The IRC script included in Light 2.7.x before 2.7.30p5, and 2.8.x before 2.8pre10, running EPIC...

The IRC script included in Light 2.7.x before 2.7.30p5, and 2.8.x before 2.8pre10, running EPIC allows remote attackers to execute arbitrary code if the user joins a channel whose topic includes EPIC4 code.

Record
GHSA-jhj6-m7gv-vv45
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
epic4-script-light
Debian:3.0
before 2.7.30p5-1.1
2.7.30p5-1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2002-0984 is a high vulnerability (CVSS 7.5) in Light, published August 22, 2002. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.74%, the 89th percentile. Fixed in epic4-script-light 2.7.30p5-1.1.

References

MoveEnter Open