Every CVE Search/ Get API key

CVE-2002-1151

The cross-site scripting protection for Konqueror in KDE 2.2.2 and 3.0 through 3.0.3 does not...

7.5 HighFix available

CVE-2002-1151 is a high vulnerability (CVSS 7.5) in Kde, published September 16, 2002. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.59%, the 89th percentile. Fixed in kdelibs 4:2.2.2-13.woody.3.

The cross-site scripting protection for Konqueror in KDE 2.2.2 and 3.0 through 3.0.3 does not properly initialize the domains on sub-frames and sub-iframes, which can allow remote attackers to execute script and steal cookies from subframes that are in other domains.

Exploit likelihood

3.59%Up 1.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The cross-site scripting protection for Konqueror in KDE 2.2.2 and 3.0 through 3.0.3 does not properly initialize the domains on sub-frames and sub-iframes, which can allow remote attackers to execute script and steal cookies from subframes that are in other domains.

Record
CVE-2002-1151
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

The cross-site scripting protection for Konqueror in KDE 2.2.2 and 3.0 through 3.0.3 does not properly initialize the domains on sub-frames and sub-iframes, which can allow remote attackers to execute script and steal cookies from subframes that are in other domains.

Record
CVE-2002-1151
Updated
2026-11-02
EUVDEUVD-2002-1138 No score

The cross-site scripting protection for Konqueror in KDE 2.2.2 and 3.0 through 3.0.3 does not properly initialize the domains on sub-frames and sub-iframes, which can allow remote attackers to execute script and steal cookies from subframes that are in other domains.

Record
EUVD-2002-1138
Updated
2026-11-03
GitHub AdvisoriesGHSA-4f6c-7wr6-73p6 No score

The cross-site scripting protection for Konqueror in KDE 2.2.2 and 3.0 through 3.0.3 does not...

The cross-site scripting protection for Konqueror in KDE 2.2.2 and 3.0 through 3.0.3 does not properly initialize the domains on sub-frames and sub-iframes, which can allow remote attackers to execute script and steal cookies from subframes that are in other domains.

Record
GHSA-4f6c-7wr6-73p6
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
kdelibs
Debian:3.0
before 4:2.2.2-13.woody.3
4:2.2.2-13.woody.3

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 6 moreShow less
MoveEnter Open