Every CVE Search/ Get API key

CVE-2002-1159

Canna 3.6 and earlier does not properly validate requests, which allows remote attackers to cause...

6.4 MediumFix available

Canna 3.6 and earlier does not properly validate requests, which allows remote attackers to cause a denial of service or information leak.

Exploit likelihood

1.90%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.4

Canna 3.6 and earlier does not properly validate requests, which allows remote attackers to cause a denial of service or information leak.

Record
CVE-2002-1159
CVSS 2.0
6.4 MediumAV:N/AC:L/Au:N/C:P/I:N/A:P
Updated
2026-11-02
CVE List No score

Canna 3.6 and earlier does not properly validate requests, which allows remote attackers to cause a denial of service or information leak.

Record
CVE-2002-1159
Updated
2026-11-02
EUVDEUVD-2002-1146 No score

Canna 3.6 and earlier does not properly validate requests, which allows remote attackers to cause a denial of service or information leak.

Record
EUVD-2002-1146
Updated
2026-11-03
GitHub AdvisoriesGHSA-v63f-8cmr-47h8 No score

Canna 3.6 and earlier does not properly validate requests, which allows remote attackers to cause...

Canna 3.6 and earlier does not properly validate requests, which allows remote attackers to cause a denial of service or information leak.

Record
GHSA-v63f-8cmr-47h8
Updated
2026-11-02
OSV No score

Canna 3.6 and earlier does not properly validate requests, which allows remote attackers to cause a denial of service or information leak.

Record
CVE-2002-1159
Updated
2026-11-02
OSVDEBIAN-CVE-2002-1159 No score

Canna 3.6 and earlier does not properly validate requests, which allows remote attackers to cause a denial of service or information leak.

Record
DEBIAN-CVE-2002-1159
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
canna
Debian:12
before 3.6p1-1
3.6p1-1
canna
Debian:13
before 3.6p1-1
3.6p1-1
canna
Debian:14
before 3.6p1-1
3.6p1-1
canna
Debian:3.0
From an advisory covering 2 CVEs
before 3.5b2-46.2
3.5b2-46.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2002-1159 is a medium vulnerability (CVSS 6.4) in Canna, published December 18, 2002. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.90%, the 79th percentile. Fixed in canna 3.6p1-1.

References

Show 4 moreShow less
MoveEnter Open