Every CVE Search/ Get API key

CVE-2002-1235

The kadm_ser_in function in (1) the Kerberos v4compatibility administration daemon (kadmind4) in...

10.0 HighFix available

The kadm_ser_in function in (1) the Kerberos v4compatibility administration daemon (kadmind4) in the MIT Kerberos 5 (krb5) krb5-1.2.6 and earlier, (2) kadmind in KTH Kerberos 4 (eBones) before 1.2.1, and (3) kadmind in KTH Kerberos 5 (Heimdal) before 0.5.1 when compiled with Kerberos 4 support, does not properly verify the length field of a request, which allows remote attackers to execute arbitrary code via a buffer overflow attack.

Exploit likelihood

15.1%Up 2.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

The kadm_ser_in function in (1) the Kerberos v4compatibility administration daemon (kadmind4) in the MIT Kerberos 5 (krb5) krb5-1.2.6 and earlier, (2) kadmind in KTH Kerberos 4 (eBones) before 1.2.1, and (3) kadmind in KTH Kerberos 5 (Heimdal) before 0.5.1 when compiled with Kerberos 4 support, does not properly verify the length field of a request, which allows remote attackers to execute arbitrary code via a buffer overflow attack.

Record
CVE-2002-1235
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

The kadm_ser_in function in (1) the Kerberos v4compatibility administration daemon (kadmind4) in the MIT Kerberos 5 (krb5) krb5-1.2.6 and earlier, (2) kadmind in KTH Kerberos 4 (eBones) before 1.2.1, and (3) kadmind in KTH Kerberos 5 (Heimdal) before 0.5.1 when compiled with Kerberos 4 support, does not properly verify the length field of a request, which allows remote attackers to execute arbitrary code via a buffer overflow attack.

Record
CVE-2002-1235
Updated
2026-11-02
EUVDEUVD-2002-1219 No score

The kadm_ser_in function in (1) the Kerberos v4compatibility administration daemon (kadmind4) in the MIT Kerberos 5 (krb5) krb5-1.2.6 and earlier, (2) kadmind in KTH Kerberos 4 (eBones) before 1.2.1, and (3) kadmind in KTH Kerberos 5 (Heimdal) before 0.5.1 when compiled with Kerberos 4 support, does not properly verify the length field of a request, which allows remote attackers to execute arbitrary code via a buffer overflow attack.

Record
EUVD-2002-1219
Updated
2026-11-03
GitHub AdvisoriesGHSA-r4jv-xp6w-68qp No score

The kadm_ser_in function in (1) the Kerberos v4compatibility administration daemon (kadmind4) in...

The kadm_ser_in function in (1) the Kerberos v4compatibility administration daemon (kadmind4) in the MIT Kerberos 5 (krb5) krb5-1.2.6 and earlier, (2) kadmind in KTH Kerberos 4 (eBones) before 1.2.1, and (3) kadmind in KTH Kerberos 5 (Heimdal) before 0.5.1 when compiled with Kerberos 4 support, does not properly verify the length field of a request, which allows remote attackers to execute arbitrary code via a buffer overflow attack.

Record
GHSA-r4jv-xp6w-68qp
Updated
2026-11-02
OSV No score

The kadm_ser_in function in (1) the Kerberos v4compatibility administration daemon (kadmind4) in the MIT Kerberos 5 (krb5) krb5-1.2.6 and earlier, (2) kadmind in KTH Kerberos 4 (eBones) before 1.2.1, and (3) kadmind in KTH Kerberos 5 (Heimdal) before 0.5.1 when compiled with Kerberos 4 support, does not properly verify the length field of a request, which allows remote attackers to execute arbitrary code via a buffer overflow attack.

Record
CVE-2002-1235
Updated
2026-11-02
OSVDEBIAN-CVE-2002-1235 No score

The kadm_ser_in function in (1) the Kerberos v4compatibility administration daemon (kadmind4) in the MIT Kerberos 5 (krb5) krb5-1.2.6 and earlier, (2) kadmind in KTH Kerberos 4 (eBones) before 1.2.1, and (3) kadmind in KTH Kerberos 5 (Heimdal) before 0.5.1 when compiled with Kerberos 4 support, does not properly verify the length field of a request, which allows remote attackers to execute arbitrary code via a buffer overflow attack.

Record
DEBIAN-CVE-2002-1235
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
heimdal
Debian:12
before 0.4e-22
0.4e-22
heimdal
Debian:13
before 0.4e-22
0.4e-22
heimdal
Debian:14
before 0.4e-22
0.4e-22
krb5
Debian:12
before 1.2.6-2
1.2.6-2
krb5
Debian:13
before 1.2.6-2
1.2.6-2
krb5
Debian:14
before 1.2.6-2
1.2.6-2
krb5
Debian:3.0
before 1.2.4-5woody3
1.2.4-5woody3
krb4
Debian:3.0
before 1.1-8-2.2, plus listed versions
0.9.9-20.9.9-30.9.9-41.0-21.0-2.21.0-2.31.1-8-2
1.1-8-2.2
heimdal
Debian:3.0
before 0.4e-7.woody.5, plus listed versions
0.2l-70.2l-7.60.4e-7.woody.1
0.4e-7.woody.5

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2002-1235 is a high vulnerability (CVSS 10.0) in Kth Kerberos 4, published October 25, 2002. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 15.1%, the 96th percentile. Fixed in heimdal 0.4e-22.

References

Show 15 moreShow less
MoveEnter Open