Every CVE Search/ Get API key

CVE-2002-1377

vim 6.0 and 6.1, and possibly other versions, allows attackers to execute arbitrary commands...

4.6 MediumFix available

CVE-2002-1377 is a medium vulnerability (CVSS 4.6) in Vim Development Group Vim, published December 23, 2002. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.47%, the 40th percentile. Fixed in vim 6.1.263-1.

vim 6.0 and 6.1, and possibly other versions, allows attackers to execute arbitrary commands using the libcall feature in modelines, which are not sandboxed but may be executed when vim is used to edit a malicious file, as demonstrated using mutt.

Exploit likelihood

0.47%Down 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.6

vim 6.0 and 6.1, and possibly other versions, allows attackers to execute arbitrary commands using the libcall feature in modelines, which are not sandboxed but may be executed when vim is used to edit a malicious file, as demonstrated using mutt.

Record
CVE-2002-1377
CVSS 2.0
4.6 MediumAV:L/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

vim 6.0 and 6.1, and possibly other versions, allows attackers to execute arbitrary commands using the libcall feature in modelines, which are not sandboxed but may be executed when vim is used to edit a malicious file, as demonstrated using mutt.

Record
CVE-2002-1377
Updated
2026-11-02
EUVDEUVD-2002-1361 No score

vim 6.0 and 6.1, and possibly other versions, allows attackers to execute arbitrary commands using the libcall feature in modelines, which are not sandboxed but may be executed when vim is used to edit a malicious file, as demonstrated using mutt.

Record
EUVD-2002-1361
Updated
2026-11-03
GitHub AdvisoriesGHSA-3g8f-84mq-ghvw No score

vim 6.0 and 6.1, and possibly other versions, allows attackers to execute arbitrary commands...

vim 6.0 and 6.1, and possibly other versions, allows attackers to execute arbitrary commands using the libcall feature in modelines, which are not sandboxed but may be executed when vim is used to edit a malicious file, as demonstrated using mutt.

Record
GHSA-3g8f-84mq-ghvw
Updated
2026-11-02
OSV No score

vim 6.0 and 6.1, and possibly other versions, allows attackers to execute arbitrary commands using the libcall feature in modelines, which are not sandboxed but may be executed when vim is used to edit a malicious file, as demonstrated using mutt.

Record
CVE-2002-1377
Updated
2026-11-02
OSVDEBIAN-CVE-2002-1377 No score

vim 6.0 and 6.1, and possibly other versions, allows attackers to execute arbitrary commands using the libcall feature in modelines, which are not sandboxed but may be executed when vim is used to edit a malicious file, as demonstrated using mutt.

Record
DEBIAN-CVE-2002-1377
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
vim
Debian:12
before 6.1.263-1
6.1.263-1
vim
Debian:13
before 6.1.263-1
6.1.263-1
vim
Debian:14
before 6.1.263-1
6.1.263-1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 7 moreShow less
MoveEnter Open