Every CVE Search/ Get API key

CVE-2003-0038

Mailman Cross-site scripting (XSS) vulnerability

4.3 MediumPublic exploitFix available

CVE-2003-0038 is a medium vulnerability (CVSS 4.3) in Gnu Mailman, published January 29, 2003. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 4.76%, the 91st percentile. Fixed in mailman 2.1.1.

Cross-site scripting (XSS) vulnerability in options.py for Mailman 2.1 allows remote attackers to inject script or HTML into web pages via the (1) email or (2) language parameters.

Exploit likelihood

4.76%Up 1.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in options.py for Mailman 2.1 allows remote attackers to inject script or HTML into web pages via the (1) email or (2) language parameters.

Record
CVE-2003-0038
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in options.py for Mailman 2.1 allows remote attackers to inject script or HTML into web pages via the (1) email or (2) language parameters.

Record
CVE-2003-0038
Updated
2026-11-02
EUVDEUVD-2022-1672 No score

Cross-site scripting (XSS) vulnerability in options.py for Mailman 2.1 allows remote attackers to inject script or HTML into web pages via the (1) email or (2) language parameters.

Record
EUVD-2022-1672
Updated
2026-11-03
GitHub AdvisoriesGHSA-82rm-28q9-435p No score

Mailman Cross-site scripting (XSS) vulnerability

Cross-site scripting (XSS) vulnerability in options.py for Mailman 2.1 allows remote attackers to inject script or HTML into web pages via the (1) email or (2) language parameters.

Record
GHSA-82rm-28q9-435p
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-82rm-28q9-435p No score

Mailman Cross-site scripting (XSS) vulnerability

Cross-site scripting (XSS) vulnerability in options.py for Mailman 2.1 allows remote attackers to inject script or HTML into web pages via the (1) email or (2) language parameters.

Record
GHSA-82rm-28q9-435p
Weakness
CWE-79
Updated
2026-11-02
OSVPYSEC-2026-657 No score

Mailman Cross-site scripting (XSS) vulnerability

Cross-site scripting (XSS) vulnerability in options.py for Mailman 2.1 allows remote attackers to inject script or HTML into web pages via the (1) email or (2) language parameters.

Record
PYSEC-2026-657
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mailman
PyPI
before 2.1.1
2.1.1
mailman
Debian:3.0
before 2.0.11-1woody7
2.0.11-1woody7
mailman
PyPI
before 2.1.1, plus listed versions
3.0.0b3-
2.1.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBGNU Mailman 2.1 - 'email' Cross-Site Scripting2003-01-24
Exploit-DBGNU Mailman 2.1 - Error Page Cross-Site Scripting2003-01-24

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

References

Show 4 moreShow less
MoveEnter Open