CVE-2003-0500
SQL injection vulnerability in the PostgreSQL authentication module (mod_sql_postgres) for...
SQL injection vulnerability in the PostgreSQL authentication module (mod_sql_postgres) for ProFTPD before 1.2.9rc1 allows remote attackers to execute arbitrary SQL and gain privileges by bypassing authentication or stealing passwords via the USER name.
Exploit likelihood
What each source reports
NVD Score used
10.0
SQL injection vulnerability in the PostgreSQL authentication module (mod_sql_postgres) for ProFTPD before 1.2.9rc1 allows remote attackers to execute arbitrary SQL and gain privileges by bypassing authentication or stealing passwords via the USER name.
- Record
CVE-2003-0500- CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Updated
- 2026-11-02
CVE List No score
SQL injection vulnerability in the PostgreSQL authentication module (mod_sql_postgres) for ProFTPD before 1.2.9rc1 allows remote attackers to execute arbitrary SQL and gain privileges by bypassing authentication or stealing passwords via the USER name.
- Record
CVE-2003-0500- Updated
- 2026-11-02
EUVDEUVD-2003-0494 No score
SQL injection vulnerability in the PostgreSQL authentication module (mod_sql_postgres) for ProFTPD before 1.2.9rc1 allows remote attackers to execute arbitrary SQL and gain privileges by bypassing authentication or stealing passwords via the USER name.
- Record
EUVD-2003-0494- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wggx-8v47-w9m4 No score
SQL injection vulnerability in the PostgreSQL authentication module (mod_sql_postgres) for...
SQL injection vulnerability in the PostgreSQL authentication module (mod_sql_postgres) for ProFTPD before 1.2.9rc1 allows remote attackers to execute arbitrary SQL and gain privileges by bypassing authentication or stealing passwords via the USER name.
- Record
GHSA-wggx-8v47-w9m4- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
proftpdDebian:3.0 |
before 1.2.4+1.2.5rc1-5woody2, plus listed versions 1.0.0-4bo1.11.2.0pre1-21.2.0pre10-2.0potato11.2.0pre10-2.0potato1.11.2.0pre9-41.2.4+1.2.5rc1-5 |
1.2.4+1.2.5rc1-5woody2 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | ProFTPd 1.2.9 RC1 - 'mod_sql' SQL Injection | 2003-06-19 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2003-0500 is a high vulnerability (CVSS 10.0) in Proftpd Project Proftpd, published June 29, 2003. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 18.3%, the 97th percentile. Fixed in proftpd 1.2.4+1.2.5rc1-5woody2.