Every CVE Search/ Get API key

CVE-2003-0550

The STP protocol, as enabled in Linux 2.4.x, does not provide sufficient security by design,...

5.0 MediumFix available

The STP protocol, as enabled in Linux 2.4.x, does not provide sufficient security by design, which allows attackers to modify the bridge topology.

Exploit likelihood

1.94%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The STP protocol, as enabled in Linux 2.4.x, does not provide sufficient security by design, which allows attackers to modify the bridge topology.

Record
CVE-2003-0550
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

The STP protocol, as enabled in Linux 2.4.x, does not provide sufficient security by design, which allows attackers to modify the bridge topology.

Record
CVE-2003-0550
Updated
2026-11-02
EUVDEUVD-2003-0544 No score

The STP protocol, as enabled in Linux 2.4.x, does not provide sufficient security by design, which allows attackers to modify the bridge topology.

Record
EUVD-2003-0544
Updated
2026-11-03
GitHub AdvisoriesGHSA-f29g-8qvj-p3hm No score

The STP protocol, as enabled in Linux 2.4.x, does not provide sufficient security by design,...

The STP protocol, as enabled in Linux 2.4.x, does not provide sufficient security by design, which allows attackers to modify the bridge topology.

Record
GHSA-f29g-8qvj-p3hm
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
kernel-source-2.4.18
Debian:3.0
before 2.4.18-11
2.4.18-11
kernel-image-2.4.18-1-i386
Debian:3.0
before 2.4.18-9
2.4.18-9
kernel-image-2.4.18-i386bf
Debian:3.0
before 2.4.18-5woody2, plus listed versions
2.4.18-5
2.4.18-5woody2
kernel-image-2.4.18-1-alpha
Debian:3.0
before 2.4.18-8
2.4.18-8
kernel-image-2.4.17-ia64
Debian:3.0
before kernel-image-2.4.17-ia64
kernel-image-2.4.17-ia64

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2003-0550 is a medium vulnerability (CVSS 5.0) in Redhat Linux, published July 25, 2003. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.94%, the 80th percentile. Fixed in kernel-source-2.4.18 2.4.18-11.

References

MoveEnter Open